diff options
author | Tuan Hoang <tuanhoanganh.dev@gmail.com> | 2019-02-24 12:05:44 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-02-24 08:07:53 -0800 |
commit | 0ad153f721ef99de585c4452a997a7104f45d71d (patch) | |
tree | aeb44d15e1d10ce28040deaa6f9ea886addad56a /meta-oe/recipes-devtools/octave | |
parent | 676a4c806c7abcbc3a48a70e8ac0abdac19362e1 (diff) | |
download | meta-openembedded-0ad153f721ef99de585c4452a997a7104f45d71d.tar.gz |
octave: add version 4.4.1
Signed-off-by: Hoang Anh Tuan <tuanha@viosoft.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/octave')
-rw-r--r-- | meta-oe/recipes-devtools/octave/files/fix-blas-library-integer-size.patch | 16 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/octave/octave_4.4.1.bb | 39 |
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/octave/files/fix-blas-library-integer-size.patch b/meta-oe/recipes-devtools/octave/files/fix-blas-library-integer-size.patch new file mode 100644 index 000000000..e89d7d346 --- /dev/null +++ b/meta-oe/recipes-devtools/octave/files/fix-blas-library-integer-size.patch | |||
@@ -0,0 +1,16 @@ | |||
1 | diff -Naur octave-4.4.1.orig/configure.ac octave-4.4.1/configure.ac | ||
2 | --- octave-4.4.1.orig/configure.ac 2019-02-23 10:46:24.287240571 +0000 | ||
3 | +++ octave-4.4.1/configure.ac 2019-02-23 10:46:42.255249333 +0000 | ||
4 | @@ -762,6 +762,12 @@ | ||
5 | AC_MSG_ERROR([BLAS and LAPACK libraries are required]) | ||
6 | fi | ||
7 | |||
8 | +if ac_fn_f77_try_run "$LINENO"; then : | ||
9 | + ax_blas_integer_size=8 | ||
10 | +else | ||
11 | + ax_blas_integer_size=4 | ||
12 | +fi | ||
13 | + | ||
14 | case $ax_blas_integer_size in | ||
15 | 4) | ||
16 | HAVE_64_BIT_BLAS=no | ||
diff --git a/meta-oe/recipes-devtools/octave/octave_4.4.1.bb b/meta-oe/recipes-devtools/octave/octave_4.4.1.bb new file mode 100644 index 000000000..c91556c76 --- /dev/null +++ b/meta-oe/recipes-devtools/octave/octave_4.4.1.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | DESCRIPTION = "High-level language, primarily intended for numerical computations" | ||
2 | HOMEPAGE = "http://www.gnu.org/software/octave/" | ||
3 | SECTION = "math" | ||
4 | |||
5 | LICENSE = "GPLv3" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464" | ||
7 | |||
8 | DEPENDS = "gperf-native texinfo lapack pcre readline" | ||
9 | |||
10 | inherit autotools pkgconfig texinfo gettext | ||
11 | |||
12 | EXTRA_OECONF = "--disable-java --disable-docs" | ||
13 | |||
14 | SRC_URI = "https://ftp.gnu.org/gnu/octave/${PN}-${PV}.tar.gz \ | ||
15 | file://fix-blas-library-integer-size.patch \ | ||
16 | " | ||
17 | |||
18 | SRC_URI[md5sum] = "b43bd5f4309a0c048c91af10cf8e8674" | ||
19 | SRC_URI[sha256sum] = "09fbd0f212f4ef21e53f1d9c41cf30ce3d7f9450fb44911601e21ed64c67ae97" | ||
20 | |||
21 | do_compile_prepend() { | ||
22 | for folder in "liboctave/operators liboctave/numeric liboctave/array liboctave/util"; do | ||
23 | mkdir -p ${B}/${folder} | ||
24 | done | ||
25 | } | ||
26 | |||
27 | PACKAGES =+ " octave-common liboctave liboctave-dev liboctave-dbg" | ||
28 | |||
29 | FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${datadir}/${PN} \ | ||
30 | ${libdir}/${PN}/${PV}/oct ${libdir}/${PN}/${PV}/site \ | ||
31 | ${libdir}/${PN}/site ${datadir}/applications ${datadir}/metainfo" | ||
32 | FILES_${PN}-common = "${datadir}/icons" | ||
33 | |||
34 | FILES_liboctave = "${libdir}/${PN}/${PV}/lib*${SOLIBS}" | ||
35 | FILES_liboctave-dev = "${libdir}/${PN}/${PV}/lib*${SOLIBSDEV}" | ||
36 | FILES_liboctave-dbg = "${libdir}/${PN}/${PV}/.debug" | ||
37 | |||
38 | FILES_${PN}-dbg = "${bindir}/.debug ${libdir}/${PN}/${PV}/oct/${TARGET_SYS}/.debug" | ||
39 | |||