diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2012-04-08 11:12:56 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-04-08 14:33:41 +0200 |
commit | d03ee17c2e40dcbbed9c6623f2e5169b4729f2e3 (patch) | |
tree | f92cac5f283ca9dd772fdcfc13cf8390ea218d2c /meta-oe/recipes-devtools/nodejs | |
parent | 9fb576a0d53d4bd511eee64f44d4ed187acdd83c (diff) | |
download | meta-openembedded-d03ee17c2e40dcbbed9c6623f2e5169b4729f2e3.tar.gz |
nodejs 0.6.x: update to 0.6.14
The LICENSE checksum changed due to date changes and clarification on licenses of included "libraries" like the markdown parser
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs')
-rw-r--r-- | meta-oe/recipes-devtools/nodejs/nodejs_0.6.14.bb (renamed from meta-oe/recipes-devtools/nodejs/nodejs_0.6.8.bb) | 22 |
1 files changed, 16 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.8.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.6.14.bb index bd404ae3a..4f85bf3ff 100644 --- a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.8.bb +++ b/meta-oe/recipes-devtools/nodejs/nodejs_0.6.14.bb | |||
@@ -1,21 +1,26 @@ | |||
1 | DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript" | 1 | DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript" |
2 | HOMEPAGE = "http://nodejs.org" | 2 | HOMEPAGE = "http://nodejs.org" |
3 | LICENSE = "MIT & BSD" | 3 | LICENSE = "MIT & BSD" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=672cc6c8dbb3e918277a61ea98f088f6" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d66c1f33ba9b89616e45f588e7606ee6" |
5 | |||
6 | DEFAULT_PREFERENCE = "-1" | ||
7 | 5 | ||
8 | DEPENDS = "openssl" | 6 | DEPENDS = "openssl" |
9 | 7 | ||
10 | SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz" | 8 | SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz" |
11 | SRC_URI[md5sum] = "9fd7baa2d27b848c3134e6ae35bb87b2" | 9 | SRC_URI[md5sum] = "3033a866e230cca64e212ee8f2af27dd" |
12 | SRC_URI[sha256sum] = "e6cbfc5ccdbe10128dbbd4dc7a88c154d80f8a39c3a8477092cf7d25eef78c9c" | 10 | SRC_URI[sha256sum] = "e41922308155c5197c2d048948ca9cd76ea5f9a51f977e1591bd93fe17d4cf1f" |
13 | 11 | ||
14 | S = "${WORKDIR}/node-v${PV}" | 12 | S = "${WORKDIR}/node-v${PV}" |
15 | 13 | ||
16 | # v8 errors out if you have set CCACHE | 14 | # v8 errors out if you have set CCACHE |
17 | CCACHE = "" | 15 | CCACHE = "" |
18 | 16 | ||
17 | do_configure_virtclass-native () { | ||
18 | sed -i -e s:\'/usr/lib:\'${STAGING_LIBDIR}:g wscript | ||
19 | sed -i -e s:\'/usr/local/lib:\'${STAGING_LIBDIR}:g wscript | ||
20 | |||
21 | ./configure --prefix=${prefix} --without-snapshot | ||
22 | } | ||
23 | |||
19 | # Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround waf+scons | 24 | # Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround waf+scons |
20 | do_configure () { | 25 | do_configure () { |
21 | echo '#!/bin/sh' > ${WORKDIR}/gcc | 26 | echo '#!/bin/sh' > ${WORKDIR}/gcc |
@@ -36,6 +41,10 @@ do_configure () { | |||
36 | ./configure --prefix=${prefix} --without-snapshot | 41 | ./configure --prefix=${prefix} --without-snapshot |
37 | } | 42 | } |
38 | 43 | ||
44 | do_compile_virtclass-native () { | ||
45 | make | ||
46 | } | ||
47 | |||
39 | do_compile () { | 48 | do_compile () { |
40 | export PATH=${WORKDIR}:${PATH} | 49 | export PATH=${WORKDIR}:${PATH} |
41 | export CC=gcc | 50 | export CC=gcc |
@@ -48,6 +57,7 @@ do_install () { | |||
48 | } | 57 | } |
49 | 58 | ||
50 | RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient " | 59 | RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient " |
60 | RDEPENDS_${PN}_virtclass-native = "curl-native python-native" | ||
51 | 61 | ||
52 | FILES_${PN} += "${libdir}/node/wafadmin" | 62 | FILES_${PN} += "${libdir}/node/wafadmin ${libdir}/node_modules" |
53 | BBCLASSEXTEND = "native" | 63 | BBCLASSEXTEND = "native" |