diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-14 19:04:44 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-14 21:19:11 +0100 |
commit | 6032d213fa6599678a4c737bc757785a7c35e382 (patch) | |
tree | 3a83a35c05217d30549282d0e4d7bf687aaf6289 /meta-oe/recipes-devtools/nodejs | |
parent | a49c995b40fafa45575554b1b842da012e9803c2 (diff) | |
download | meta-openembedded-6032d213fa6599678a4c737bc757785a7c35e382.tar.gz |
nodejs: add 0.6.1
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs')
-rw-r--r-- | meta-oe/recipes-devtools/nodejs/nodejs_0.6.1.bb | 53 |
1 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.6.1.bb new file mode 100644 index 0000000000..22a215b8c0 --- /dev/null +++ b/meta-oe/recipes-devtools/nodejs/nodejs_0.6.1.bb | |||
@@ -0,0 +1,53 @@ | |||
1 | DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript" | ||
2 | HOMEPAGE = "http://nodejs.org" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5c2b22818f53dbcb43dee3cb4daf7845" | ||
5 | |||
6 | DEFAULT_PREFERENCE = "-1" | ||
7 | |||
8 | DEPENDS = "openssl" | ||
9 | |||
10 | SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz" | ||
11 | SRC_URI[md5sum] = "92b8085967110b0125c192634f127a2b" | ||
12 | SRC_URI[sha256sum] = "b161050ed8cdb2d45f601181d146821e5535a8fcbf5978b2ff064e5476a8e606" | ||
13 | |||
14 | S = "${WORKDIR}/node-v${PV}" | ||
15 | |||
16 | # v8 errors out if you have set CCACHE | ||
17 | CCACHE = "" | ||
18 | |||
19 | # Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround waf+scons | ||
20 | do_configure () { | ||
21 | echo '#!/bin/sh' > ${WORKDIR}/gcc | ||
22 | echo '${CC} $@' >> ${WORKDIR}/gcc | ||
23 | |||
24 | echo '#!/bin/sh' > ${WORKDIR}/g++ | ||
25 | echo '${CXX} $@'>> ${WORKDIR}/g++ | ||
26 | |||
27 | chmod +x ${WORKDIR}/gcc ${WORKDIR}/g++ | ||
28 | |||
29 | sed -i -e s:\'/usr/lib:\'${STAGING_LIBDIR}:g wscript | ||
30 | sed -i -e s:\'/usr/local/lib:\'${STAGING_LIBDIR}:g wscript | ||
31 | |||
32 | export PATH=${WORKDIR}:${PATH} | ||
33 | export CC=gcc | ||
34 | export CXX=g++ | ||
35 | |||
36 | ./configure --prefix=${prefix} --without-snapshot | ||
37 | } | ||
38 | |||
39 | do_compile () { | ||
40 | export PATH=${WORKDIR}:${PATH} | ||
41 | export CC=gcc | ||
42 | export CXX=g++ | ||
43 | make | ||
44 | } | ||
45 | |||
46 | do_install () { | ||
47 | DESTDIR=${D} oe_runmake install | ||
48 | } | ||
49 | |||
50 | RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient " | ||
51 | |||
52 | FILES_${PN} += "${libdir}/node/wafadmin" | ||
53 | BBCLASSEXTEND = "native" | ||