diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-08-16 15:49:41 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-08-17 09:21:10 +0200 |
commit | ffd6c31cb4beea4edf1b70864b6894a692aab596 (patch) | |
tree | 40845bc3169f5dea58ea29adb828c9880b180115 /meta-oe/recipes-devtools/nodejs | |
parent | 246b0b07f771ef6d096d0ef3e488ea28c56e13c5 (diff) | |
download | meta-openembedded-ffd6c31cb4beea4edf1b70864b6894a692aab596.tar.gz |
nodejs 0.4.2: import from OE rev e02237d7e46e60fbd9eb4a05a308e6adcf916ebb
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs')
-rw-r--r-- | meta-oe/recipes-devtools/nodejs/nodejs/libev-cross-cc_0.4.2.patch | 13 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/nodejs/nodejs_0.4.2.bb | 40 |
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/libev-cross-cc_0.4.2.patch b/meta-oe/recipes-devtools/nodejs/nodejs/libev-cross-cc_0.4.2.patch new file mode 100644 index 000000000..2b9838f0c --- /dev/null +++ b/meta-oe/recipes-devtools/nodejs/nodejs/libev-cross-cc_0.4.2.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | diff --git a/deps/libev/wscript b/deps/libev/wscript | ||
2 | index 4f6c9a8..1796749 100644 | ||
3 | --- a/deps/libev/wscript | ||
4 | +++ b/deps/libev/wscript | ||
5 | @@ -58,7 +58,7 @@ def configure(conf): | ||
6 | return 0; | ||
7 | } | ||
8 | """ | ||
9 | - conf.check_cc(fragment=code, define_name="HAVE_CLOCK_SYSCALL", execute=True, | ||
10 | + conf.check_cc(fragment=code, define_name="HAVE_CLOCK_SYSCALL", execute=False, | ||
11 | msg="Checking for SYS_clock_gettime") | ||
12 | |||
13 | have_librt = conf.check(lib='rt', uselib_store='RT') | ||
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.4.2.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.4.2.bb new file mode 100644 index 000000000..84b4bbe17 --- /dev/null +++ b/meta-oe/recipes-devtools/nodejs/nodejs_0.4.2.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript" | ||
2 | HOMEPAGE = "http://nodejs.org" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=6394136134ac02d730a7302418c94fb6" | ||
5 | |||
6 | DEPENDS = "openssl" | ||
7 | |||
8 | def nodejs_get_gcc_version(d): | ||
9 | import subprocess,os,bb | ||
10 | if os.path.exists(bb.data.getVar('TOOLCHAIN_PATH', d, 1)+'/bin/'+bb.data.getVar('TARGET_PREFIX', d, 1)+'gcc'): | ||
11 | return subprocess.Popen([bb.data.getVar('TOOLCHAIN_PATH', d, 1)+'/bin/'+bb.data.getVar('TARGET_PREFIX', d, 1)+'gcc', '-v'], stderr=subprocess.PIPE).communicate()[1].splitlines()[-1].split()[2] | ||
12 | |||
13 | SRC_URI = " \ | ||
14 | http://nodejs.org/dist/node-v${PV}.tar.gz \ | ||
15 | file://libev-cross-cc_${PV}.patch \ | ||
16 | " | ||
17 | |||
18 | SRC_URI[md5sum] = "9e9e791e125f6a601ebc663dc99c72a8" | ||
19 | SRC_URI[sha256sum] = "09b1100ca6828eedbe52418fbeb3352d71c0b1ff3344c44a5af3efb80c5b908c" | ||
20 | |||
21 | S = "${WORKDIR}/node-v${PV}" | ||
22 | |||
23 | # v8 errors out if you have set CCACHE | ||
24 | CCACHE = "" | ||
25 | |||
26 | do_configure () { | ||
27 | sed -i -e 's:/usr/lib:${STAGING_LIBDIR}:g' wscript | ||
28 | sed -i -e 's:/usr/local/lib:${STAGING_LIBDIR}:g' wscript | ||
29 | ./configure --prefix=${prefix} --without-snapshot | ||
30 | } | ||
31 | |||
32 | do_compile () { | ||
33 | make | ||
34 | } | ||
35 | |||
36 | do_install () { | ||
37 | DESTDIR=${D} oe_runmake install | ||
38 | } | ||
39 | |||
40 | BBCLASSEXTEND = "native" | ||