diff options
author | Trevor Woerner <twoerner@gmail.com> | 2015-12-22 10:45:25 -0500 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-01-04 14:56:23 +0100 |
commit | c13175d91321b34b7b15e84f969dd0043de8867f (patch) | |
tree | 8a60577ff5c36fe5859eb5c36943d8c9f24016c9 /meta-oe/recipes-devtools/nodejs/nodejs4_0.4.12.bb | |
parent | e05057c587b546c2a7de7380049cbd270cb95803 (diff) | |
download | meta-openembedded-c13175d91321b34b7b15e84f969dd0043de8867f.tar.gz |
nodejs: cleanup and update
Remove old nodejs4_0.4.12 and update nodejs_0.12.7 to the latest stable
nodejs_4.2.3.
Nodejs is picky about which architectures it supports. The supported arch
mapping required some updating to bring it up to date with the current nodejs
code. Add COMPATIBLE_MACHINE entries so it only builds for the supported
architectures.
ARM cores that don't support at least VFP2 have been dropped:
https://groups.google.com/forum/#!topic/v8-users/aSOFbaAQvMk
"Due the increasing cost of the keeping the "no-VFPv2" port of V8 working
on ARM, we are planning on making 3.17 the last V8 release that that
supports ARM chips without VFPv2. Starting with the 3.18 release, the
minimal V8 requirements will increase to ARMv6 + VFPv2. In order to
simplify maintenance, we will also remove the "pre-VFP2" ARM code from the
V8 code base."
Additionally, gcc no longer supports a VFPv2 option:
https://gcc.gnu.org/onlinedocs/gcc/ARM-Options.html#index-mfpu-1460
Signed-off-by: Trevor Woerner <twoerner@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs/nodejs4_0.4.12.bb')
-rw-r--r-- | meta-oe/recipes-devtools/nodejs/nodejs4_0.4.12.bb | 49 |
1 files changed, 0 insertions, 49 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs4_0.4.12.bb b/meta-oe/recipes-devtools/nodejs/nodejs4_0.4.12.bb deleted file mode 100644 index c73cefc56..000000000 --- a/meta-oe/recipes-devtools/nodejs/nodejs4_0.4.12.bb +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | SUMMARY = "nodeJS Evented I/O for V8 JavaScript" | ||
2 | HOMEPAGE = "http://nodejs.org" | ||
3 | LICENSE = "MIT & Zlib" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d6237f3a840aef5b7880fb4e49eecfe5" | ||
5 | |||
6 | DEPENDS = "openssl" | ||
7 | |||
8 | PNBLACKLIST[nodejs4] ?= "Used only by currently blacklisted cloud9 and fails to build for qemuarm with thumb: error: #error For thumb inter-working we require an architecture which supports blx" | ||
9 | |||
10 | SRC_URI = " \ | ||
11 | http://nodejs.org/dist/node-v${PV}.tar.gz \ | ||
12 | file://libev-cross-cc_${PV}.patch \ | ||
13 | " | ||
14 | SRC_URI[md5sum] = "a6375eaa43db5356bf443e25b828ae16" | ||
15 | SRC_URI[sha256sum] = "c01af05b933ad4d2ca39f63cac057f54f032a4d83cff8711e42650ccee24fce4" | ||
16 | |||
17 | S = "${WORKDIR}/node-v${PV}" | ||
18 | |||
19 | # v8 errors out if you have set CCACHE | ||
20 | CCACHE = "" | ||
21 | |||
22 | do_configure () { | ||
23 | sed -i -e 's:/usr/lib:${STAGING_LIBDIR}:g' wscript | ||
24 | sed -i -e 's:/usr/local/lib:${STAGING_LIBDIR}:g' wscript | ||
25 | ./configure --prefix=${prefix} --without-snapshot | ||
26 | } | ||
27 | |||
28 | do_compile () { | ||
29 | make | ||
30 | } | ||
31 | |||
32 | do_install () { | ||
33 | oe_runmake install DESTDIR=${D} | ||
34 | |||
35 | # fix namespace conflicts with other nodejs recipes | ||
36 | mv ${D}${bindir}/node ${D}${bindir}/node4 | ||
37 | mv ${D}${bindir}/node-waf ${D}${bindir}/node4-waf | ||
38 | |||
39 | mv ${D}${includedir}/node ${D}${includedir}/node4 | ||
40 | |||
41 | mv ${D}${libdir}/node ${D}${libdir}/node4 | ||
42 | mv ${D}${libdir}/pkgconfig/nodejs.pc ${D}${libdir}/pkgconfig/nodejs4.pc | ||
43 | sed -i -e s:include/node:include/node4: ${D}${libdir}/pkgconfig/nodejs4.pc | ||
44 | |||
45 | mv ${D}${datadir}/man/man1/node.1 ${D}${datadir}/man/man1/node4.1 | ||
46 | } | ||
47 | |||
48 | FILES_${PN} += "${libdir}/node4/wafadmin" | ||
49 | BBCLASSEXTEND = "native" | ||