summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/luajit
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-devtools/luajit
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/luajit')
-rw-r--r--meta-oe/recipes-devtools/luajit/luajit_2.0.0.bb28
1 files changed, 14 insertions, 14 deletions
diff --git a/meta-oe/recipes-devtools/luajit/luajit_2.0.0.bb b/meta-oe/recipes-devtools/luajit/luajit_2.0.0.bb
index a7f96f81f..38783869c 100644
--- a/meta-oe/recipes-devtools/luajit/luajit_2.0.0.bb
+++ b/meta-oe/recipes-devtools/luajit/luajit_2.0.0.bb
@@ -7,7 +7,7 @@ DEPENDS += "lua5.1"
7PR = "r2" 7PR = "r2"
8SRC_URI = "http://luajit.org/download/LuaJIT-${PV}.tar.gz \ 8SRC_URI = "http://luajit.org/download/LuaJIT-${PV}.tar.gz \
9 file://disable_lj_vm_foldarith_for_spe.patch \ 9 file://disable_lj_vm_foldarith_for_spe.patch \
10 " 10"
11SRC_URI[md5sum] = "97a2b87cc0490784f54b64cfb3b8f5ad" 11SRC_URI[md5sum] = "97a2b87cc0490784f54b64cfb3b8f5ad"
12SRC_URI[sha256sum] = "deaed645c4a093c5fb250c30c9933c9131ee05c94b13262d58f6e0b60b338c15" 12SRC_URI[sha256sum] = "deaed645c4a093c5fb250c30c9933c9131ee05c94b13262d58f6e0b60b338c15"
13 13
@@ -16,8 +16,8 @@ S = "${WORKDIR}/LuaJIT-${PV}"
16inherit pkgconfig binconfig 16inherit pkgconfig binconfig
17 17
18do_configure_prepend() { 18do_configure_prepend() {
19 sed -i -e s:/usr/local:${prefix}:g ${S}/Makefile 19 sed -i -e s:/usr/local:${prefix}:g ${S}/Makefile
20 sed -i -e s:/lib$:${base_libdir}:g ${S}/Makefile 20 sed -i -e s:/lib$:${base_libdir}:g ${S}/Makefile
21} 21}
22 22
23EXTRA_OEMAKE = 'CROSS=${HOST_PREFIX} TARGET_CFLAGS="${TOOLCHAIN_OPTIONS}" TARGET_LDFLAGS="${TOOLCHAIN_OPTIONS}" TARGET_SHLDFLAGS="${TOOLCHAIN_OPTIONS}"' 23EXTRA_OEMAKE = 'CROSS=${HOST_PREFIX} TARGET_CFLAGS="${TOOLCHAIN_OPTIONS}" TARGET_LDFLAGS="${TOOLCHAIN_OPTIONS}" TARGET_SHLDFLAGS="${TOOLCHAIN_OPTIONS}"'
@@ -29,25 +29,25 @@ EXTRA_OEMAKE_append_arm = ' HOST_CC="${BUILD_CC} -m32"'
29EXTRA_OEMAKE_append_mips64 = ' HOST_CC="${BUILD_CC} -m32"' 29EXTRA_OEMAKE_append_mips64 = ' HOST_CC="${BUILD_CC} -m32"'
30 30
31do_compile () { 31do_compile () {
32 oe_runmake 32 oe_runmake
33} 33}
34 34
35do_install () { 35do_install () {
36 oe_runmake 'DESTDIR=${D}' install 36 oe_runmake 'DESTDIR=${D}' install
37 rmdir ${D}${datadir}/lua/5.1 \ 37 rmdir ${D}${datadir}/lua/5.1 \
38 ${D}${datadir}/lua \ 38 ${D}${datadir}/lua \
39 ${D}${libdir}/lua/5.1 \ 39 ${D}${libdir}/lua/5.1 \
40 ${D}${libdir}/lua 40 ${D}${libdir}/lua
41} 41}
42 42
43PACKAGES += 'luajit-common' 43PACKAGES += 'luajit-common'
44 44
45FILES_${PN} += "${libdir}/libluajit-5.1.so.2 \ 45FILES_${PN} += "${libdir}/libluajit-5.1.so.2 \
46 ${libdir}/libluajit-5.1.so.2.0.0 \ 46 ${libdir}/libluajit-5.1.so.2.0.0 \
47 " 47"
48FILES_${PN}-dev += "${libdir}/libluajit-5.1.a \ 48FILES_${PN}-dev += "${libdir}/libluajit-5.1.a \
49 ${libdir}/libluajit-5.1.so \ 49 ${libdir}/libluajit-5.1.so \
50 ${libdir}/pkgconfig/luajit.pc \ 50 ${libdir}/pkgconfig/luajit.pc \
51 " 51"
52FILES_luajit-common = "${datadir}/${BPN}-${PV}" 52FILES_luajit-common = "${datadir}/${BPN}-${PV}"
53 53