diff options
author | Paul Vaduva <Paul.Vaduva@enea.com> | 2016-02-03 10:25:16 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-02-15 10:15:27 +0100 |
commit | 142d6fb402a5c6fad7bb0fd818c5d45b45eaf69d (patch) | |
tree | 51ce9c29eb3a06d2eea359ac11b65f4da9ca932c /meta-oe/recipes-devtools/lua | |
parent | d3be014d9c1f3d9fa39739eb1d68db0ce344246b (diff) | |
download | meta-openembedded-142d6fb402a5c6fad7bb0fd818c5d45b45eaf69d.tar.gz |
lua: Added ptest for lua
Signed-off-by: Andreas Sundstr
Signed-off-by: Maxin B. John <maxin.john@enea.com>
Signed-off-by: Paul Vaduva <Paul.Vaduva@enea.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/lua')
-rw-r--r-- | meta-oe/recipes-devtools/lua/lua/run-ptest | 19 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/lua/lua_5.3.2.bb | 20 |
2 files changed, 34 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/lua/lua/run-ptest b/meta-oe/recipes-devtools/lua/lua/run-ptest new file mode 100644 index 000000000..8e085e1af --- /dev/null +++ b/meta-oe/recipes-devtools/lua/lua/run-ptest | |||
@@ -0,0 +1,19 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | cd test | ||
4 | lua -e"_U=true" all.lua > lua-test.tmp | ||
5 | |||
6 | echo "--- test output ---" | ||
7 | cat lua-test.tmp | ||
8 | echo "" | ||
9 | echo "" | ||
10 | echo "--- ptest result ---" | ||
11 | |||
12 | grep "final OK \!\!\!" lua-test.tmp > /dev/null | ||
13 | if [ $? -eq 0 ]; then | ||
14 | echo "PASS: lua" | ||
15 | else | ||
16 | echo "FAIL: lua" | ||
17 | fi | ||
18 | |||
19 | rm -f lua-test.tmp | ||
diff --git a/meta-oe/recipes-devtools/lua/lua_5.3.2.bb b/meta-oe/recipes-devtools/lua/lua_5.3.2.bb index 3fe8c3fe8..0cc882df2 100644 --- a/meta-oe/recipes-devtools/lua/lua_5.3.2.bb +++ b/meta-oe/recipes-devtools/lua/lua_5.3.2.bb | |||
@@ -7,14 +7,20 @@ HOMEPAGE = "http://www.lua.org/" | |||
7 | PR = "r0" | 7 | PR = "r0" |
8 | 8 | ||
9 | DEPENDS = "readline" | 9 | DEPENDS = "readline" |
10 | SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz \ | 10 | SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz;name=tarballsrc \ |
11 | file://lua.pc \ | 11 | file://lua.pc \ |
12 | " | 12 | " |
13 | SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', \ | ||
14 | 'http://www.lua.org/tests/lua-${PV}-tests.tar.gz;name=tarballtest \ | ||
15 | file://run-ptest \ | ||
16 | ', '', d)}" | ||
13 | 17 | ||
14 | SRC_URI[md5sum] = "33278c2ab5ee3c1a875be8d55c1ca2a1" | 18 | SRC_URI[tarballsrc.md5sum] = "33278c2ab5ee3c1a875be8d55c1ca2a1" |
15 | SRC_URI[sha256sum] = "c740c7bb23a936944e1cc63b7c3c5351a8976d7867c5252c8854f7b2af9da68f" | 19 | SRC_URI[tarballsrc.sha256sum] = "c740c7bb23a936944e1cc63b7c3c5351a8976d7867c5252c8854f7b2af9da68f" |
20 | SRC_URI[tarballtest.md5sum] = "a2b7ab1b8ff82a0145376e233ef30a4a" | ||
21 | SRC_URI[tarballtest.sha256sum] = "56909863a3713dee3709b3dbd0c868237e4f5c9ea1744f5bf0ba8bafa6c4ed32" | ||
16 | 22 | ||
17 | inherit pkgconfig binconfig | 23 | inherit pkgconfig binconfig ptest |
18 | 24 | ||
19 | UCLIBC_PATCHES += "file://uclibc-pthread.patch" | 25 | UCLIBC_PATCHES += "file://uclibc-pthread.patch" |
20 | SRC_URI_append_libc-uclibc = "${UCLIBC_PATCHES}" | 26 | SRC_URI_append_libc-uclibc = "${UCLIBC_PATCHES}" |
@@ -46,4 +52,8 @@ do_install () { | |||
46 | rmdir ${D}${datadir}/lua | 52 | rmdir ${D}${datadir}/lua |
47 | } | 53 | } |
48 | 54 | ||
55 | do_install_ptest () { | ||
56 | cp -a ${WORKDIR}/lua-${PV}-tests ${D}${PTEST_PATH}/test | ||
57 | } | ||
58 | |||
49 | BBCLASSEXTEND = "native" | 59 | BBCLASSEXTEND = "native" |