summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/ltrace
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-06 14:23:41 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-07 10:08:45 -0700
commit720a2ffe85cff1d24012b14e9ab47a6a239cd9eb (patch)
tree3b8cc68e6504511143bb3c094b2bb88fe5a83c12 /meta-oe/recipes-devtools/ltrace
parent6b236cd021806dde7d043aabe2e23d3d241a6053 (diff)
downloadmeta-openembedded-720a2ffe85cff1d24012b14e9ab47a6a239cd9eb.tar.gz
ltrace: Fix build on mips
Newer kernel UAPI headers for mips have moved these needed defines around Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/ltrace')
-rw-r--r--meta-oe/recipes-devtools/ltrace/ltrace/include_unistd_nr.patch30
-rw-r--r--meta-oe/recipes-devtools/ltrace/ltrace_git.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/ltrace/ltrace/include_unistd_nr.patch b/meta-oe/recipes-devtools/ltrace/ltrace/include_unistd_nr.patch
new file mode 100644
index 000000000..e4490bbb9
--- /dev/null
+++ b/meta-oe/recipes-devtools/ltrace/ltrace/include_unistd_nr.patch
@@ -0,0 +1,30 @@
1kernel headers have restructured mips syscall generation in kernel
2in recent versions, however, ltrace still has logic to define the
3syscall numbers based on old logic, this patch includes the legacy
4UAPI headers to get these defines
5
6Fixes errors e.g.
7../../../../git/sysdeps/linux-gnu/mips/trace.c:138:29: error: '__NR_O32_Linux' undeclared (first use in this function)
8 const int syscallbase[] = {__NR_O32_Linux, __NR_N32_Linux,
9
10Upstream-Status: Pending
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12--- a/sysdeps/linux-gnu/mips/trace.c
13+++ b/sysdeps/linux-gnu/mips/trace.c
14@@ -34,6 +34,16 @@
15 #include <assert.h>
16 #include <asm/unistd.h>
17
18+#ifndef __NR_O32_Linux
19+#include <asm/unistd_nr_o32.h>
20+#endif
21+#ifndef __NR_N32_Linux
22+#include <asm/unistd_nr_n64.h>
23+#endif
24+#ifndef __NR_N64_Linux
25+#include <asm/unistd_nr_n32.h>
26+#endif
27+
28 #include "backend.h"
29 #include "common.h"
30 #include "debug.h"
diff --git a/meta-oe/recipes-devtools/ltrace/ltrace_git.bb b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
index 3dc269c80..ead637cb7 100644
--- a/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
+++ b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
@@ -27,6 +27,7 @@ SRC_URI = "git://github.com/sparkleholic/ltrace.git;branch=master;protocol=http
27 file://0001-mips-plt.c-Delete-include-error.h.patch \ 27 file://0001-mips-plt.c-Delete-include-error.h.patch \
28 file://0001-move-fprintf-into-same-block-where-modname-and-symna.patch \ 28 file://0001-move-fprintf-into-same-block-where-modname-and-symna.patch \
29 file://0001-hook-Do-not-append-int-to-std-string.patch \ 29 file://0001-hook-Do-not-append-int-to-std-string.patch \
30 file://include_unistd_nr.patch \
30 " 31 "
31S = "${WORKDIR}/git" 32S = "${WORKDIR}/git"
32 33