summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2014-12-02 03:14:27 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-09 11:34:42 +0100
commite2d07c8646d25a473dd66ab2f76954f1103470f7 (patch)
treef2e522e8669576113f6c398da3676e690d97870d /meta-oe/recipes-devtools/ltrace/ltrace_git.bb
parent1bc5ab1737371a023256b1771819e0ec6aee1e31 (diff)
downloadmeta-openembedded-e2d07c8646d25a473dd66ab2f76954f1103470f7.tar.gz
ltrace: add PACKAGECONFIG for selinux
Add PACKAGECONFIG for 'selinux', otherwise there would be warnings like below: WARN: ltrace: ltrace rdepends on libselinux, but it isn't a build dependency? Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/ltrace/ltrace_git.bb')
-rw-r--r--meta-oe/recipes-devtools/ltrace/ltrace_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/ltrace/ltrace_git.bb b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
index 507747ae1..69848483d 100644
--- a/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
+++ b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
@@ -17,12 +17,15 @@ DEPENDS = "elfutils"
17RDEPENDS_${PN} = "elfutils" 17RDEPENDS_${PN} = "elfutils"
18SRC_URI = "git://anonscm.debian.org/collab-maint/ltrace.git \ 18SRC_URI = "git://anonscm.debian.org/collab-maint/ltrace.git \
19 file://ltrace-0.7.2-unused-typedef.patch \ 19 file://ltrace-0.7.2-unused-typedef.patch \
20 file://configure-allow-to-disable-selinux-support.patch \
20 " 21 "
21S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"
22 23
23inherit autotools 24inherit autotools
24 25
26PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
25PACKAGECONFIG[unwind] = "--with-libunwind,--without-libunwind,libunwind" 27PACKAGECONFIG[unwind] = "--with-libunwind,--without-libunwind,libunwind"
28PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
26 29
27do_configure_prepend () { 30do_configure_prepend () {
28 ( cd ${S}; ./autogen.sh ) 31 ( cd ${S}; ./autogen.sh )