diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-28 13:49:59 +0000 |
---|---|---|
committer | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-28 14:32:06 +0000 |
commit | 3a30c562385cb3d9cd1b3043f6fe677a22024018 (patch) | |
tree | 66dc67f338ba316c25ca672950ef334e9e357386 /meta-oe/recipes-devtools/libgee | |
parent | d66c9a8b625f7b19f7b17e728dc82413399c2e19 (diff) | |
download | meta-openembedded-3a30c562385cb3d9cd1b3043f6fe677a22024018.tar.gz |
Replace bb.data.* with d.*
Used sed expression given here:
http://lists.linuxtogo.org/pipermail/openembedded-core/2011-November/012373.html
Plus an additional expression for .expand. Full expression is:
sed \
-e 's:bb.data.\(setVar([^,]*,[^,]*\), \([^ )]*\) *):\2.\1):g' \
-e 's:bb.data.\(setVarFlag([^,]*,[^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(expand([^,]*\), \([^ )]*\) *):\2.\1):g' \
-i `grep -ril bb.data *`
Some minor correction in systemd.bbclass was needed for some expressions
that didn't quite match the regex in the desired way; additionally a few
instances were manually changed.
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-devtools/libgee')
-rw-r--r-- | meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb b/meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb index a6044cdf3..fbd14662f 100644 --- a/meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb +++ b/meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb | |||
@@ -4,7 +4,7 @@ PR = "${INC_PR}.2" | |||
4 | DEPENDS += "gobject-introspection-stub" | 4 | DEPENDS += "gobject-introspection-stub" |
5 | DEPENDS_virtclass-native += "gobject-introspection-stub-native" | 5 | DEPENDS_virtclass-native += "gobject-introspection-stub-native" |
6 | 6 | ||
7 | SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}" | 7 | SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" |
8 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgee/${SHRT_VER}/${BP}.tar.xz" | 8 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgee/${SHRT_VER}/${BP}.tar.xz" |
9 | SRC_URI[md5sum] = "a32bf498cf33d5e3417823a7b252ad22" | 9 | SRC_URI[md5sum] = "a32bf498cf33d5e3417823a7b252ad22" |
10 | SRC_URI[sha256sum] = "55f39f3b28e676f6cbd9377d83edd031084436a4da41280a9503c94faffb1665" | 10 | SRC_URI[sha256sum] = "55f39f3b28e676f6cbd9377d83edd031084436a4da41280a9503c94faffb1665" |