summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/gcc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-07-02 07:56:48 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-07-02 22:40:22 +0200
commit340cc366c7feff983a85f9e9ae8ae1f537239f5b (patch)
treed31941bd9684ec7ed3fca4b62b20fb39c80b0aba /meta-oe/recipes-devtools/gcc
parenta7b8268b8f0248a6a5d501f501dad926f6a705db (diff)
downloadmeta-openembedded-340cc366c7feff983a85f9e9ae8ae1f537239f5b.tar.gz
gcc-4.5: Edit defaults.h in ${B} instead of ${S}, and t-oe in ${B}
This patches are from oe-core needed after shared sourcedir changes to oe-core Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/gcc')
-rw-r--r--meta-oe/recipes-devtools/gcc/gcc-4.5.inc3
-rw-r--r--meta-oe/recipes-devtools/gcc/gcc-4.5/use-defaults.h-and-t-oe-in-B.patch57
2 files changed, 59 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/gcc/gcc-4.5.inc b/meta-oe/recipes-devtools/gcc/gcc-4.5.inc
index 30a969204..abd30882d 100644
--- a/meta-oe/recipes-devtools/gcc/gcc-4.5.inc
+++ b/meta-oe/recipes-devtools/gcc/gcc-4.5.inc
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
14 14
15 15
16PV = "4.5" 16PV = "4.5"
17INC_PR = "r38" 17INC_PR = "r39"
18 18
19# BINV should be incremented after updating to a revision 19# BINV should be incremented after updating to a revision
20# after a minor gcc release (e.g. 4.5.1 or 4.5.2) has been made 20# after a minor gcc release (e.g. 4.5.1 or 4.5.2) has been made
@@ -216,6 +216,7 @@ SRC_URI = "svn://gcc.gnu.org/svn/gcc/branches;module=${BRANCH};proto=http \
216 file://gcc-poison-parameters.patch \ 216 file://gcc-poison-parameters.patch \
217 file://gcc-ppc-config-fix.patch \ 217 file://gcc-ppc-config-fix.patch \
218 file://gcc-ppc-include-config-linux.h.patch \ 218 file://gcc-ppc-include-config-linux.h.patch \
219 file://use-defaults.h-and-t-oe-in-B.patch \
219 " 220 "
220 221
221# Language Overrides 222# Language Overrides
diff --git a/meta-oe/recipes-devtools/gcc/gcc-4.5/use-defaults.h-and-t-oe-in-B.patch b/meta-oe/recipes-devtools/gcc/gcc-4.5/use-defaults.h-and-t-oe-in-B.patch
new file mode 100644
index 000000000..c93e6caa0
--- /dev/null
+++ b/meta-oe/recipes-devtools/gcc/gcc-4.5/use-defaults.h-and-t-oe-in-B.patch
@@ -0,0 +1,57 @@
1Upstream-Status: Pending
2
3Use the defaults.h in ${B} instead of ${S}, and t-oe in ${B}, so that
4the source can be shared between gcc-cross-initial,
5gcc-cross-intermediate, gcc-cross, gcc-runtime, and also the sdk build.
6---
7 gcc/Makefile.in | 2 +-
8 gcc/configure | 4 ++--
9 gcc/configure.ac | 4 ++--
10 3 files changed, 5 insertions(+), 5 deletions(-)
11
12diff --git a/gcc/Makefile.in b/gcc/Makefile.in
13index d91f93a..03ee2bd 100644
14--- a/gcc/Makefile.in
15+++ b/gcc/Makefile.in
16@@ -461,7 +461,7 @@ LIMITS_H_TEST = [ -f $(SYSTEM_HEADER_DIR)/limits.h ]
17 TARGET_SYSTEM_ROOT = @TARGET_SYSTEM_ROOT@
18
19 xmake_file=@xmake_file@
20-tmake_file=@tmake_file@
21+tmake_file=@tmake_file@ ./t-oe
22 TM_ENDIAN_CONFIG=@TM_ENDIAN_CONFIG@
23 TM_MULTILIB_CONFIG=@TM_MULTILIB_CONFIG@
24 TM_MULTILIB_EXCEPTIONS_CONFIG=@TM_MULTILIB_EXCEPTIONS_CONFIG@
25diff --git a/gcc/configure b/gcc/configure
26index f440fa2..dafb0c1 100755
27--- a/gcc/configure
28+++ b/gcc/configure
29@@ -10838,8 +10838,8 @@ for f in $tm_file; do
30 tm_include_list="${tm_include_list} $f"
31 ;;
32 defaults.h )
33- tm_file_list="${tm_file_list} \$(srcdir)/$f"
34- tm_include_list="${tm_include_list} $f"
35+ tm_file_list="${tm_file_list} ./$f"
36+ tm_include_list="${tm_include_list} ./$f"
37 ;;
38 * )
39 tm_file_list="${tm_file_list} \$(srcdir)/config/$f"
40diff --git a/gcc/configure.ac b/gcc/configure.ac
41index d003091..ba422e6 100644
42--- a/gcc/configure.ac
43+++ b/gcc/configure.ac
44@@ -1652,8 +1652,8 @@ for f in $tm_file; do
45 tm_include_list="${tm_include_list} $f"
46 ;;
47 defaults.h )
48- tm_file_list="${tm_file_list} \$(srcdir)/$f"
49- tm_include_list="${tm_include_list} $f"
50+ tm_file_list="${tm_file_list} ./$f"
51+ tm_include_list="${tm_include_list} ./$f"
52 ;;
53 * )
54 tm_file_list="${tm_file_list} \$(srcdir)/config/$f"
55--
561.7.1
57