summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-01-05 19:42:51 -0800
committerKhem Raj <raj.khem@gmail.com>2013-01-08 09:31:45 -0800
commit13d5ab6cf18dfe03a6164ceb4bd580fe19556e8a (patch)
tree2fc286f138ed0afa9d1b0fabbf6bcf76fa6c423c /meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
parent9aecf2944ea8646dfce4085622b4cc6427d2140c (diff)
downloadmeta-openembedded-13d5ab6cf18dfe03a6164ceb4bd580fe19556e8a.tar.gz
concurrencykit: Add recipe for latest from git
Provides concurrency primitives Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb')
-rw-r--r--meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
new file mode 100644
index 000000000..b0ff5cf45
--- /dev/null
+++ b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "Concurrency Kit provides a plethora of concurrency primitives, \
2safe memory reclamation mechanisms and non-blocking data structures \
3designed to aid in the design and implementation of high performance \
4concurrent systems."
5
6LICENSE = "BSD & Apache-2.0"
7HOMEPAGE = "http://concurrencykit.org"
8SECTION = "base"
9
10SRCREV = "900d203aa9e41288545368ea40da0bee89f7907f"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=f12611e65e064515ce264249b2bdea98"
12SRC_URI = "git://git.concurrencykit.org/ck.git;protocol=git \
13 file://cross.patch \
14 "
15
16S = "${WORKDIR}/git"
17
18COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64).*-linux*"
19
20inherit autotools
21
22PLAT_powerpc64 = "ppc64"
23PLAT ?= "${HOST_ARCH}"
24
25do_configure () {
26 export PLATFORM=${PLAT}
27 export COMPILER='gcc'
28 ${S}/configure \
29 --prefix=${prefix} \
30 --includedir=${includedir} \
31 --libdir=${libdir} \
32}
33
34do_compile () {
35 oe_runmake
36}
37
38do_install () {
39 oe_runmake 'DESTDIR=${D}' install
40}