summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/cloud9
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-devtools/cloud9
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/cloud9')
-rw-r--r--meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb58
1 files changed, 29 insertions, 29 deletions
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
index 9ae25bb65..3300fd234 100644
--- a/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
+++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
@@ -37,7 +37,7 @@ SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \
37 file://cloud9-avahi.service \ 37 file://cloud9-avahi.service \
38 file://cloud9.service \ 38 file://cloud9.service \
39 file://0001-ide-use-node-as-interpreter-for-sketches-instead-of-.patch \ 39 file://0001-ide-use-node-as-interpreter-for-sketches-instead-of-.patch \
40 " 40"
41 41
42SRCREV_cloud9ide = "c4e2574896a22bb749f0500b25f41c888d346bed" 42SRCREV_cloud9ide = "c4e2574896a22bb749f0500b25f41c888d346bed"
43SRCREV_o3 = "302cd3a6d5039f53a9fa3932bed88b53281c1e1e" 43SRCREV_o3 = "302cd3a6d5039f53a9fa3932bed88b53281c1e1e"
@@ -68,46 +68,46 @@ SRCREV_FORMAT = "cloud9ide"
68S = "${WORKDIR}/git" 68S = "${WORKDIR}/git"
69 69
70do_configure () { 70do_configure () {
71 cd ${WORKDIR}/o3 71 cd ${WORKDIR}/o3
72 node-waf -vv configure 72 node-waf -vv configure
73} 73}
74 74
75EXTRA_CXXFLAGS = "-Idefault/include -I../include -Idefault/hosts -I../hosts -Idefault/modules -I../modules -Idefault/deps -I../deps -I${STAGING_DIR_NATIVE}/usr/include/node4 -fPIC -DPIC" 75EXTRA_CXXFLAGS = "-Idefault/include -I../include -Idefault/hosts -I../hosts -Idefault/modules -I../modules -Idefault/deps -I../deps -I${STAGING_DIR_NATIVE}/usr/include/node4 -fPIC -DPIC"
76 76
77do_compile () { 77do_compile () {
78 cd ${WORKDIR}/o3 78 cd ${WORKDIR}/o3
79 node4 tools/gluegen.js 79 node4 tools/gluegen.js
80 cd hosts 80 cd hosts
81 ${CXX} ${TARGET_CXXFLAGS} ${EXTRA_CXXFLAGS} -c -o sh_node.o node-o3/sh_node.cc 81 ${CXX} ${TARGET_CXXFLAGS} ${EXTRA_CXXFLAGS} -c -o sh_node.o node-o3/sh_node.cc
82 ${CXX} ${TARGET_CXXFLAGS} ${EXTRA_CXXFLAGS} -c -o sh_node_libs.o node-o3/sh_node_libs.cc 82 ${CXX} ${TARGET_CXXFLAGS} ${EXTRA_CXXFLAGS} -c -o sh_node_libs.o node-o3/sh_node_libs.cc
83 cd .. 83 cd ..
84 ${CXX} ${TARGET_LDFLAGS} hosts/sh_node.o hosts/sh_node_libs.o -o o3.node -shared -Wl,-Bdynamic -lxml2 84 ${CXX} ${TARGET_LDFLAGS} hosts/sh_node.o hosts/sh_node_libs.o -o o3.node -shared -Wl,-Bdynamic -lxml2
85} 85}
86 86
87do_install () { 87do_install () {
88 install -m 0755 -d ${D}${datadir}/cloud9 ${D}${bindir} ${D}/var/lib/cloud9 88 install -m 0755 -d ${D}${datadir}/cloud9 ${D}${bindir} ${D}/var/lib/cloud9
89 rsync -r --exclude=".*" ${S}/* ${D}${datadir}/cloud9 89 rsync -r --exclude=".*" ${S}/* ${D}${datadir}/cloud9
90 90
91 touch ${D}${bindir}/cloud9 91 touch ${D}${bindir}/cloud9
92 echo "#!/bin/sh" > ${D}${bindir}/cloud9 92 echo "#!/bin/sh" > ${D}${bindir}/cloud9
93 echo "node4 ${datadir}/cloud9/bin/cloud9.js -l 0.0.0.0 -w /var/lib/cloud9 -p 3000" >> ${D}${bindir}/cloud9 93 echo "node4 ${datadir}/cloud9/bin/cloud9.js -l 0.0.0.0 -w /var/lib/cloud9 -p 3000" >> ${D}${bindir}/cloud9
94 chmod 0755 ${D}${bindir}/cloud9 94 chmod 0755 ${D}${bindir}/cloud9
95 95
96 install -m 0755 -d ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml 96 install -m 0755 -d ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml
97 install -m 0644 ${WORKDIR}/index.js ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/index.js 97 install -m 0644 ${WORKDIR}/index.js ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/index.js
98 install -m 0644 ${WORKDIR}/o3/modules/o3.js ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/o3.js 98 install -m 0644 ${WORKDIR}/o3/modules/o3.js ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/o3.js
99 install -m 0755 ${WORKDIR}/o3/o3.node ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/o3.node 99 install -m 0755 ${WORKDIR}/o3/o3.node ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/o3.node
100 100
101 install -m 0755 -d ${D}${sysconfdir}/avahi/services/ 101 install -m 0755 -d ${D}${sysconfdir}/avahi/services/
102 install -m 0644 ${WORKDIR}/cloud9-avahi.service ${D}${sysconfdir}/avahi/services/ 102 install -m 0644 ${WORKDIR}/cloud9-avahi.service ${D}${sysconfdir}/avahi/services/
103 103
104 install -d ${D}${systemd_unitdir}/system 104 install -d ${D}${systemd_unitdir}/system
105 install -m 0644 ${WORKDIR}/cloud9.service ${D}${systemd_unitdir}/system 105 install -m 0644 ${WORKDIR}/cloud9.service ${D}${systemd_unitdir}/system
106} 106}
107 107
108FILES_${PN}-dbg += "${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/.debug \ 108FILES_${PN}-dbg += "${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/.debug \
109 ${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/.debug \ 109 ${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/.debug \
110 " 110"
111 111
112RDEPENDS_${PN} = "nodejs4 nodejs gzip" 112RDEPENDS_${PN} = "nodejs4 nodejs gzip"
113 113