diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2013-04-12 10:04:46 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:16:52 +0200 |
commit | 5ce31df17f12bb4507eae2b383f5462952dfa7b5 (patch) | |
tree | b5c84187accac87adb64a31a072458beb9e90589 /meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb | |
parent | 4fe1acbe3b9ce058264e1a9e43d179a62ab5daa2 (diff) | |
download | meta-openembedded-5ce31df17f12bb4507eae2b383f5462952dfa7b5.tar.gz |
cloud9: use node4 to build o3-xml binary
Using node 0.8.x will make it crash at runtime
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb')
-rw-r--r-- | meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb | 7 |
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb index a78c653c7..0c07b128b 100644 --- a/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb +++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb | |||
@@ -5,7 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018" | |||
5 | 5 | ||
6 | PR = "r2" | 6 | PR = "r2" |
7 | 7 | ||
8 | DEPENDS = "libxml2 nodejs-native" | 8 | # Nodejs-native for node-waf, nodejs4-native for the headers |
9 | DEPENDS = "libxml2 nodejs-native nodejs4-native" | ||
9 | 10 | ||
10 | SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \ | 11 | SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \ |
11 | git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \ | 12 | git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \ |
@@ -68,11 +69,11 @@ do_configure () { | |||
68 | node-waf -vv configure | 69 | node-waf -vv configure |
69 | } | 70 | } |
70 | 71 | ||
71 | EXTRA_CXXFLAGS = "-Idefault/include -I../include -Idefault/hosts -I../hosts -Idefault/modules -I../modules -Idefault/deps -I../deps -I${STAGING_DIR_NATIVE}/usr/include/node -fPIC -DPIC" | 72 | EXTRA_CXXFLAGS = "-Idefault/include -I../include -Idefault/hosts -I../hosts -Idefault/modules -I../modules -Idefault/deps -I../deps -I${STAGING_DIR_NATIVE}/usr/include/node4 -fPIC -DPIC" |
72 | 73 | ||
73 | do_compile () { | 74 | do_compile () { |
74 | cd ${WORKDIR}/o3 | 75 | cd ${WORKDIR}/o3 |
75 | node tools/gluegen.js | 76 | node4 tools/gluegen.js |
76 | cd hosts | 77 | cd hosts |
77 | ${CXX} ${TARGET_CXXFLAGS} ${EXTRA_CXXFLAGS} -c -o sh_node.o node-o3/sh_node.cc | 78 | ${CXX} ${TARGET_CXXFLAGS} ${EXTRA_CXXFLAGS} -c -o sh_node.o node-o3/sh_node.cc |
78 | ${CXX} ${TARGET_CXXFLAGS} ${EXTRA_CXXFLAGS} -c -o sh_node_libs.o node-o3/sh_node_libs.cc | 79 | ${CXX} ${TARGET_CXXFLAGS} ${EXTRA_CXXFLAGS} -c -o sh_node_libs.o node-o3/sh_node_libs.cc |