diff options
author | wangmy <wangmy@fujitsu.com> | 2022-01-25 21:12:47 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-01-25 10:56:04 -0800 |
commit | 46a98bfa3b06627bd7dce825602c0f681d2e760b (patch) | |
tree | 3eecae489b573ed1f7570eba4c94760ceb93fc01 /meta-oe/recipes-devtools/cgdb | |
parent | ac3bf04b2885371dfbcbc8bd991f4834d2c9dab6 (diff) | |
download | meta-openembedded-46a98bfa3b06627bd7dce825602c0f681d2e760b.tar.gz |
cgdb: upgrade 0.7.1 -> 0.8.0
0001-Avoid-use-of-mips-which-is-reserved-on-mips.patch
removed since it is inappropriate in 0.8.0
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/cgdb')
-rw-r--r-- | meta-oe/recipes-devtools/cgdb/cgdb/0001-Avoid-use-of-mips-which-is-reserved-on-mips.patch | 67 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/cgdb/cgdb_0.8.0.bb (renamed from meta-oe/recipes-devtools/cgdb/cgdb_0.7.1.bb) | 7 |
2 files changed, 2 insertions, 72 deletions
diff --git a/meta-oe/recipes-devtools/cgdb/cgdb/0001-Avoid-use-of-mips-which-is-reserved-on-mips.patch b/meta-oe/recipes-devtools/cgdb/cgdb/0001-Avoid-use-of-mips-which-is-reserved-on-mips.patch deleted file mode 100644 index daf90ad44..000000000 --- a/meta-oe/recipes-devtools/cgdb/cgdb/0001-Avoid-use-of-mips-which-is-reserved-on-mips.patch +++ /dev/null | |||
@@ -1,67 +0,0 @@ | |||
1 | From a3eba0fcee5e96ef47a6d3fac7196a1074f0dc17 Mon Sep 17 00:00:00 2001 | ||
2 | From: Adrian Bunk <bunk@stusta.de> | ||
3 | Date: Wed, 30 Oct 2019 11:07:23 +0200 | ||
4 | Subject: Avoid use of "mips" which is reserved on mips | ||
5 | |||
6 | Upstream-Status: Submitted [https://github.com/brasko/gdbwire/pull/9] | ||
7 | |||
8 | Signed-off-by: Adrian Bunk <bunk@stusta.de> | ||
9 | |||
10 | diff --git a/src/gdbwire_mi_parser.c b/src/gdbwire_mi_parser.c | ||
11 | index 3f6b563..24aa0cf 100644 | ||
12 | --- a/lib/tgdb/gdbwire.c | ||
13 | +++ b/lib/tgdb/gdbwire.c | ||
14 | @@ -40,7 +40,7 @@ struct gdbwire_mi_parser { | ||
15 | /* The GDB/MI lexer state */ | ||
16 | yyscan_t mils; | ||
17 | /* The GDB/MI push parser state */ | ||
18 | - gdbwire_mi_pstate *mips; | ||
19 | + gdbwire_mi_pstate *mipst; | ||
20 | /* The client parser callbacks */ | ||
21 | struct gdbwire_mi_parser_callbacks callbacks; | ||
22 | }; | ||
23 | @@ -71,8 +71,8 @@ gdbwire_mi_parser_create(struct gdbwire_mi_parser_callbacks callbacks) | ||
24 | } | ||
25 | |||
26 | /* Create a new push parser state instance */ | ||
27 | - parser->mips = gdbwire_mi_pstate_new(); | ||
28 | - if (!parser->mips) { | ||
29 | + parser->mipst = gdbwire_mi_pstate_new(); | ||
30 | + if (!parser->mipst) { | ||
31 | gdbwire_mi_lex_destroy(parser->mils); | ||
32 | gdbwire_string_destroy(parser->buffer); | ||
33 | free(parser); | ||
34 | @@ -81,7 +81,7 @@ gdbwire_mi_parser_create(struct gdbwire_mi_parser_callbacks callbacks) | ||
35 | |||
36 | /* Ensure that the callbacks are non null */ | ||
37 | if (!callbacks.gdbwire_mi_output_callback) { | ||
38 | - gdbwire_mi_pstate_delete(parser->mips); | ||
39 | + gdbwire_mi_pstate_delete(parser->mipst); | ||
40 | gdbwire_mi_lex_destroy(parser->mils); | ||
41 | gdbwire_string_destroy(parser->buffer); | ||
42 | free(parser); | ||
43 | @@ -109,9 +109,9 @@ void gdbwire_mi_parser_destroy(struct gdbwire_mi_parser *parser) | ||
44 | } | ||
45 | |||
46 | /* Free the push parser instance */ | ||
47 | - if (parser->mips) { | ||
48 | - gdbwire_mi_pstate_delete(parser->mips); | ||
49 | - parser->mips = NULL; | ||
50 | + if (parser->mipst) { | ||
51 | + gdbwire_mi_pstate_delete(parser->mipst); | ||
52 | + parser->mipst = NULL; | ||
53 | } | ||
54 | |||
55 | free(parser); | ||
56 | @@ -162,7 +162,7 @@ gdbwire_mi_parser_parse_line(struct gdbwire_mi_parser *parser, | ||
57 | pattern = gdbwire_mi_lex(parser->mils); | ||
58 | if (pattern == 0) | ||
59 | break; | ||
60 | - mi_status = gdbwire_mi_push_parse(parser->mips, pattern, NULL, | ||
61 | + mi_status = gdbwire_mi_push_parse(parser->mipst, pattern, NULL, | ||
62 | parser->mils, &output); | ||
63 | } while (mi_status == YYPUSH_MORE); | ||
64 | |||
65 | -- | ||
66 | 2.20.1 | ||
67 | |||
diff --git a/meta-oe/recipes-devtools/cgdb/cgdb_0.7.1.bb b/meta-oe/recipes-devtools/cgdb/cgdb_0.8.0.bb index a48e32af2..99e09bfc6 100644 --- a/meta-oe/recipes-devtools/cgdb/cgdb_0.7.1.bb +++ b/meta-oe/recipes-devtools/cgdb/cgdb_0.8.0.bb | |||
@@ -9,11 +9,8 @@ DEPENDS = "flex-native readline ncurses" | |||
9 | 9 | ||
10 | inherit autotools texinfo | 10 | inherit autotools texinfo |
11 | 11 | ||
12 | SRC_URI = "http://cgdb.me/files/${BP}.tar.gz \ | 12 | SRC_URI = "http://cgdb.me/files/${BP}.tar.gz" |
13 | file://0001-Avoid-use-of-mips-which-is-reserved-on-mips.patch \ | 13 | SRC_URI[sha256sum] = "0d38b524d377257b106bad6d856d8ae3304140e1ee24085343e6ddf1b65811f1" |
14 | " | ||
15 | SRC_URI[md5sum] = "a104862ffd3145b076303992e9a3af26" | ||
16 | SRC_URI[sha256sum] = "bb723be58ec68cb59a598b8e24a31d10ef31e0e9c277a4de07b2f457fe7de198" | ||
17 | 14 | ||
18 | CACHED_CONFIGUREVARS = "ac_cv_file__dev_ptmx=yes ac_cv_rl_version=6.2 ac_cv_file__proc_self_status=yes" | 15 | CACHED_CONFIGUREVARS = "ac_cv_file__dev_ptmx=yes ac_cv_rl_version=6.2 ac_cv_file__proc_self_status=yes" |
19 | EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR} \ | 16 | EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR} \ |