summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/android-tools
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-10-02 17:33:58 +0000
committerKhem Raj <raj.khem@gmail.com>2018-10-02 17:17:10 -0700
commitff5549841c5c5debae0180574643281d25d4c037 (patch)
treef0ad36c7a5cebe52b8ac64a3be9747c4172280ee /meta-oe/recipes-devtools/android-tools
parent934a034e0ece3527652b6fa84c1590e6f5847073 (diff)
downloadmeta-openembedded-ff5549841c5c5debae0180574643281d25d4c037.tar.gz
android-tools: use patchdir parameter to apply patches
* helps to apply the patches for correct git repo * split remove-selinux-android.patch into 2, because devtool modify fails to apply it across 2 different git repositories: ERROR: Command Error: 'sh -c 'PATCHFILE="remove-selinux-android.patch" git -c user.name="OpenEmbedded" -c user.email="oe.patch@oe" commit -F /tmp/tmpvn7yf20j --author="Sergio Schvezov <sergio.schvezov@canonical.com>" --date="Wed, 7 Sep 2016 12:58:47 +0300"'' exited with 0 Output: On branch devtool Changes not staged for commit: modified: system/core (modified content) modified: system/extras (modified content) no changes added to commit ERROR: Function failed: patch_do_patch ERROR: Logfile of failure stored in: /OE/build/owpb/webos-ports/tmp-glibc/work/aarch64-webos-linux/android-tools/5.1.1.r37-r0/devtooltmp-7qrccor9/temp/log.do_patch.8643 NOTE: Tasks Summary: Attempted 3 tasks of which 0 didn't need to be rerun and 1 failed. NOTE: Writing buildhistory ERROR: Extracting source for android-tools failed * similarly with remove-bionic-android.patch Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/android-tools')
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools/0001-add-base64-implementation.patch16
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools/0002-adb-Musl-fixes.patch32
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools/define-shell-command.patch6
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools/fix-big-endian-build.patch6
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools/implicit-declaration-function-strlcat-strlcopy.patch18
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools/mkbootimg-Add-dt-parameter-to-specify-DT-image.patch12
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools/remove-bionic-android-libselinux.patch16
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools/remove-bionic-android.patch29
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools/remove-selinux-android-extras.patch28
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools/remove-selinux-android.patch29
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools/use-capability.patch6
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools/use-local-socket.patch18
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb26
13 files changed, 127 insertions, 115 deletions
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools/0001-add-base64-implementation.patch b/meta-oe/recipes-devtools/android-tools/android-tools/0001-add-base64-implementation.patch
index 680d21f3a..fa7253a2b 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools/0001-add-base64-implementation.patch
+++ b/meta-oe/recipes-devtools/android-tools/android-tools/0001-add-base64-implementation.patch
@@ -7,15 +7,15 @@ musl needs it
7 7
8Signed-off-by: Khem Raj <raj.khem@gmail.com> 8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9--- 9---
10 system/core/adb/adb_auth_client.c | 2 +- 10 adb/adb_auth_client.c | 2 +-
11 system/core/adb/base64.c | 315 ++++++++++++++++++++++++++++++++++++++ 11 adb/base64.c | 315 ++++++++++++++++++++++++++++++++++++++
12 2 files changed, 316 insertions(+), 1 deletion(-) 12 2 files changed, 316 insertions(+), 1 deletion(-)
13 create mode 100644 system/core/adb/base64.c 13 create mode 100644 adb/base64.c
14 14
15diff --git a/system/core/adb/adb_auth_client.c b/system/core/adb/adb_auth_client.c 15diff --git a/adb/adb_auth_client.c b/adb/adb_auth_client.c
16index 55e9dca..104b413 100644 16index 55e9dca..104b413 100644
17--- a/system/core/adb/adb_auth_client.c 17--- a/adb/adb_auth_client.c
18+++ b/system/core/adb/adb_auth_client.c 18+++ b/adb/adb_auth_client.c
19@@ -75,7 +75,7 @@ static void read_keys(const char *file, struct listnode *list) 19@@ -75,7 +75,7 @@ static void read_keys(const char *file, struct listnode *list)
20 if (sep) 20 if (sep)
21 *sep = '\0'; 21 *sep = '\0';
@@ -25,11 +25,11 @@ index 55e9dca..104b413 100644
25 if (ret != sizeof(key->key)) { 25 if (ret != sizeof(key->key)) {
26 D("%s: Invalid base64 data ret=%d\n", file, ret); 26 D("%s: Invalid base64 data ret=%d\n", file, ret);
27 free(key); 27 free(key);
28diff --git a/system/core/adb/base64.c b/system/core/adb/base64.c 28diff --git a/adb/base64.c b/adb/base64.c
29new file mode 100644 29new file mode 100644
30index 0000000..95da284 30index 0000000..95da284
31--- /dev/null 31--- /dev/null
32+++ b/system/core/adb/base64.c 32+++ b/adb/base64.c
33@@ -0,0 +1,315 @@ 33@@ -0,0 +1,315 @@
34+/* 34+/*
35+ * Copyright (c) 1996-1999 by Internet Software Consortium. 35+ * Copyright (c) 1996-1999 by Internet Software Consortium.
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools/0002-adb-Musl-fixes.patch b/meta-oe/recipes-devtools/android-tools/android-tools/0002-adb-Musl-fixes.patch
index c7aebb641..23feaba81 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools/0002-adb-Musl-fixes.patch
+++ b/meta-oe/recipes-devtools/android-tools/android-tools/0002-adb-Musl-fixes.patch
@@ -9,16 +9,16 @@ Do not redefine close() and lseek()
9 9
10Signed-off-by: Khem Raj <raj.khem@gmail.com> 10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11--- 11---
12 system/core/adb/adb.h | 2 ++ 12 adb/adb.h | 2 ++
13 system/core/adb/disable_verity_service.c | 13 ++++++++----- 13 adb/disable_verity_service.c | 13 ++++++++-----
14 system/core/adb/framebuffer_service.c | 7 ++++--- 14 adb/framebuffer_service.c | 7 ++++---
15 system/core/adb/sysdeps.h | 12 ++++++------ 15 adb/sysdeps.h | 12 ++++++------
16 4 files changed, 20 insertions(+), 14 deletions(-) 16 4 files changed, 20 insertions(+), 14 deletions(-)
17 17
18diff --git a/system/core/adb/adb.h b/system/core/adb/adb.h 18diff --git a/adb/adb.h b/adb/adb.h
19index 44e5981..bcdc49f 100644 19index 44e5981..bcdc49f 100644
20--- a/system/core/adb/adb.h 20--- a/adb/adb.h
21+++ b/system/core/adb/adb.h 21+++ b/adb/adb.h
22@@ -18,7 +18,9 @@ 22@@ -18,7 +18,9 @@
23 #define __ADB_H 23 #define __ADB_H
24 24
@@ -29,10 +29,10 @@ index 44e5981..bcdc49f 100644
29 #include "adb_trace.h" 29 #include "adb_trace.h"
30 #include "transport.h" /* readx(), writex() */ 30 #include "transport.h" /* readx(), writex() */
31 31
32diff --git a/system/core/adb/disable_verity_service.c b/system/core/adb/disable_verity_service.c 32diff --git a/adb/disable_verity_service.c b/adb/disable_verity_service.c
33index ed3da52..29fa3d6 100644 33index ed3da52..29fa3d6 100644
34--- a/system/core/adb/disable_verity_service.c 34--- a/adb/disable_verity_service.c
35+++ b/system/core/adb/disable_verity_service.c 35+++ b/adb/disable_verity_service.c
36@@ -14,25 +14,28 @@ 36@@ -14,25 +14,28 @@
37 * limitations under the License. 37 * limitations under the License.
38 */ 38 */
@@ -67,10 +67,10 @@ index ed3da52..29fa3d6 100644
67 static void write_console(int fd, const char* format, ...) 67 static void write_console(int fd, const char* format, ...)
68 { 68 {
69 char buffer[256]; 69 char buffer[256];
70diff --git a/system/core/adb/framebuffer_service.c b/system/core/adb/framebuffer_service.c 70diff --git a/adb/framebuffer_service.c b/adb/framebuffer_service.c
71index 8cbe840..8f0ccfb 100644 71index 8cbe840..8f0ccfb 100644
72--- a/system/core/adb/framebuffer_service.c 72--- a/adb/framebuffer_service.c
73+++ b/system/core/adb/framebuffer_service.c 73+++ b/adb/framebuffer_service.c
74@@ -14,6 +14,10 @@ 74@@ -14,6 +14,10 @@
75 * limitations under the License. 75 * limitations under the License.
76 */ 76 */
@@ -92,10 +92,10 @@ index 8cbe840..8f0ccfb 100644
92 #include <linux/fb.h> 92 #include <linux/fb.h>
93 #include <sys/ioctl.h> 93 #include <sys/ioctl.h>
94 #include <sys/mman.h> 94 #include <sys/mman.h>
95diff --git a/system/core/adb/sysdeps.h b/system/core/adb/sysdeps.h 95diff --git a/adb/sysdeps.h b/adb/sysdeps.h
96index cc1f839..ea39ac3 100644 96index cc1f839..ea39ac3 100644
97--- a/system/core/adb/sysdeps.h 97--- a/adb/sysdeps.h
98+++ b/system/core/adb/sysdeps.h 98+++ b/adb/sysdeps.h
99@@ -123,8 +123,8 @@ static __inline__ int unix_close(int fd) 99@@ -123,8 +123,8 @@ static __inline__ int unix_close(int fd)
100 { 100 {
101 return close(fd); 101 return close(fd);
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools/define-shell-command.patch b/meta-oe/recipes-devtools/android-tools/android-tools/define-shell-command.patch
index 8381967c4..64edd0d11 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools/define-shell-command.patch
+++ b/meta-oe/recipes-devtools/android-tools/android-tools/define-shell-command.patch
@@ -4,11 +4,11 @@ Author: Fathi Boudra <fabo@debian.org>
4 4
5Upstream-Status: Inappropriate 5Upstream-Status: Inappropriate
6--- 6---
7 system/core/adb/services.c | 4 ---- 7 adb/services.c | 4 ----
8 1 file changed, 4 deletions(-) 8 1 file changed, 4 deletions(-)
9 9
10--- a/system/core/adb/services.c 10--- a/adb/services.c
11+++ b/system/core/adb/services.c 11+++ b/adb/services.c
12@@ -299,11 +299,7 @@ static int create_subproc_raw(const char 12@@ -299,11 +299,7 @@ static int create_subproc_raw(const char
13 } 13 }
14 #endif /* !ABD_HOST */ 14 #endif /* !ABD_HOST */
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools/fix-big-endian-build.patch b/meta-oe/recipes-devtools/android-tools/android-tools/fix-big-endian-build.patch
index 8deaf3a3d..2b91c3baf 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools/fix-big-endian-build.patch
+++ b/meta-oe/recipes-devtools/android-tools/android-tools/fix-big-endian-build.patch
@@ -15,10 +15,10 @@ them to be used when initializing structures.
15 15
16Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> 16Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
17 17
18Index: b/system/core/adb/usb_linux_client.c 18Index: b/adb/usb_linux_client.c
19=================================================================== 19===================================================================
20--- a/system/core/adb/usb_linux_client.c 20--- a/adb/usb_linux_client.c
21+++ b/system/core/adb/usb_linux_client.c 21+++ b/adb/usb_linux_client.c
22@@ -34,8 +34,15 @@ 22@@ -34,8 +34,15 @@
23 #define MAX_PACKET_SIZE_FS 64 23 #define MAX_PACKET_SIZE_FS 64
24 #define MAX_PACKET_SIZE_HS 512 24 #define MAX_PACKET_SIZE_HS 512
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools/implicit-declaration-function-strlcat-strlcopy.patch b/meta-oe/recipes-devtools/android-tools/android-tools/implicit-declaration-function-strlcat-strlcopy.patch
index 64db6168c..f26e5d0cf 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools/implicit-declaration-function-strlcat-strlcopy.patch
+++ b/meta-oe/recipes-devtools/android-tools/android-tools/implicit-declaration-function-strlcat-strlcopy.patch
@@ -3,13 +3,13 @@ Author: Fathi Boudra <fabo@debian.org>
3 3
4Upstream-Status: Inappropriate 4Upstream-Status: Inappropriate
5--- 5---
6 system/core/adb/adb.c | 1 + 6 adb/adb.c | 1 +
7 system/core/fs_mgr/fs_mgr_fstab.c | 2 +- 7 fs_mgr/fs_mgr_fstab.c | 2 +-
8 system/core/include/cutils/sockets.h | 2 +- 8 include/cutils/sockets.h | 2 +-
9 3 files changed, 3 insertions(+), 2 deletions(-) 9 3 files changed, 3 insertions(+), 2 deletions(-)
10 10
11--- a/system/core/fs_mgr/fs_mgr_fstab.c 11--- a/fs_mgr/fs_mgr_fstab.c
12+++ b/system/core/fs_mgr/fs_mgr_fstab.c 12+++ b/fs_mgr/fs_mgr_fstab.c
13@@ -17,7 +17,7 @@ 13@@ -17,7 +17,7 @@
14 #include <ctype.h> 14 #include <ctype.h>
15 #include <stdio.h> 15 #include <stdio.h>
@@ -19,8 +19,8 @@ Upstream-Status: Inappropriate
19 #include <sys/mount.h> 19 #include <sys/mount.h>
20 20
21 #include "fs_mgr_priv.h" 21 #include "fs_mgr_priv.h"
22--- a/system/core/include/cutils/sockets.h 22--- a/include/cutils/sockets.h
23+++ b/system/core/include/cutils/sockets.h 23+++ b/include/cutils/sockets.h
24@@ -19,7 +19,7 @@ 24@@ -19,7 +19,7 @@
25 25
26 #include <errno.h> 26 #include <errno.h>
@@ -30,8 +30,8 @@ Upstream-Status: Inappropriate
30 #include <stdbool.h> 30 #include <stdbool.h>
31 31
32 #ifdef HAVE_WINSOCK 32 #ifdef HAVE_WINSOCK
33--- a/system/core/adb/adb.c 33--- a/adb/adb.c
34+++ b/system/core/adb/adb.c 34+++ b/adb/adb.c
35@@ -41,6 +41,7 @@ 35@@ -41,6 +41,7 @@
36 #include <sys/prctl.h> 36 #include <sys/prctl.h>
37 #include <getopt.h> 37 #include <getopt.h>
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools/mkbootimg-Add-dt-parameter-to-specify-DT-image.patch b/meta-oe/recipes-devtools/android-tools/android-tools/mkbootimg-Add-dt-parameter-to-specify-DT-image.patch
index 35bb766a7..76624d406 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools/mkbootimg-Add-dt-parameter-to-specify-DT-image.patch
+++ b/meta-oe/recipes-devtools/android-tools/android-tools/mkbootimg-Add-dt-parameter-to-specify-DT-image.patch
@@ -10,12 +10,12 @@ Change-Id: Ie29a11cbf4138426bfd19ae486d69a5fcbd8f442
10 10
11Upstream-Status: Inappropriate 11Upstream-Status: Inappropriate
12--- 12---
13 system/core/mkbootimg/bootimg.h | 7 +++++-- 13 mkbootimg/bootimg.h | 7 +++++--
14 system/core/mkbootimg/mkbootimg.c | 21 +++++++++++++++++++++ 14 mkbootimg/mkbootimg.c | 21 +++++++++++++++++++++
15 2 files changed, 26 insertions(+), 2 deletions(-) 15 2 files changed, 26 insertions(+), 2 deletions(-)
16 16
17--- a/system/core/mkbootimg/bootimg.h 17--- a/mkbootimg/bootimg.h
18+++ b/system/core/mkbootimg/bootimg.h 18+++ b/mkbootimg/bootimg.h
19@@ -41,8 +41,8 @@ struct boot_img_hdr 19@@ -41,8 +41,8 @@ struct boot_img_hdr
20 20
21 unsigned tags_addr; /* physical addr for kernel tags */ 21 unsigned tags_addr; /* physical addr for kernel tags */
@@ -41,8 +41,8 @@ Upstream-Status: Inappropriate
41 ** 41 **
42 ** 0. all entities are page_size aligned in flash 42 ** 0. all entities are page_size aligned in flash
43 ** 1. kernel and ramdisk are required (size != 0) 43 ** 1. kernel and ramdisk are required (size != 0)
44--- a/system/core/mkbootimg/mkbootimg.c 44--- a/mkbootimg/mkbootimg.c
45+++ b/system/core/mkbootimg/mkbootimg.c 45+++ b/mkbootimg/mkbootimg.c
46@@ -65,6 +65,7 @@ int usage(void) 46@@ -65,6 +65,7 @@ int usage(void)
47 " [ --board <boardname> ]\n" 47 " [ --board <boardname> ]\n"
48 " [ --base <address> ]\n" 48 " [ --base <address> ]\n"
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools/remove-bionic-android-libselinux.patch b/meta-oe/recipes-devtools/android-tools/android-tools/remove-bionic-android-libselinux.patch
new file mode 100644
index 000000000..7bfb98c44
--- /dev/null
+++ b/meta-oe/recipes-devtools/android-tools/android-tools/remove-bionic-android-libselinux.patch
@@ -0,0 +1,16 @@
1Description: remove bionic specific calls
2Author: Fathi Boudra <fabo@debian.org>
3
4Upstream-Status: Inappropriate
5---
6--- a/src/procattr.c
7+++ b/src/procattr.c
8@@ -8,7 +8,7 @@
9 #include "selinux_internal.h"
10 #include "policy.h"
11
12-#ifdef HOST
13+#ifndef __BIONIC__
14 static pid_t gettid(void)
15 {
16 return syscall(__NR_gettid);
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools/remove-bionic-android.patch b/meta-oe/recipes-devtools/android-tools/android-tools/remove-bionic-android.patch
index e933724cf..93b30cab6 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools/remove-bionic-android.patch
+++ b/meta-oe/recipes-devtools/android-tools/android-tools/remove-bionic-android.patch
@@ -3,13 +3,13 @@ Author: Fathi Boudra <fabo@debian.org>
3 3
4Upstream-Status: Inappropriate 4Upstream-Status: Inappropriate
5--- 5---
6 system/core/include/cutils/properties.h | 1 - 6 include/cutils/properties.h | 1 -
7 system/core/libcutils/properties.c | 2 +- 7 libcutils/properties.c | 2 +-
8 system/core/liblog/logd_write.c | 5 +++++ 8 liblog/logd_write.c | 5 +++++
9 3 files changed, 6 insertions(+), 2 deletions(-) 9 3 files changed, 6 insertions(+), 2 deletions(-)
10 10
11--- a/system/core/include/cutils/properties.h 11--- a/include/cutils/properties.h
12+++ b/system/core/include/cutils/properties.h 12+++ b/include/cutils/properties.h
13@@ -19,7 +19,6 @@ 13@@ -19,7 +19,6 @@
14 14
15 #include <sys/cdefs.h> 15 #include <sys/cdefs.h>
@@ -18,8 +18,8 @@ Upstream-Status: Inappropriate
18 #include <stdint.h> 18 #include <stdint.h>
19 19
20 #ifdef __cplusplus 20 #ifdef __cplusplus
21--- a/system/core/liblog/logd_write.c 21--- a/liblog/logd_write.c
22+++ b/system/core/liblog/logd_write.c 22+++ b/liblog/logd_write.c
23@@ -23,6 +23,7 @@ 23@@ -23,6 +23,7 @@
24 #include <stdlib.h> 24 #include <stdlib.h>
25 #include <string.h> 25 #include <string.h>
@@ -40,8 +40,8 @@ Upstream-Status: Inappropriate
40 40
41 newVec[0].iov_base = (unsigned char *) &log_id_buf; 41 newVec[0].iov_base = (unsigned char *) &log_id_buf;
42 newVec[0].iov_len = sizeof_log_id_t; 42 newVec[0].iov_len = sizeof_log_id_t;
43--- a/system/core/libcutils/properties.c 43--- a/libcutils/properties.c
44+++ b/system/core/libcutils/properties.c 44+++ b/libcutils/properties.c
45@@ -104,10 +104,10 @@ int32_t property_get_int32(const char *k 45@@ -104,10 +104,10 @@ int32_t property_get_int32(const char *k
46 return (int32_t)property_get_imax(key, INT32_MIN, INT32_MAX, default_value); 46 return (int32_t)property_get_imax(key, INT32_MIN, INT32_MAX, default_value);
47 } 47 }
@@ -54,14 +54,3 @@ Upstream-Status: Inappropriate
54 54
55 int property_set(const char *key, const char *value) 55 int property_set(const char *key, const char *value)
56 { 56 {
57--- a/external/libselinux/src/procattr.c
58+++ b/external/libselinux/src/procattr.c
59@@ -8,7 +8,7 @@
60 #include "selinux_internal.h"
61 #include "policy.h"
62
63-#ifdef HOST
64+#ifndef __BIONIC__
65 static pid_t gettid(void)
66 {
67 return syscall(__NR_gettid);
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools/remove-selinux-android-extras.patch b/meta-oe/recipes-devtools/android-tools/android-tools/remove-selinux-android-extras.patch
new file mode 100644
index 000000000..c52d935f5
--- /dev/null
+++ b/meta-oe/recipes-devtools/android-tools/android-tools/remove-selinux-android-extras.patch
@@ -0,0 +1,28 @@
1Subject: drop useless includes of Android SELINUX extensions; avoids having to clone another module; this should be sent upstream
2Author: Sergio Schvezov <sergio.schvezov@canonical.com>
3
4Upstream-Status: Inappropriate
5---
6 ext4_utils/make_ext4fs.c | 1 -
7 ext4_utils/make_ext4fs_main.c | 1 -
8
9--- a/ext4_utils/make_ext4fs.c
10+++ b/ext4_utils/make_ext4fs.c
11@@ -62,7 +62,6 @@
12
13 #include <selinux/selinux.h>
14 #include <selinux/label.h>
15-#include <selinux/android.h>
16
17 #define O_BINARY 0
18
19--- a/ext4_utils/make_ext4fs_main.c
20+++ b/ext4_utils/make_ext4fs_main.c
21@@ -32,7 +32,6 @@
22 #ifndef USE_MINGW
23 #include <selinux/selinux.h>
24 #include <selinux/label.h>
25-#include <selinux/android.h>
26 #else
27 struct selabel_handle;
28 #endif
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools/remove-selinux-android.patch b/meta-oe/recipes-devtools/android-tools/android-tools/remove-selinux-android.patch
index d4a37f82b..bc0dd4a2e 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools/remove-selinux-android.patch
+++ b/meta-oe/recipes-devtools/android-tools/android-tools/remove-selinux-android.patch
@@ -3,33 +3,10 @@ Author: Sergio Schvezov <sergio.schvezov@canonical.com>
3 3
4Upstream-Status: Inappropriate 4Upstream-Status: Inappropriate
5--- 5---
6 system/core/adb/file_sync_service.c | 3 --- 6 adb/file_sync_service.c | 3 ---
7 system/extras/ext4_utils/make_ext4fs.c | 1 -
8 system/extras/ext4_utils/make_ext4fs_main.c | 1 -
9 3 files changed, 5 deletions(-)
10 7
11--- a/system/extras/ext4_utils/make_ext4fs.c 8--- a/adb/file_sync_service.c
12+++ b/system/extras/ext4_utils/make_ext4fs.c 9+++ b/adb/file_sync_service.c
13@@ -62,7 +62,6 @@
14
15 #include <selinux/selinux.h>
16 #include <selinux/label.h>
17-#include <selinux/android.h>
18
19 #define O_BINARY 0
20
21--- a/system/extras/ext4_utils/make_ext4fs_main.c
22+++ b/system/extras/ext4_utils/make_ext4fs_main.c
23@@ -32,7 +32,6 @@
24 #ifndef USE_MINGW
25 #include <selinux/selinux.h>
26 #include <selinux/label.h>
27-#include <selinux/android.h>
28 #else
29 struct selabel_handle;
30 #endif
31--- a/system/core/adb/file_sync_service.c
32+++ b/system/core/adb/file_sync_service.c
33@@ -26,7 +26,6 @@ 10@@ -26,7 +26,6 @@
34 11
35 #include <errno.h> 12 #include <errno.h>
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools/use-capability.patch b/meta-oe/recipes-devtools/android-tools/android-tools/use-capability.patch
index b8ebe09dc..aef2ac2c1 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools/use-capability.patch
+++ b/meta-oe/recipes-devtools/android-tools/android-tools/use-capability.patch
@@ -3,11 +3,11 @@ Author: Loïc Minier <loic.minier@ubuntu.com>
3 3
4Upstream-Status: Inappropriate 4Upstream-Status: Inappropriate
5--- 5---
6 system/core/include/private/android_filesystem_config.h | 2 +- 6 include/private/android_filesystem_config.h | 2 +-
7 1 file changed, 1 insertion(+), 1 deletion(-) 7 1 file changed, 1 insertion(+), 1 deletion(-)
8 8
9--- a/system/core/include/private/android_filesystem_config.h 9--- a/include/private/android_filesystem_config.h
10+++ b/system/core/include/private/android_filesystem_config.h 10+++ b/include/private/android_filesystem_config.h
11@@ -27,7 +27,7 @@ 11@@ -27,7 +27,7 @@
12 #include <sys/types.h> 12 #include <sys/types.h>
13 #include <stdint.h> 13 #include <stdint.h>
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools/use-local-socket.patch b/meta-oe/recipes-devtools/android-tools/android-tools/use-local-socket.patch
index 7facd61b9..0ff37e038 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools/use-local-socket.patch
+++ b/meta-oe/recipes-devtools/android-tools/android-tools/use-local-socket.patch
@@ -3,13 +3,13 @@ Author: Hilko Bengen <bengen@debian.org>
3 3
4Upstream-Status: Inappropriate 4Upstream-Status: Inappropriate
5--- 5---
6 system/core/adb/adb.c | 6 +++++- 6 adb/adb.c | 6 +++++-
7 system/core/adb/adb_client.c | 5 +++-- 7 adb/adb_client.c | 5 +++--
8 system/core/adb/transport_local.c | 3 ++- 8 adb/transport_local.c | 3 ++-
9 3 files changed, 10 insertions(+), 4 deletions(-) 9 3 files changed, 10 insertions(+), 4 deletions(-)
10 10
11--- a/system/core/adb/adb.c 11--- a/adb/adb.c
12+++ b/system/core/adb/adb.c 12+++ b/adb/adb.c
13@@ -1230,7 +1230,11 @@ int launch_server(int server_port) 13@@ -1230,7 +1230,11 @@ int launch_server(int server_port)
14 */ 14 */
15 void build_local_name(char* target_str, size_t target_size, int server_port) 15 void build_local_name(char* target_str, size_t target_size, int server_port)
@@ -23,8 +23,8 @@ Upstream-Status: Inappropriate
23 } 23 }
24 24
25 #if !ADB_HOST 25 #if !ADB_HOST
26--- a/system/core/adb/adb_client.c 26--- a/adb/adb_client.c
27+++ b/system/core/adb/adb_client.c 27+++ b/adb/adb_client.c
28@@ -185,12 +185,12 @@ int _adb_connect(const char *service) 28@@ -185,12 +185,12 @@ int _adb_connect(const char *service)
29 strcpy(__adb_error, "service name too long"); 29 strcpy(__adb_error, "service name too long");
30 return -1; 30 return -1;
@@ -48,8 +48,8 @@ Upstream-Status: Inappropriate
48 if(writex(fd, tmp, 4) || writex(fd, service, len)) { 48 if(writex(fd, tmp, 4) || writex(fd, service, len)) {
49 strcpy(__adb_error, "write failure during connection"); 49 strcpy(__adb_error, "write failure during connection");
50 adb_close(fd); 50 adb_close(fd);
51--- a/system/core/adb/transport_local.c 51--- a/adb/transport_local.c
52+++ b/system/core/adb/transport_local.c 52+++ b/adb/transport_local.c
53@@ -121,7 +121,8 @@ int local_connect_arbitrary_ports(int co 53@@ -121,7 +121,8 @@ int local_connect_arbitrary_ports(int co
54 } 54 }
55 #endif 55 #endif
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
index 74f2bf221..1478c1205 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
+++ b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
@@ -30,17 +30,21 @@ SRC_URI = " \
30 git://${LIBHARDWARE_REPO};name=libhardware;protocol=https;nobranch=1;destsuffix=git/hardware/libhardware \ 30 git://${LIBHARDWARE_REPO};name=libhardware;protocol=https;nobranch=1;destsuffix=git/hardware/libhardware \
31 git://${LIBSELINUX_REPO};name=libselinux;protocol=https;nobranch=1;destsuffix=git/external/libselinux \ 31 git://${LIBSELINUX_REPO};name=libselinux;protocol=https;nobranch=1;destsuffix=git/external/libselinux \
32 git://${BUILD_REPO};name=build;protocol=https;nobranch=1;destsuffix=git/build \ 32 git://${BUILD_REPO};name=build;protocol=https;nobranch=1;destsuffix=git/build \
33 file://remove-selinux-android.patch \ 33 file://remove-selinux-android.patch;patchdir=system/core \
34 file://use-capability.patch \ 34 file://use-capability.patch;patchdir=system/core \
35 file://use-local-socket.patch \ 35 file://use-local-socket.patch;patchdir=system/core \
36 file://mkbootimg-Add-dt-parameter-to-specify-DT-image.patch;patchdir=system/core \
37 file://remove-bionic-android.patch;patchdir=system/core \
38 file://define-shell-command.patch;patchdir=system/core \
39 file://implicit-declaration-function-strlcat-strlcopy.patch;patchdir=system/core \
40 file://fix-big-endian-build.patch;patchdir=system/core \
41 file://0001-add-base64-implementation.patch;patchdir=system/core \
42 file://0002-adb-Musl-fixes.patch;patchdir=system/core \
43 file://0001-usb_linux.c-fix-build-with-glibc-2.28.patch;patchdir=system/core \
44 file://0001-Allow-adbd-to-be-ran-as-root.patch;patchdir=system/core \
45 file://remove-selinux-android-extras.patch;patchdir=system/extras \
36 file://preserve-ownership.patch;patchdir=system/extras \ 46 file://preserve-ownership.patch;patchdir=system/extras \
37 file://mkbootimg-Add-dt-parameter-to-specify-DT-image.patch \ 47 file://remove-bionic-android-libselinux.patch;patchdir=external/libselinux \
38 file://remove-bionic-android.patch \
39 file://define-shell-command.patch \
40 file://implicit-declaration-function-strlcat-strlcopy.patch \
41 file://fix-big-endian-build.patch \
42 file://0001-add-base64-implementation.patch \
43 file://0002-adb-Musl-fixes.patch \
44 file://android-tools-adbd.service \ 48 file://android-tools-adbd.service \
45 file://.gitignore;subdir=git \ 49 file://.gitignore;subdir=git \
46 file://adb.mk;subdir=${BPN} \ 50 file://adb.mk;subdir=${BPN} \
@@ -48,8 +52,6 @@ SRC_URI = " \
48 file://ext4_utils.mk;subdir=${BPN} \ 52 file://ext4_utils.mk;subdir=${BPN} \
49 file://fastboot.mk;subdir=${BPN} \ 53 file://fastboot.mk;subdir=${BPN} \
50 file://mkbootimg.mk;subdir=${BPN} \ 54 file://mkbootimg.mk;subdir=${BPN} \
51 file://0001-usb_linux.c-fix-build-with-glibc-2.28.patch;patchdir=system/core \
52 file://0001-Allow-adbd-to-be-ran-as-root.patch;patchdir=system/core \
53" 55"
54 56
55S = "${WORKDIR}/git" 57S = "${WORKDIR}/git"