summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-02-05 00:15:25 -0800
committerKhem Raj <raj.khem@gmail.com>2019-02-05 16:43:12 -0800
commit4603ff9745a03a679b7666817607b442855441e1 (patch)
treef2ed85dd08e98ef741772815da8038c6f2e7925a /meta-oe/recipes-dbs
parent984526c4b830b446d01dddf00b5ef1809e535573 (diff)
downloadmeta-openembedded-4603ff9745a03a679b7666817607b442855441e1.tar.gz
mongodb: Upgrade to 4.0.6
Change License to SSPL version 1 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs')
-rw-r--r--meta-oe/recipes-dbs/mongodb/mongodb/disable-hw-crc32-on-arm64-s390x.patch50
-rw-r--r--meta-oe/recipes-dbs/mongodb/mongodb_git.bb11
2 files changed, 5 insertions, 56 deletions
diff --git a/meta-oe/recipes-dbs/mongodb/mongodb/disable-hw-crc32-on-arm64-s390x.patch b/meta-oe/recipes-dbs/mongodb/mongodb/disable-hw-crc32-on-arm64-s390x.patch
deleted file mode 100644
index 23d4923d2..000000000
--- a/meta-oe/recipes-dbs/mongodb/mongodb/disable-hw-crc32-on-arm64-s390x.patch
+++ /dev/null
@@ -1,50 +0,0 @@
1imported from debian
2
3Upstream-Status: Pending
4Index: git/src/third_party/wiredtiger/SConscript
5===================================================================
6--- git.orig/src/third_party/wiredtiger/SConscript
7+++ git/src/third_party/wiredtiger/SConscript
8@@ -181,7 +181,9 @@ if useSnappy:
9 # If not available at runtime, we fall back to software in some cases.
10 #
11 # On zSeries we may disable because SLES 11 kernel doe not support the instructions.
12-if not (env['TARGET_ARCH'] == 's390x' and get_option("use-s390x-crc32") == "off"):
13+# Debian: disable hardware-assisted crc32 on s390x and arm64, as at least the
14+# buildd's do not support the instructions.
15+if env['TARGET_ARCH'] not in ('s390x', 'arm64', 'aarch64'):
16 env.Append(CPPDEFINES=["HAVE_CRC32_HARDWARE"])
17
18 wtlib = env.Library(
19Index: git/src/third_party/wiredtiger/dist/filelist
20===================================================================
21--- git.orig/src/third_party/wiredtiger/dist/filelist
22+++ git/src/third_party/wiredtiger/dist/filelist
23@@ -54,7 +54,6 @@ src/checksum/power8/crc32_wrapper.c POWE
24 src/checksum/software/checksum.c
25 src/checksum/x86/crc32-x86.c X86_HOST
26 src/checksum/zseries/crc32-s390x.c ZSERIES_HOST
27-src/checksum/zseries/crc32le-vx.sx ZSERIES_HOST
28 src/config/config.c
29 src/config/config_api.c
30 src/config/config_check.c
31Index: git/src/third_party/wiredtiger/src/checksum/zseries/crc32-s390x.c
32===================================================================
33--- git.orig/src/third_party/wiredtiger/src/checksum/zseries/crc32-s390x.c
34+++ git/src/third_party/wiredtiger/src/checksum/zseries/crc32-s390x.c
35@@ -77,6 +77,7 @@ unsigned int __wt_crc32c_le(unsigned int
36 return crc; \
37 }
38
39+#if defined(HAVE_CRC32_HARDWARE)
40 /* Main CRC-32 functions */
41 DEFINE_CRC32_VX(__wt_crc32c_le_vx, __wt_crc32c_le_vgfm_16, __wt_crc32c_le)
42
43@@ -89,6 +90,7 @@ __wt_checksum_hw(const void *chunk, size
44 {
45 return (~__wt_crc32c_le_vx(0xffffffff, chunk, len));
46 }
47+#endif
48
49 #endif
50
diff --git a/meta-oe/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/recipes-dbs/mongodb/mongodb_git.bb
index d39ab0a31..6494e25bf 100644
--- a/meta-oe/recipes-dbs/mongodb/mongodb_git.bb
+++ b/meta-oe/recipes-dbs/mongodb/mongodb_git.bb
@@ -1,6 +1,6 @@
1SUMMARY = "mongodb" 1SUMMARY = "mongodb"
2LICENSE = "AGPL-3.0 & Apache-2.0 & Zlib" 2LICENSE = "SSPL-1 & Apache-2.0 & Zlib"
3LIC_FILES_CHKSUM = "file://GNU-AGPL-3.0.txt;md5=73f1eb20517c55bf9493b7dd6e480788 \ 3LIC_FILES_CHKSUM = "file://LICENSE-Community.txt;md5=3a865f27f11f43ecbe542d9ea387dcf1 \
4 file://APACHE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" 4 file://APACHE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
5 5
6DEPENDS = "openssl libpcre libpcap zlib boost curl python \ 6DEPENDS = "openssl libpcre libpcap zlib boost curl python \
@@ -10,9 +10,9 @@ DEPENDS = "openssl libpcre libpcap zlib boost curl python \
10 10
11inherit scons dos2unix siteinfo pythonnative 11inherit scons dos2unix siteinfo pythonnative
12 12
13PV = "4.0.1+git${SRCPV}" 13PV = "4.0.6+git${SRCPV}"
14#v4.0.1 14#v4.0.6
15SRCREV = "54f1582fc6eb01de4d4c42f26fc133e623f065fb" 15SRCREV = "caa42a1f75a56c7643d0b68d3880444375ec42e3"
16SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.0 \ 16SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.0 \
17 file://0001-Tell-scons-to-use-build-settings-from-environment-va.patch \ 17 file://0001-Tell-scons-to-use-build-settings-from-environment-va.patch \
18 file://0001-Use-long-long-instead-of-int64_t.patch \ 18 file://0001-Use-long-long-instead-of-int64_t.patch \
@@ -20,7 +20,6 @@ SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.0 \
20 file://0002-Add-a-definition-for-the-macro-__ELF_NATIVE_CLASS.patch \ 20 file://0002-Add-a-definition-for-the-macro-__ELF_NATIVE_CLASS.patch \
21 file://arm64-support.patch \ 21 file://arm64-support.patch \
22 file://0001-IntelRDFPMathLib20U1-Check-for-__DEFINED_wchar_t.patch \ 22 file://0001-IntelRDFPMathLib20U1-Check-for-__DEFINED_wchar_t.patch \
23 file://disable-hw-crc32-on-arm64-s390x.patch \
24 file://0001-Support-deprecated-resolver-functions.patch \ 23 file://0001-Support-deprecated-resolver-functions.patch \
25 " 24 "
26SRC_URI_append_libc-musl ="\ 25SRC_URI_append_libc-musl ="\