summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-01-11 11:54:36 +0100
committerKhem Raj <raj.khem@gmail.com>2019-01-11 07:48:30 -0800
commit26b1bd209707f356e5a3508558901612f47adba8 (patch)
tree390f063c2fdad79b214762674b0caa05132be9cd /meta-oe/recipes-dbs
parentf090f37590ed383f0d03c046e4e08d685f95c318 (diff)
downloadmeta-openembedded-26b1bd209707f356e5a3508558901612f47adba8.tar.gz
postgresql: correctly build against target perl
Previously perl-native headers were erroneously included, which was causing issues with the new perl recipe. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs')
-rw-r--r--meta-oe/recipes-dbs/postgresql/postgresql.inc8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql.inc b/meta-oe/recipes-dbs/postgresql/postgresql.inc
index dc8522454..85f19170b 100644
--- a/meta-oe/recipes-dbs/postgresql/postgresql.inc
+++ b/meta-oe/recipes-dbs/postgresql/postgresql.inc
@@ -37,7 +37,7 @@ LEAD_SONAME = "libpq.so"
37# LDFLAGS for shared libraries 37# LDFLAGS for shared libraries
38export LDFLAGS_SL = "${LDFLAGS}" 38export LDFLAGS_SL = "${LDFLAGS}"
39 39
40inherit autotools pkgconfig perlnative pythonnative useradd update-rc.d systemd gettext 40inherit autotools pkgconfig perlnative pythonnative useradd update-rc.d systemd gettext cpan-base
41 41
42CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR} -I${STAGING_INCDIR}/tcl8.6" 42CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR} -I${STAGING_INCDIR}/tcl8.6"
43 43
@@ -106,6 +106,10 @@ python populate_packages_prepend() {
106 106
107} 107}
108 108
109# This will make native perl use target settings (for include dirs etc.)
110export PERLCONFIGTARGET = "${@is_target(d)}"
111export PERL_ARCHLIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl5/${@get_perl_version(d)}/${@get_perl_arch(d)}"
112
109do_configure() { 113do_configure() {
110 # do_configure 114 # do_configure
111 autotools_do_configure 115 autotools_do_configure
@@ -119,7 +123,7 @@ do_configure() {
119 BLIBNA="\${STAGING_BASE_LIBDIR_NATIVE}" 123 BLIBNA="\${STAGING_BASE_LIBDIR_NATIVE}"
120 sed -i -e "/^perl_archlibexp/s:${LIBPNA}:${STAGING_LIBDIR}:g" \ 124 sed -i -e "/^perl_archlibexp/s:${LIBPNA}:${STAGING_LIBDIR}:g" \
121 ${B}/src/Makefile.global 125 ${B}/src/Makefile.global
122 sed -i -e "/^perl_privlibexp/s:${LIBPNA}:${STAGING_LIBDIR}:g" \ 126 sed -i -e "/^perl_privlibexp/s:${libdir}:${STAGING_LIBDIR}:g" \
123 ${B}/src/Makefile.global 127 ${B}/src/Makefile.global
124 # remove the rpath, replace with correct lib path 128 # remove the rpath, replace with correct lib path
125 sed -i \ 129 sed -i \