diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-11-03 15:56:22 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-11-05 09:42:50 -0800 |
commit | fd57ac6162253c6fbdcfdb33ab661311c8d612f6 (patch) | |
tree | db83508e1a139f5a66394975b38fb615f795cd39 /meta-oe/recipes-dbs | |
parent | 7e0b56f3c63e844f6a5133a5cefcad1f09f2ba85 (diff) | |
download | meta-openembedded-fd57ac6162253c6fbdcfdb33ab661311c8d612f6.tar.gz |
postgresql: Add tclsh 9 support
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs')
3 files changed, 28 insertions, 1 deletions
diff --git a/meta-oe/recipes-dbs/postgresql/files/0001-tcl.m4-Recognize-tclsh9.patch b/meta-oe/recipes-dbs/postgresql/files/0001-tcl.m4-Recognize-tclsh9.patch new file mode 100644 index 000000000..89a509087 --- /dev/null +++ b/meta-oe/recipes-dbs/postgresql/files/0001-tcl.m4-Recognize-tclsh9.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From f0d8240dbf594e6dfab31fd7d70ce340ac365a65 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 3 Nov 2024 15:50:50 -0800 | ||
4 | Subject: [PATCH] tcl.m4: Recognize tclsh9 | ||
5 | |||
6 | Add missing support to recognize tclsh9 as supported | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | config/tcl.m4 | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/config/tcl.m4 b/config/tcl.m4 | ||
15 | index 9de31a5..568fd45 100644 | ||
16 | --- a/config/tcl.m4 | ||
17 | +++ b/config/tcl.m4 | ||
18 | @@ -4,7 +4,7 @@ | ||
19 | |||
20 | |||
21 | AC_DEFUN([PGAC_PATH_TCLSH], | ||
22 | -[PGAC_PATH_PROGS(TCLSH, [tclsh tcl tclsh8.6 tclsh86 tclsh8.5 tclsh85 tclsh8.4 tclsh84]) | ||
23 | +[PGAC_PATH_PROGS(TCLSH, [tclsh tcl tclsh9.0 tclsh90 tclsh8.6 tclsh86 tclsh8.5 tclsh85 tclsh8.4 tclsh84]) | ||
24 | AC_ARG_VAR(TCLSH, [Tcl interpreter program (tclsh)])dnl | ||
25 | if test x"$TCLSH" = x""; then | ||
26 | AC_MSG_ERROR([Tcl shell not found]) | ||
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql.inc b/meta-oe/recipes-dbs/postgresql/postgresql.inc index fb3bca272..ec5daeaa6 100644 --- a/meta-oe/recipes-dbs/postgresql/postgresql.inc +++ b/meta-oe/recipes-dbs/postgresql/postgresql.inc | |||
@@ -39,7 +39,7 @@ export LDFLAGS_EX_BE = "-Wl,--export-dynamic" | |||
39 | 39 | ||
40 | inherit autotools pkgconfig perlnative python3native python3targetconfig useradd update-rc.d systemd gettext perl-version multilib_header | 40 | inherit autotools pkgconfig perlnative python3native python3targetconfig useradd update-rc.d systemd gettext perl-version multilib_header |
41 | 41 | ||
42 | CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR} -I${STAGING_INCDIR}/tcl8.6" | 42 | CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR}" |
43 | 43 | ||
44 | SYSTEMD_SERVICE:${PN} = "postgresql.service" | 44 | SYSTEMD_SERVICE:${PN} = "postgresql.service" |
45 | SYSTEMD_AUTO_ENABLE:${PN} = "disable" | 45 | SYSTEMD_AUTO_ENABLE:${PN} = "disable" |
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql_16.4.bb b/meta-oe/recipes-dbs/postgresql/postgresql_16.4.bb index 1a47369e4..7135263da 100644 --- a/meta-oe/recipes-dbs/postgresql/postgresql_16.4.bb +++ b/meta-oe/recipes-dbs/postgresql/postgresql_16.4.bb | |||
@@ -9,6 +9,7 @@ SRC_URI += "\ | |||
9 | file://0003-configure.ac-bypass-autoconf-2.69-version-check.patch \ | 9 | file://0003-configure.ac-bypass-autoconf-2.69-version-check.patch \ |
10 | file://0004-config_info.c-not-expose-build-info.patch \ | 10 | file://0004-config_info.c-not-expose-build-info.patch \ |
11 | file://0005-postgresql-fix-ptest-failure-of-sysviews.patch \ | 11 | file://0005-postgresql-fix-ptest-failure-of-sysviews.patch \ |
12 | file://0001-tcl.m4-Recognize-tclsh9.patch \ | ||
12 | " | 13 | " |
13 | 14 | ||
14 | SRC_URI[sha256sum] = "971766d645aa73e93b9ef4e3be44201b4f45b5477095b049125403f9f3386d6f" | 15 | SRC_URI[sha256sum] = "971766d645aa73e93b9ef4e3be44201b4f45b5477095b049125403f9f3386d6f" |