diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-02-05 00:23:41 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-02-05 16:43:12 -0800 |
commit | cde3ede254ef5c15b4940c6b425e2f5ab25c853b (patch) | |
tree | 2f43b03c72512430f791c3859d5b578b69dd5bad /meta-oe/recipes-dbs/mongodb | |
parent | 4603ff9745a03a679b7666817607b442855441e1 (diff) | |
download | meta-openembedded-cde3ede254ef5c15b4940c6b425e2f5ab25c853b.tar.gz |
mongodb: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs/mongodb')
-rw-r--r-- | meta-oe/recipes-dbs/mongodb/mongodb/0001-asio-Dont-use-experimental-with-clang.patch | 28 | ||||
-rw-r--r-- | meta-oe/recipes-dbs/mongodb/mongodb_git.bb | 1 |
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-dbs/mongodb/mongodb/0001-asio-Dont-use-experimental-with-clang.patch b/meta-oe/recipes-dbs/mongodb/mongodb/0001-asio-Dont-use-experimental-with-clang.patch new file mode 100644 index 000000000..b597422e4 --- /dev/null +++ b/meta-oe/recipes-dbs/mongodb/mongodb/0001-asio-Dont-use-experimental-with-clang.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 31ca5c563f1d9a3f70258be3dd2b1e547a65a550 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 5 Feb 2019 00:21:12 -0800 | ||
4 | Subject: [PATCH] asio: Dont use experimental with clang | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | .../asio-master/asio/include/asio/detail/string_view.hpp | 4 ++-- | ||
9 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
10 | |||
11 | diff --git a/src/third_party/asio-master/asio/include/asio/detail/string_view.hpp b/src/third_party/asio-master/asio/include/asio/detail/string_view.hpp | ||
12 | index 222c02186d..3bf7494529 100644 | ||
13 | --- a/src/third_party/asio-master/asio/include/asio/detail/string_view.hpp | ||
14 | +++ b/src/third_party/asio-master/asio/include/asio/detail/string_view.hpp | ||
15 | @@ -28,8 +28,8 @@ | ||
16 | namespace asio { | ||
17 | |||
18 | #if defined(ASIO_HAS_STD_EXPERIMENTAL_STRING_VIEW) | ||
19 | -using std::experimental::basic_string_view; | ||
20 | -using std::experimental::string_view; | ||
21 | +using std::basic_string_view; | ||
22 | +using std::string_view; | ||
23 | #else // defined(ASIO_HAS_STD_EXPERIMENTAL_STRING_VIEW) | ||
24 | using std::basic_string_view; | ||
25 | using std::string_view; | ||
26 | -- | ||
27 | 2.20.1 | ||
28 | |||
diff --git a/meta-oe/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/recipes-dbs/mongodb/mongodb_git.bb index 6494e25bf..53a9f6611 100644 --- a/meta-oe/recipes-dbs/mongodb/mongodb_git.bb +++ b/meta-oe/recipes-dbs/mongodb/mongodb_git.bb | |||
@@ -21,6 +21,7 @@ SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.0 \ | |||
21 | file://arm64-support.patch \ | 21 | file://arm64-support.patch \ |
22 | file://0001-IntelRDFPMathLib20U1-Check-for-__DEFINED_wchar_t.patch \ | 22 | file://0001-IntelRDFPMathLib20U1-Check-for-__DEFINED_wchar_t.patch \ |
23 | file://0001-Support-deprecated-resolver-functions.patch \ | 23 | file://0001-Support-deprecated-resolver-functions.patch \ |
24 | file://0001-asio-Dont-use-experimental-with-clang.patch \ | ||
24 | " | 25 | " |
25 | SRC_URI_append_libc-musl ="\ | 26 | SRC_URI_append_libc-musl ="\ |
26 | file://0002-Fix-default-stack-size-to-256K.patch \ | 27 | file://0002-Fix-default-stack-size-to-256K.patch \ |