summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs/mongodb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-10-07 20:03:34 -0700
committerKhem Raj <raj.khem@gmail.com>2019-10-08 00:54:56 -0700
commit31161b5fee5ae8616f18e135990fd27838c7a6ad (patch)
treeddb59c6f350b0e6624a4a2780c0c63cfb2b7bf72 /meta-oe/recipes-dbs/mongodb
parentfb0a590c4a21c7303de6f0b048bbc648b0e7f5f5 (diff)
downloadmeta-openembedded-31161b5fee5ae8616f18e135990fd27838c7a6ad.tar.gz
mongodb: Turn system libpcre support into packageconfig
when libpcre is built with clang and mongodb with gcc then they dont link well, in such cases its better to use in-tree pcre, this paves a way to achieve that if needed Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs/mongodb')
-rw-r--r--meta-oe/recipes-dbs/mongodb/mongodb_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/recipes-dbs/mongodb/mongodb_git.bb
index e7e03a4e1..cd8ccdc8a 100644
--- a/meta-oe/recipes-dbs/mongodb/mongodb_git.bb
+++ b/meta-oe/recipes-dbs/mongodb/mongodb_git.bb
@@ -3,7 +3,7 @@ LICENSE = "SSPL-1 & Apache-2.0 & Zlib"
3LIC_FILES_CHKSUM = "file://LICENSE-Community.txt;md5=3a865f27f11f43ecbe542d9ea387dcf1 \ 3LIC_FILES_CHKSUM = "file://LICENSE-Community.txt;md5=3a865f27f11f43ecbe542d9ea387dcf1 \
4 file://APACHE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" 4 file://APACHE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
5 5
6DEPENDS = "openssl libpcre libpcap zlib boost curl python3 \ 6DEPENDS = "openssl libpcap zlib boost curl python3 \
7 python3-setuptools-native \ 7 python3-setuptools-native \
8 python3-pyyaml-native python3-cheetah-native \ 8 python3-pyyaml-native python3-cheetah-native \
9 python3-psutil-native python3-regex-native \ 9 python3-psutil-native python3-regex-native \
@@ -38,7 +38,7 @@ S = "${WORKDIR}/git"
38 38
39COMPATIBLE_HOST ?= '(x86_64|powerpc64|aarch64).*-linux' 39COMPATIBLE_HOST ?= '(x86_64|powerpc64|aarch64).*-linux'
40 40
41PACKAGECONFIG ??= "tcmalloc" 41PACKAGECONFIG ??= "tcmalloc system-pcre"
42# gperftools compilation fails for arm below v7 because of missing support of 42# gperftools compilation fails for arm below v7 because of missing support of
43# dmb operation. So we use system-allocator instead of tcmalloc 43# dmb operation. So we use system-allocator instead of tcmalloc
44PACKAGECONFIG_remove_armv6 = "tcmalloc" 44PACKAGECONFIG_remove_armv6 = "tcmalloc"
@@ -46,6 +46,7 @@ PACKAGECONFIG_remove_libc-musl = "tcmalloc"
46 46
47PACKAGECONFIG[tcmalloc] = "--use-system-tcmalloc,--allocator=system,gperftools," 47PACKAGECONFIG[tcmalloc] = "--use-system-tcmalloc,--allocator=system,gperftools,"
48PACKAGECONFIG[shell] = ",--js-engine=none,," 48PACKAGECONFIG[shell] = ",--js-engine=none,,"
49PACKAGECONFIG[system-pcre] = "--use-system-pcre,,libpcre,"
49 50
50EXTRA_OESCONS = "--prefix=${D}${prefix} \ 51EXTRA_OESCONS = "--prefix=${D}${prefix} \
51 LIBPATH=${STAGING_LIBDIR} \ 52 LIBPATH=${STAGING_LIBDIR} \
@@ -54,7 +55,6 @@ EXTRA_OESCONS = "--prefix=${D}${prefix} \
54 TARGET_ARCH=${TARGET_ARCH} \ 55 TARGET_ARCH=${TARGET_ARCH} \
55 --ssl \ 56 --ssl \
56 --disable-warnings-as-errors \ 57 --disable-warnings-as-errors \
57 --use-system-pcre \
58 --use-system-zlib \ 58 --use-system-zlib \
59 --nostrip \ 59 --nostrip \
60 --endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \ 60 --endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \