summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-crypto
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2021-06-18 19:28:47 +0200
committerKhem Raj <raj.khem@gmail.com>2021-06-28 09:03:34 -0700
commit497602b4840720e8351ecf961ac6f85103093750 (patch)
treeb4bca26c3e918409693a8448422950b182aa36f7 /meta-oe/recipes-crypto
parent5abdb2dab0c77dda9465dafd313d2932086f81c5 (diff)
downloadmeta-openembedded-497602b4840720e8351ecf961ac6f85103093750.tar.gz
cryptsetup: Only recommend kernel modules when building for target
Otherwise cryptsetup-native depends on the target kernel and thus the target compiler, as can be seen by: $ bitbake -g cryptsetup-native $ grep 'cryptsetup.*linux-yocto' task-depends.dot "cryptsetup-native.do_build" -> "linux-yocto.do_deploy" "cryptsetup-native.do_build" -> "linux-yocto.do_package_write_rpm" "cryptsetup-native.do_populate_sysroot" -> "linux-yocto.do_populate_sysroot" $ grep 'linux-yocto.*gcc-cross' task-depends.dot "linux-yocto.do_kernel_configme" -> "gcc-cross-x86_64.do_populate_sysroot" "linux-yocto.do_prepare_recipe_sysroot" -> "gcc-cross-x86_64.do_populate_sysroot" This also moves the runtime dependencies to near the end of the recipe, which is more customary. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-crypto')
-rw-r--r--meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.3.6.bb25
1 files changed, 13 insertions, 12 deletions
diff --git a/meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.3.6.bb b/meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.3.6.bb
index 562ac83fb..9e83b90ea 100644
--- a/meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.3.6.bb
+++ b/meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.3.6.bb
@@ -16,10 +16,6 @@ DEPENDS = " \
16 util-linux-libuuid \ 16 util-linux-libuuid \
17" 17"
18 18
19RDEPENDS_${PN} = " \
20 libdevmapper \
21"
22
23SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/v${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}/${BP}.tar.xz" 19SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/v${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}/${BP}.tar.xz"
24SRC_URI[md5sum] = "504d1ab22cbc4d1a59a8d8c7ee5ed3bf" 20SRC_URI[md5sum] = "504d1ab22cbc4d1a59a8d8c7ee5ed3bf"
25SRC_URI[sha256sum] = "b296b7a21ea576c2b180611ccb19d06aec8dddaedf7c704b0c6a81210c25635f" 21SRC_URI[sha256sum] = "b296b7a21ea576c2b180611ccb19d06aec8dddaedf7c704b0c6a81210c25635f"
@@ -71,14 +67,6 @@ PACKAGECONFIG[kernel] = "--with-crypto_backend=kernel"
71PACKAGECONFIG[nettle] = "--with-crypto_backend=nettle,,nettle" 67PACKAGECONFIG[nettle] = "--with-crypto_backend=nettle,,nettle"
72PACKAGECONFIG[luks2] = "--with-default-luks-format=LUKS2,--with-default-luks-format=LUKS1" 68PACKAGECONFIG[luks2] = "--with-default-luks-format=LUKS2,--with-default-luks-format=LUKS1"
73 69
74RRECOMMENDS_${PN} = "kernel-module-aes-generic \
75 kernel-module-dm-crypt \
76 kernel-module-md5 \
77 kernel-module-cbc \
78 kernel-module-sha256-generic \
79 kernel-module-xts \
80"
81
82EXTRA_OECONF = "--enable-static" 70EXTRA_OECONF = "--enable-static"
83# Building without largefile is not supported by upstream 71# Building without largefile is not supported by upstream
84EXTRA_OECONF += "--enable-largefile" 72EXTRA_OECONF += "--enable-largefile"
@@ -89,4 +77,17 @@ EXTRA_OECONF += "--disable-libargon2"
89 77
90FILES_${PN} += "${@bb.utils.contains('DISTRO_FEATURES','systemd','${exec_prefix}/lib/tmpfiles.d/cryptsetup.conf', '', d)}" 78FILES_${PN} += "${@bb.utils.contains('DISTRO_FEATURES','systemd','${exec_prefix}/lib/tmpfiles.d/cryptsetup.conf', '', d)}"
91 79
80RDEPENDS_${PN} = " \
81 libdevmapper \
82"
83
84RRECOMMENDS_${PN}_class-target = " \
85 kernel-module-aes-generic \
86 kernel-module-dm-crypt \
87 kernel-module-md5 \
88 kernel-module-cbc \
89 kernel-module-sha256-generic \
90 kernel-module-xts \
91"
92
92BBCLASSEXTEND = "native nativesdk" 93BBCLASSEXTEND = "native nativesdk"