summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-crypto
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-27 19:52:05 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-29 02:10:12 -0700
commit70a0692211a396a616507e660fa6dd8a14c16190 (patch)
treea18e8b9426329ccdf2b9c3bfcd6e0b76ac2eb50c /meta-oe/recipes-crypto
parent57d8e2c673d5f5686bbf411333f1d39c3e29690e (diff)
downloadmeta-openembedded-70a0692211a396a616507e660fa6dd8a14c16190.tar.gz
botan: Add recipe
botan is a common crypto library used by various infrastructures e.g. qtcreator chromium etc. Its beneficial to build it once for the system and let apps use it if possible Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-crypto')
-rw-r--r--meta-oe/recipes-crypto/botan/botan_2.7.0.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-crypto/botan/botan_2.7.0.bb b/meta-oe/recipes-crypto/botan/botan_2.7.0.bb
new file mode 100644
index 000000000..92853d00e
--- /dev/null
+++ b/meta-oe/recipes-crypto/botan/botan_2.7.0.bb
@@ -0,0 +1,55 @@
1# Copyright (C) 2018 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Crypto and TLS for C++11"
5HOMEPAGE = "https://botan.randombit.net"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://license.txt;md5=bf361fc63df3fa25652ee82c43b7601a"
8SECTION = "libs"
9
10
11#v2.7.0
12SRCREV = "5874000d42c338ec95a7ff24cdc0c64e70f967b5"
13SRC_URI = "git://github.com/randombit/botan.git"
14
15S = "${WORKDIR}/git"
16
17inherit python3native siteinfo lib_package
18
19CPU ?= "${TARGET_ARCH}"
20CPU_x86 = "x86_32"
21CPU_armv7a = "armv7"
22CPU_armv7ve = "armv7"
23
24do_configure() {
25 python3 ${S}/configure.py \
26 --prefix="${D}${prefix}" \
27 --cpu="${CPU}" \
28 --cc-bin="${CXX}" \
29 --cxxflags="${CXXFLAGS}" \
30 --ldflags="${LDFLAGS}" \
31 --with-endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \
32 ${@bb.utils.contains("TUNE_FEATURES","neon","","--disable-neon",d)} \
33 --with-sysroot-dir=${STAGING_DIR_TARGET} \
34 --with-build-dir="${B}" \
35 --optimize-for-size \
36 --with-stack-protector \
37 --enable-shared-library \
38 --with-python-versions=3 \
39 ${EXTRA_OECONF}
40}
41
42do_compile() {
43 oe_runmake
44}
45do_install() {
46 oe_runmake install
47 sed -i -e "s|${D}||g" ${D}${libdir}/pkgconfig/botan-2.pc
48}
49
50PACKAGES += "${PN}-python3"
51
52FILES_${PN}-python3 = "${libdir}/python3"
53
54RDEPENDS_${PN}-python3 += "python3"
55