diff options
author | Khem Raj <raj.khem@gmail.com> | 2015-09-03 07:39:54 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-09-08 16:21:38 +0200 |
commit | 81fdb4d1f80ebfffe4d245138637592d23babca6 (patch) | |
tree | 50eacb2370dec64f3e25edb6843abc75a0221308 /meta-oe/recipes-core | |
parent | 8a5df66704ce01f5d53c20d85d50d0a9c9dacc9e (diff) | |
download | meta-openembedded-81fdb4d1f80ebfffe4d245138637592d23babca6.tar.gz |
plymouth: Add recipe
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r-- | meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb new file mode 100644 index 0000000000..b8c82ed4ee --- /dev/null +++ b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb | |||
@@ -0,0 +1,61 @@ | |||
1 | SUMMARY = "Plymouth is a project from Fedora providing a flicker-free graphical boot process." | ||
2 | |||
3 | DESCRIPTION = "Plymouth is an application that runs very early in the boot process \ | ||
4 | (even before the root filesystem is mounted!) that provides a \ | ||
5 | graphical boot animation while the boot process happens in the background." | ||
6 | |||
7 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/Plymouth" | ||
8 | SECTION = "base" | ||
9 | |||
10 | LICENSE = "GPLv2+" | ||
11 | |||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
13 | |||
14 | DEPENDS = "libcap libpng cairo dbus udev" | ||
15 | PROVIDES = "virtual/psplash" | ||
16 | RPROVIDES_${PN} = "virtual/psplash virtual/psplash-support" | ||
17 | |||
18 | SRC_URI = "http://www.freedesktop.org/software/plymouth/releases/${BPN}-${PV}.tar.bz2" | ||
19 | SRC_URI[md5sum] = "ff420994deb7ea203df678df92e7ab7d" | ||
20 | SRC_URI[sha256sum] = "2f0ce82042cf9c7eadd2517a1f74c8a85fa8699781d9f294a06eade29fbed57f" | ||
21 | |||
22 | EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk \ | ||
23 | --with-logo=${LOGO} \ | ||
24 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install', '', d)} \ | ||
25 | " | ||
26 | |||
27 | PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm" | ||
28 | PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango" | ||
29 | PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+" | ||
30 | |||
31 | PACKAGECONFIG ??= "pango" | ||
32 | |||
33 | LOGO ??= "${datadir}/plymouth/bizcom.png" | ||
34 | |||
35 | PACKAGECONFIG_append_x86 = " drm" | ||
36 | PACKAGECONFIG_append_x86-64 = " drm" | ||
37 | |||
38 | inherit autotools pkgconfig systemd | ||
39 | |||
40 | |||
41 | do_install_append() { | ||
42 | install -d ${D}${systemd_unitdir}/system | ||
43 | install -m 644 ${B}/systemd-units/*.service ${D}${systemd_unitdir}/system | ||
44 | install -m 644 ${B}/systemd-units/systemd-ask-password-plymouth.path ${D}${systemd_unitdir}/system | ||
45 | # Remove /var/run from package as plymouth will populate it on startup | ||
46 | rm -fr "${D}${localstatedir}/run" | ||
47 | } | ||
48 | |||
49 | PACKAGES =+ "${PN}-initrd ${PN}-set-default-theme" | ||
50 | |||
51 | FILES_${PN}-initrd = "${libdir}/plymouth/plymouth/*" | ||
52 | FILES_${PN}-set-default-theme = "${sbindir}/plymouth-set-default-theme" | ||
53 | |||
54 | FILES_${PN} += "${systemd_unitdir}/system/*" | ||
55 | FILES_${PN}-dbg += "${libdir}/plymouth/renderers/.debug" | ||
56 | |||
57 | |||
58 | RDEPENDS_${PN}-initrd = "bash dracut" | ||
59 | RDEPENDS_${PN}-set-default-theme = "bash" | ||
60 | |||
61 | SYSTEMD_SERVICE_${PN} = "plymouth-start.service" | ||