summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorMartin Hundebøll <martin@geanix.com>2018-07-12 14:05:50 +0200
committerKhem Raj <raj.khem@gmail.com>2018-07-12 08:12:03 -0700
commit6a0efef15cd625d4fb4f60e2235450de0222c357 (patch)
treedcf71aee93561b1a9fd715cb831182a465c02349 /meta-oe/recipes-core
parent41c23d32ca8bbaf27cf86905928baa5be07fff0f (diff)
downloadmeta-openembedded-6a0efef15cd625d4fb4f60e2235450de0222c357.tar.gz
ell: update to 0.6
Remove upstreamed patch to fix musl build, and replace with another (submitted) patch to fix a new musl issue. Signed-off-by: Martin Hundebøll <martin@geanix.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/ell/ell/0001-dhcp-include-if_arp.h-from-libc-instead-of-linux-hea.patch39
-rw-r--r--meta-oe/recipes-core/ell/ell/0001-ell-fix-build-with-musl-libc.patch39
-rw-r--r--meta-oe/recipes-core/ell/ell_0.6.bb (renamed from meta-oe/recipes-core/ell/ell_0.4.bb)9
3 files changed, 44 insertions, 43 deletions
diff --git a/meta-oe/recipes-core/ell/ell/0001-dhcp-include-if_arp.h-from-libc-instead-of-linux-hea.patch b/meta-oe/recipes-core/ell/ell/0001-dhcp-include-if_arp.h-from-libc-instead-of-linux-hea.patch
new file mode 100644
index 000000000..df3c055d3
--- /dev/null
+++ b/meta-oe/recipes-core/ell/ell/0001-dhcp-include-if_arp.h-from-libc-instead-of-linux-hea.patch
@@ -0,0 +1,39 @@
1From d8236d1d789f496a193dae5d2a15d706b81f6482 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Martin=20Hundeb=C3=B8ll?= <martin@geanix.com>
3Date: Thu, 12 Jul 2018 10:19:50 +0200
4Subject: [PATCH] dhcp: include if_arp.h from libc instead of linux headers
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8To: ell@lists.01.org
9
10Compilation with musl libc fails due to redefinition of 'struct
11arp{req,req_old,hdr}' in linux/if_arp.h, since it is already defined and
12included in net/if_arp.h (through net/ethernet.h -> net/if_ether.h).
13
14The only symbols used from if_arp.h is ARPHRD_ETHER, so it should be
15safe to avoid the compile error by including the if_arp.h header from
16the c-library instead.
17
18Upstream-Status: Submitted [https://lists.01.org/pipermail/ell/2018-July/001242.html]
19Signed-off-by: Martin Hundebøll <martin@geanix.com>
20---
21 ell/dhcp.c | 2 +-
22 1 file changed, 1 insertion(+), 1 deletion(-)
23
24diff --git a/ell/dhcp.c b/ell/dhcp.c
25index 6c90370..0d99f74 100644
26--- a/ell/dhcp.c
27+++ b/ell/dhcp.c
28@@ -27,7 +27,7 @@
29 #include <netinet/ip.h>
30 #include <net/ethernet.h>
31 #include <linux/types.h>
32-#include <linux/if_arp.h>
33+#include <net/if_arp.h>
34 #include <errno.h>
35 #include <time.h>
36
37--
382.18.0
39
diff --git a/meta-oe/recipes-core/ell/ell/0001-ell-fix-build-with-musl-libc.patch b/meta-oe/recipes-core/ell/ell/0001-ell-fix-build-with-musl-libc.patch
deleted file mode 100644
index a172a93ca..000000000
--- a/meta-oe/recipes-core/ell/ell/0001-ell-fix-build-with-musl-libc.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 4f8c68757b05d12392cd1a8aed174cb8e56f80e3 Mon Sep 17 00:00:00 2001
2From: "Maxin B. John" <maxin.john@intel.com>
3Date: Thu, 5 Apr 2018 17:19:44 +0300
4Subject: [PATCH] ell: fix build with musl libc
5
6musl libc doesn't implement TEMP_FAILURE_RETRY. Use the
7TEMP_FAILURE_RETRY from glibc to fix build.
8
9Upstream-Status: Submitted [https://lists.01.org/pipermail/ell/2018-April/001209.html]
10
11Signed-off-by: Maxin B. John <maxin.john@intel.com>
12---
13 ell/dbus.h | 10 ++++++++++
14 1 file changed, 10 insertions(+)
15
16diff --git a/ell/dbus.h b/ell/dbus.h
17index a7c08d2..3ff5e0f 100644
18--- a/ell/dbus.h
19+++ b/ell/dbus.h
20@@ -28,6 +28,16 @@
21 #include <stddef.h>
22 #include <stdarg.h>
23
24+/* taken from glibc unistd.h for musl support */
25+#ifndef TEMP_FAILURE_RETRY
26+#define TEMP_FAILURE_RETRY(expression) \
27+ (__extension__ \
28+ ({ long int __result; \
29+ do __result = (long int) (expression); \
30+ while (__result == -1L && errno == EINTR); \
31+ __result; }))
32+#endif
33+
34 #ifdef __cplusplus
35 extern "C" {
36 #endif
37--
382.4.0
39
diff --git a/meta-oe/recipes-core/ell/ell_0.4.bb b/meta-oe/recipes-core/ell/ell_0.6.bb
index 1524bd6b9..399eddb07 100644
--- a/meta-oe/recipes-core/ell/ell_0.4.bb
+++ b/meta-oe/recipes-core/ell/ell_0.6.bb
@@ -7,10 +7,11 @@ SECTION = "libs"
7inherit autotools pkgconfig 7inherit autotools pkgconfig
8 8
9S = "${WORKDIR}/git" 9S = "${WORKDIR}/git"
10SRCREV = "b4aea06fabb2af1af01f861f8f394c75950b6d47" 10SRCREV = "59ff3160fe55a841e662f8776f0520f2038235f4"
11SRC_URI = "git://git.kernel.org/pub/scm/libs/ell/ell.git \ 11SRC_URI = " \
12 file://0001-ell-fix-build-with-musl-libc.patch \ 12 git://git.kernel.org/pub/scm/libs/ell/ell.git \
13 " 13 file://0001-dhcp-include-if_arp.h-from-libc-instead-of-linux-hea.patch \
14"
14 15
15do_configure_prepend () { 16do_configure_prepend () {
16 mkdir ${S}/build-aux 17 mkdir ${S}/build-aux