summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2011-11-21 09:45:30 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-21 12:08:21 +0100
commit0c1147ad8da559ebc23c54f6c3d39b4c40dbf00a (patch)
tree95c6999ff98d88e6ac70f246cefc6c066c1d1b35 /meta-oe/recipes-core
parentb006355af5ebe0e0465dd8412d918fa042bbda55 (diff)
downloadmeta-openembedded-0c1147ad8da559ebc23c54f6c3d39b4c40dbf00a.tar.gz
systemd: add prerm u-a calls
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index 7b0771a00..228e0e4b3 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -108,7 +108,6 @@ RRECOMMENDS_${PN} += "kbd kbd-consolefonts \
108 108
109# TODO: 109# TODO:
110# u-a for runlevel and telinit 110# u-a for runlevel and telinit
111# u-a prerm
112 111
113pkg_postinst_systemd () { 112pkg_postinst_systemd () {
114update-alternatives --install ${base_sbindir}/init init ${base_bindir}/systemd 300 113update-alternatives --install ${base_sbindir}/init init ${base_bindir}/systemd 300
@@ -117,3 +116,11 @@ update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/syste
117update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300 116update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300
118update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/systemctl 300 117update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/systemctl 300
119} 118}
119
120pkg_prerm_systemd () {
121update-alternatives --remove init ${base_bindir}/systemd
122update-alternatives --remove halt ${base_bindir}/systemctl
123update-alternatives --remove reboot ${base_bindir}/systemctl
124update-alternatives --remove shutdown ${base_bindir}/systemctl
125update-alternatives --remove poweroff ${base_bindir}/systemctl
126}