summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-01-31 17:38:58 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-02-01 08:24:08 +0100
commit6396ac4454d2d8096f9622bb6979834f9d649085 (patch)
treef4b34016a70db442a5dd4eee7245039b7ad4a9a7 /meta-oe/recipes-core
parentc029d4a268de1ac7076fbeb9e337e96fdb1b226d (diff)
downloadmeta-openembedded-6396ac4454d2d8096f9622bb6979834f9d649085.tar.gz
busybox: fix busybox-syslog systemd service file
The service file had the 'Wants' in 'Service' group instead of the 'Unit' group. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in2
-rw-r--r--meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in b/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in
index db9008259..27b9831da 100644
--- a/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in
+++ b/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in
@@ -1,12 +1,12 @@
1[Unit] 1[Unit]
2Description=System Logging Service 2Description=System Logging Service
3Wants=busybox-klogd.service
3 4
4[Service] 5[Service]
5ExecStartPre=/bin/systemctl stop systemd-kmsg-syslogd.service 6ExecStartPre=/bin/systemctl stop systemd-kmsg-syslogd.service
6EnvironmentFile=-/etc/default/busybox-syslog 7EnvironmentFile=-/etc/default/busybox-syslog
7ExecStart=@base_sbindir@/syslogd -n $OPTIONS 8ExecStart=@base_sbindir@/syslogd -n $OPTIONS
8Sockets=syslog.socket 9Sockets=syslog.socket
9Wants=busybox-klogd.service
10 10
11[Install] 11[Install]
12WantedBy=multi-user.target 12WantedBy=multi-user.target
diff --git a/meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend b/meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend
index 46177e3dd..7e72a43a4 100644
--- a/meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend
+++ b/meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend
@@ -1,6 +1,6 @@
1inherit systemd 1inherit systemd
2 2
3PRINC := "${@int(PRINC) + 1}" 3PRINC := "${@int(PRINC) + 2}"
4 4
5# look for files in the layer first 5# look for files in the layer first
6FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 6FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"