summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-08 14:47:53 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-13 13:21:01 +0200
commiteae0e5719cdc90ab244fc490ff16a9726d2e40bf (patch)
tree023f0e418be11ac3915a66cce80c7157ff4cd03d /meta-oe/recipes-core
parentad9df2b36a57d5a2760dc5924e8fa91201916bc0 (diff)
downloadmeta-openembedded-eae0e5719cdc90ab244fc490ff16a9726d2e40bf.tar.gz
llvm: Remove
Moved to OE-core, with a version upgrade Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/llvm/llvm-common.bb22
-rw-r--r--meta-oe/recipes-core/llvm/llvm-common/llvm-config11
-rw-r--r--meta-oe/recipes-core/llvm/llvm.inc162
-rw-r--r--meta-oe/recipes-core/llvm/llvm3.3/Remove-error-output-from-configure-if-CFLAGS-is-set-.patch52
-rw-r--r--meta-oe/recipes-core/llvm/llvm3.3/arm_fenv_uclibc.patch14
-rw-r--r--meta-oe/recipes-core/llvm/llvm3.3_3.3.bb22
6 files changed, 0 insertions, 283 deletions
diff --git a/meta-oe/recipes-core/llvm/llvm-common.bb b/meta-oe/recipes-core/llvm/llvm-common.bb
deleted file mode 100644
index 618cc1e9d..000000000
--- a/meta-oe/recipes-core/llvm/llvm-common.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1SUMMARY = "Helper script for OE's llvm support"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \
5"
6
7SRC_URI = "file://llvm-config"
8
9ALLOW_EMPTY_${PN} = "1"
10SYSROOT_PREPROCESS_FUNCS_append_class-target = " llvm_common_sysroot_preprocess"
11
12llvm_common_sysroot_preprocess() {
13 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
14 install -m 0755 ${WORKDIR}/llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
15}
16
17do_install_class-native() {
18 install -d ${D}${bindir}
19 install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
20}
21
22BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-core/llvm/llvm-common/llvm-config b/meta-oe/recipes-core/llvm/llvm-common/llvm-config
deleted file mode 100644
index b0f33c8d6..000000000
--- a/meta-oe/recipes-core/llvm/llvm-common/llvm-config
+++ /dev/null
@@ -1,11 +0,0 @@
1#!/bin/sh
2# Wrapper script for real llvm-config. Simply calls
3
4if [ $WANT_LLVM_RELEASE ]; then
5 exec `dirname $0`/${TARGET_PREFIX}llvm-config$WANT_LLVM_RELEASE ${@}
6else
7 echo "To use llvm-common WANT_LLVM_RELEASE needs to be exported."
8 echo "For example if this is being called through a recipe:"
9 echo "export WANT_LLVM_RELEASE=\"3.3\""
10 exit 1
11fi
diff --git a/meta-oe/recipes-core/llvm/llvm.inc b/meta-oe/recipes-core/llvm/llvm.inc
deleted file mode 100644
index f27261fa9..000000000
--- a/meta-oe/recipes-core/llvm/llvm.inc
+++ /dev/null
@@ -1,162 +0,0 @@
1# LLVM does not provide ABI stability between different versions. For this
2# reason OE makes it possible to build and install different llvm versions
3# at the same time.
4#
5# This is true for the normal recipes as well as the native ones.
6#
7# All regular installation directories are prefixed with 'llvm${LLVM_RELEASE}'
8# e.g. "${STAGING_BINDIR}/llvm2.5" or "${STAGING_INCDIR}/llvm2.5"
9#
10# For your program or library that makes use of llvm you do should not need to
11# modify anything as long as it uses the results of various llvm-config
12# invocations. If you need customizations something is wrong and it needs to be
13# fixed (report bug).
14#
15# However the *recipe* for your program/library *must* declare
16# export WANT_LLVM_RELEASE = "<valid version number>"
17# The version number is picked up by a generic wrapper script which just calls
18# the variant of the specified version.
19
20DESCRIPTION = "The Low Level Virtual Machine"
21HOMEPAGE = "http://llvm.org"
22
23# 3-clause BSD-like
24# University of Illinois/NCSA Open Source License
25LICENSE = "NCSA"
26LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=d0a3ef0d3e0e8f5cf59e5ffc273ab1f8"
27
28DEPENDS = "libffi libxml2-native llvm-common"
29
30inherit perlnative pythonnative autotools
31
32LLVM_RELEASE = "${PV}"
33LLVM_DIR = "llvm${LLVM_RELEASE}"
34
35SRC_URI = "http://llvm.org/releases/${PV}/llvm-${PV}.src.tar.gz"
36S = "${WORKDIR}/llvm-${PV}.src"
37
38LLVM_BUILD_DIR = "${WORKDIR}/llvm-${PV}.build"
39LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install"
40
41EXTRA_OECONF += "--disable-assertions \
42 --enable-debug-runtime \
43 --disable-expensive-checks \
44 --enable-bindings=none \
45 --enable-keep-symbols \
46 --enable-libffi \
47 --enable-optimized \
48 --enable-shared \
49 --enable-targets=host-only"
50EXTRA_OEMAKE += "REQUIRES_RTTI=1 VERBOSE=1"
51
52do_configure_prepend() {
53 # Remove RPATHs
54 sed -i 's:$(RPATH) -Wl,$(\(ToolDir\|LibDir\|ExmplDir\))::g' ${S}/Makefile.rules
55
56 # Drop "svn" suffix from version string
57 sed -i 's/${PV}svn/${PV}/g' ${S}/configure
58
59 # Fix paths in llvm-config
60 sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" ${S}/tools/llvm-config/llvm-config.cpp
61 sed -ri "s#/(bin|include|lib)(/?\")#/\1/${LLVM_DIR}\2#g" ${S}/tools/llvm-config/llvm-config.cpp
62
63 # Fix the hardcoded libdir in llvm-config
64 sed -i 's:/lib\>:/${baselib}:g' ${S}/tools/llvm-config/llvm-config.cpp
65
66 # Fails to build unless using separate directory from source
67 mkdir -p ${LLVM_BUILD_DIR}
68 cd ${LLVM_BUILD_DIR}
69}
70
71do_compile() {
72 cd ${LLVM_BUILD_DIR}
73
74 # Fix libdir for multilib
75 sed -i 's:(PROJ_prefix)/lib:(PROJ_prefix)/${baselib}:g' Makefile.config
76
77 oe_runmake \
78 AR="${BUILD_AR}" \
79 CC="${BUILD_CC}" \
80 CFLAGS="${BUILD_CFLAGS}" \
81 CXX="${BUILD_CXX}" \
82 CXXFLAGS="${BUILD_CXXFLAGS}" \
83 CPP="${BUILD_CPP}" \
84 CPPFLAGS="${BUILD_CPPFLAGS}" \
85 NM="${BUILD_NM}" \
86 RANLIB="${BUILD_RANLIB}" \
87 PATH="${STAGING_BINDIR_NATIVE}:$PATH" \
88 cross-compile-build-tools
89 oe_runmake
90}
91
92do_install() {
93 cd ${LLVM_BUILD_DIR}
94 oe_runmake DESTDIR=${LLVM_INSTALL_DIR} install
95
96 mv ${LLVM_INSTALL_DIR}${bindir}/${HOST_SYS}-llvm-config-host ${LLVM_INSTALL_DIR}/llvm-config-host
97
98 install -d ${D}${bindir}/${LLVM_DIR}
99 mv ${LLVM_INSTALL_DIR}${bindir}/* ${D}${bindir}/${LLVM_DIR}/
100
101 install -d ${D}${includedir}/${LLVM_DIR}
102 mv ${LLVM_INSTALL_DIR}${includedir}/* ${D}${includedir}/${LLVM_DIR}/
103
104 install -d ${D}${libdir}/${LLVM_DIR}
105 mv ${LLVM_INSTALL_DIR}${libdir}/* ${D}${libdir}/${LLVM_DIR}/
106 ln -s ${LLVM_DIR}/libLLVM-${PV}.so ${D}${libdir}/libLLVM-${PV}.so
107
108 install -d ${D}${docdir}/${LLVM_DIR}
109 mv ${LLVM_INSTALL_DIR}${prefix}/docs/llvm/* ${D}${docdir}/${LLVM_DIR}
110}
111
112SYSROOT_PREPROCESS_FUNCS += "llvm_sysroot_preprocess"
113
114llvm_sysroot_preprocess() {
115 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}
116 mv ${LLVM_INSTALL_DIR}/llvm-config-host ${SYSROOT_DESTDIR}${bindir_crossscripts}/llvm-config${PV}
117}
118
119PACKAGES += "${PN}-bugpointpasses ${PN}-llvmhello"
120ALLOW_EMPTY_${PN} = "1"
121ALLOW_EMPTY_${PN}-staticdev = "1"
122FILES_${PN} = ""
123FILES_${PN}-staticdev = ""
124FILES_${PN}-dbg = " \
125 ${bindir}/${LLVM_DIR}/.debug \
126 ${libdir}/${LLVM_DIR}/.debug/BugpointPasses.so \
127 ${libdir}/${LLVM_DIR}/.debug/LLVMHello.so \
128 /usr/src/debug \
129"
130
131FILES_${PN}-dev = " \
132 ${bindir}/${LLVM_DIR} \
133 ${includedir}/${LLVM_DIR} \
134"
135RRECOMMENDS_${PN}-dev += "${PN}-bugpointpasses ${PN}-llvmhello"
136
137FILES_${PN}-bugpointpasses = "\
138 ${libdir}/${LLVM_DIR}/BugpointPasses.so \
139"
140FILES_${PN}-llvmhello = "\
141 ${libdir}/${LLVM_DIR}/LLVMHello.so \
142"
143
144PACKAGES_DYNAMIC = "^libllvm${LLVM_RELEASE}-.*$"
145NOAUTOPACKAGEDEBUG = "1"
146
147INSANE_SKIP_${MLPREFIX}libllvm${LLVM_RELEASE}-llvm-${LLVM_RELEASE} += "dev-so"
148
149python llvm_populate_packages() {
150 libdir = bb.data.expand('${libdir}', d)
151 libllvm_libdir = bb.data.expand('${libdir}/${LLVM_DIR}', d)
152 split_dbg_packages = do_split_packages(d, libllvm_libdir+'/.debug', '^lib(.*)\.so$', 'libllvm${LLVM_RELEASE}-%s-dbg', 'Split debug package for %s', allow_dirs=True)
153 split_packages = do_split_packages(d, libdir, '^lib(.*)\.so$', 'libllvm${LLVM_RELEASE}-%s', 'Split package for %s', allow_dirs=True, allow_links=True, recursive=True)
154 split_staticdev_packages = do_split_packages(d, libllvm_libdir, '^lib(.*)\.a$', 'libllvm${LLVM_RELEASE}-%s-staticdev', 'Split staticdev package for %s', allow_dirs=True)
155 if split_packages:
156 pn = d.getVar('PN')
157 d.appendVar('RDEPENDS_' + pn, ' '+' '.join(split_packages))
158 d.appendVar('RDEPENDS_' + pn + '-dbg', ' '+' '.join(split_dbg_packages))
159 d.appendVar('RDEPENDS_' + pn + '-staticdev', ' '+' '.join(split_staticdev_packages))
160}
161
162PACKAGESPLITFUNCS_prepend = "llvm_populate_packages "
diff --git a/meta-oe/recipes-core/llvm/llvm3.3/Remove-error-output-from-configure-if-CFLAGS-is-set-.patch b/meta-oe/recipes-core/llvm/llvm3.3/Remove-error-output-from-configure-if-CFLAGS-is-set-.patch
deleted file mode 100644
index 44387e898..000000000
--- a/meta-oe/recipes-core/llvm/llvm3.3/Remove-error-output-from-configure-if-CFLAGS-is-set-.patch
+++ /dev/null
@@ -1,52 +0,0 @@
1From d4bf7a3853dab12c11cbfc8088fd76f548a8d017 Mon Sep 17 00:00:00 2001
2From: Patrik Hagglund <patrik.h.hagglund@ericsson.com>
3Date: Tue, 24 Sep 2013 11:38:45 +0000
4Subject: [PATCH] Remove error output from configure if CFLAGS is set (r174313).
5
6This fixes PR16724.
7
8git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@191289 91177308-0d34-0410-b5e6-96231b3b80d8
9
10https://github.com/llvm-mirror/llvm/commit/d4bf7a3853dab12c11cbfc8088fd76f548a8d017
11
12Upstream-Status: Backport
13
14Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
15---
16 autoconf/configure.ac | 4 ++--
17 configure | 4 ++--
18 2 files changed, 4 insertions(+), 4 deletions(-)
19
20diff --git a/autoconf/configure.ac b/autoconf/configure.ac
21index f9c365c..45f2fe4 100644
22--- a/autoconf/configure.ac
23+++ b/autoconf/configure.ac
24@@ -61,8 +61,8 @@ fi
25
26 dnl Default to empty (i.e. assigning the null string to) CFLAGS and CXXFLAGS,
27 dnl instead of the autoconf default (for example, '-g -O2' for CC=gcc).
28-${CFLAGS=}
29-${CXXFLAGS=}
30+: ${CFLAGS=}
31+: ${CXXFLAGS=}
32
33 dnl We need to check for the compiler up here to avoid anything else
34 dnl starting with a different one.
35diff --git a/configure b/configure
36index f3a6594..9090cda 100755
37--- a/configure
38+++ b/configure
39@@ -1992,8 +1992,8 @@ echo "$as_me: error: Already configured in ${srcdir}" >&2;}
40 fi
41 fi
42
43-${CFLAGS=}
44-${CXXFLAGS=}
45+: ${CFLAGS=}
46+: ${CXXFLAGS=}
47
48 ac_ext=c
49 ac_cpp='$CPP $CPPFLAGS'
50--
511.9.1
52
diff --git a/meta-oe/recipes-core/llvm/llvm3.3/arm_fenv_uclibc.patch b/meta-oe/recipes-core/llvm/llvm3.3/arm_fenv_uclibc.patch
deleted file mode 100644
index c3ae49464..000000000
--- a/meta-oe/recipes-core/llvm/llvm3.3/arm_fenv_uclibc.patch
+++ /dev/null
@@ -1,14 +0,0 @@
1Index: llvm-2.9/include/llvm/Support/FEnv.h
2===================================================================
3--- llvm-2.9.orig/include/llvm/Support/FEnv.h 2010-11-29 20:44:50.000000000 +0100
4+++ llvm-2.9/include/llvm/Support/FEnv.h 2011-11-18 18:42:22.580161297 +0100
5@@ -17,6 +17,9 @@
6
7 #include "llvm/Config/config.h"
8 #include <cerrno>
9+
10+#undef HAVE_FENV_H
11+
12 #ifdef HAVE_FENV_H
13 #include <fenv.h>
14 #endif
diff --git a/meta-oe/recipes-core/llvm/llvm3.3_3.3.bb b/meta-oe/recipes-core/llvm/llvm3.3_3.3.bb
deleted file mode 100644
index 60a222185..000000000
--- a/meta-oe/recipes-core/llvm/llvm3.3_3.3.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1require llvm.inc
2
3DEPENDS += "zlib"
4EXTRA_OECONF += "--enable-zlib"
5
6SRC_URI += "file://Remove-error-output-from-configure-if-CFLAGS-is-set-.patch"
7
8SRC_URI_append_libc-uclibc = " file://arm_fenv_uclibc.patch "
9
10SRC_URI[md5sum] = "40564e1dc390f9844f1711c08b08e391"
11SRC_URI[sha256sum] = "68766b1e70d05a25e2f502e997a3cb3937187a3296595cf6e0977d5cd6727578"
12
13PACKAGECONFIG ??= ""
14PACKAGECONFIG[r600] = "--enable-experimental-targets=R600,,,"
15
16# Fails to build with thumb-1 (qemuarm)
17# | {standard input}: Assembler messages:
18# | {standard input}:22: Error: selected processor does not support Thumb mode `stmdb sp!,{r0,r1,r2,r3,lr}'
19# | {standard input}:31: Error: lo register required -- `ldmia sp!,{r0,r1,r2,r3,lr}'
20# | {standard input}:32: Error: lo register required -- `ldr pc,[sp],#4'
21# | make[3]: *** [/home/jenkins/oe/world/shr-core/tmp-glibc/work/armv5te-oe-linux-gnueabi/llvm3.3/3.3-r0/llvm-3.3.build/lib/Target/ARM/Release/ARMJITInfo.o] Error 1
22ARM_INSTRUCTION_SET = "arm"