diff options
author | Andreas Oberritter <obi@opendreambox.org> | 2012-03-08 21:15:31 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-03-09 07:50:37 +0100 |
commit | 8b5006510a73d04f023554b2126b0858f7bbd68a (patch) | |
tree | 5e33e80557fc667c0bde3b04c2acc18ce12043fa /meta-oe/recipes-core | |
parent | 47ba455a110db200170c227263467685c382094b (diff) | |
download | meta-openembedded-8b5006510a73d04f023554b2126b0858f7bbd68a.tar.gz |
udev-173: don't hardcode path to pidof
* pidof lives in /bin, search it in $PATH.
* Assume pidof's presence.
* Remove -e shell option, because pidof may return nonzero.
Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r-- | meta-oe/recipes-core/udev/udev/init | 8 | ||||
-rw-r--r-- | meta-oe/recipes-core/udev/udev_173.bb | 2 |
2 files changed, 4 insertions, 6 deletions
diff --git a/meta-oe/recipes-core/udev/udev/init b/meta-oe/recipes-core/udev/udev/init index ecc357d4fe..d160300abd 100644 --- a/meta-oe/recipes-core/udev/udev/init +++ b/meta-oe/recipes-core/udev/udev/init | |||
@@ -1,4 +1,4 @@ | |||
1 | #!/bin/sh -e | 1 | #!/bin/sh |
2 | 2 | ||
3 | ### BEGIN INIT INFO | 3 | ### BEGIN INIT INFO |
4 | # Provides: udev | 4 | # Provides: udev |
@@ -18,10 +18,8 @@ export TZ=/etc/localtime | |||
18 | [ -f /etc/udev/udev.conf ] && . /etc/udev/udev.conf | 18 | [ -f /etc/udev/udev.conf ] && . /etc/udev/udev.conf |
19 | 19 | ||
20 | kill_udevd() { | 20 | kill_udevd() { |
21 | if [ -x /sbin/pidof ]; then | 21 | pid=`pidof -x udevd` |
22 | pid=`/sbin/pidof -x udevd` | 22 | [ -n "$pid" ] && kill $pid |
23 | [ -n "$pid" ] && kill $pid | ||
24 | fi | ||
25 | } | 23 | } |
26 | 24 | ||
27 | export ACTION=add | 25 | export ACTION=add |
diff --git a/meta-oe/recipes-core/udev/udev_173.bb b/meta-oe/recipes-core/udev/udev_173.bb index 5c5ce26b26..b7d7ed3d88 100644 --- a/meta-oe/recipes-core/udev/udev_173.bb +++ b/meta-oe/recipes-core/udev/udev_173.bb | |||
@@ -16,7 +16,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ | |||
16 | # Needed for udev-extras | 16 | # Needed for udev-extras |
17 | DEPENDS = "gperf-native usbutils acl glib-2.0" | 17 | DEPENDS = "gperf-native usbutils acl glib-2.0" |
18 | 18 | ||
19 | PR = "r3" | 19 | PR = "r4" |
20 | 20 | ||
21 | # version specific SRC_URI | 21 | # version specific SRC_URI |
22 | SRC_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \ | 22 | SRC_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \ |