summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorAlejandro Joya <alejandro.joya.cruz@intel.com>2016-02-02 18:11:57 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 18:09:40 +0100
commit26ee1849d1d70296aee8694f89502eb813842565 (patch)
tree4e452250e18cdfcd751fa5811d92060b71e6420b /meta-oe/recipes-core
parent6cc38cad69d6ec8eccb5d19eda733c6deb1ef8a6 (diff)
downloadmeta-openembedded-26ee1849d1d70296aee8694f89502eb813842565.tar.gz
toybox: upgrade to 0.7.0
Change SRC_URI to latest version and update the checksum for package. remove old patch not longer need it to build it and add depedency found for builiding on temporary enviroment like yocto. Signed-off-by: Alejandro Joya <alejandro.joya.cruz@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/toybox/toybox/0001-Match-paths-with-busybox.patch388
-rw-r--r--meta-oe/recipes-core/toybox/toybox/toybox_build-add-Missing-CFLAGS.patch28
-rw-r--r--meta-oe/recipes-core/toybox/toybox_0.7.0.bb (renamed from meta-oe/recipes-core/toybox/toybox_0.6.0.bb)10
3 files changed, 34 insertions, 392 deletions
diff --git a/meta-oe/recipes-core/toybox/toybox/0001-Match-paths-with-busybox.patch b/meta-oe/recipes-core/toybox/toybox/0001-Match-paths-with-busybox.patch
deleted file mode 100644
index 9eb965d32..000000000
--- a/meta-oe/recipes-core/toybox/toybox/0001-Match-paths-with-busybox.patch
+++ /dev/null
@@ -1,388 +0,0 @@
1From 9b37b45067677563dc8daa73d73a015c20ad6222 Mon Sep 17 00:00:00 2001
2From: Paul Barker <paul@paulbarker.me.uk>
3Date: Mon, 18 Aug 2014 12:18:16 +0000
4Subject: [PATCH] Match paths with busybox
5
6To ensure that toybox can be installed alongside busybox without confusing
7update-alternatives, the paths of the links installed by toybox should match
8those installed by busybox. This is accomplished by changing the flags of a few
9tools within toybox.
10
11v3:
12 - Forward ported from v0.5.0 to v0.5.2
13
14v2:
15 - Forward ported from v0.4.9 to v0.5.0
16 - Move new 'mount' command
17
18Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
19
20Upstream-status: Inappropriate
21 (specific to update-alternatives use in OpenEmbedded)
22
23Signed-off-by: Amarnath Valluri <amarnath.valluri@intel.com>
24---
25 toys/lsb/mount.c | 2 +-
26 toys/lsb/pidof.c | 2 +-
27 toys/other/chvt.c | 2 +-
28 toys/other/ifconfig.c | 2 +-
29 toys/other/insmod.c | 2 +-
30 toys/other/lsmod.c | 2 +-
31 toys/other/netcat.c | 2 +-
32 toys/other/pivot_root.c | 2 +-
33 toys/other/readlink.c | 2 +-
34 toys/other/reboot.c | 6 +++---
35 toys/other/rfkill.c | 2 +-
36 toys/other/rmmod.c | 2 +-
37 toys/other/swapoff.c | 2 +-
38 toys/other/swapon.c | 2 +-
39 toys/other/sysctl.c | 2 +-
40 toys/posix/cut.c | 2 +-
41 toys/posix/df.c | 2 +-
42 toys/posix/head.c | 2 +-
43 toys/posix/id.c | 6 +++---
44 toys/posix/mkfifo.c | 2 +-
45 toys/posix/renice.c | 2 +-
46 toys/posix/tail.c | 2 +-
47 toys/posix/tee.c | 2 +-
48 toys/posix/uniq.c | 2 +-
49 toys/posix/who.c | 2 +-
50 25 files changed, 29 insertions(+), 29 deletions(-)
51
52diff --git a/toys/lsb/mount.c b/toys/lsb/mount.c
53index c334681..b076ca1 100644
54--- a/toys/lsb/mount.c
55+++ b/toys/lsb/mount.c
56@@ -6,7 +6,7 @@
57 * Note: -hV is bad spec, haven't implemented -FsLU yet
58 * no mtab (/proc/mounts does it) so -n is NOP.
59
60-USE_MOUNT(NEWTOY(mount, "?O:afnrvwt:o*[-rw]", TOYFLAG_USR|TOYFLAG_BIN|TOYFLAG_STAYROOT))
61+USE_MOUNT(NEWTOY(mount, "?O:afnrvwt:o*[-rw]", TOYFLAG_BIN|TOYFLAG_STAYROOT))
62 //USE_NFSMOUNT(NEWTOY(nfsmount, "?<2>2", TOYFLAG_USR|TOYFLAG_BIN|TOYFLAG_STAYROOT))
63
64 config MOUNT
65diff --git a/toys/lsb/pidof.c b/toys/lsb/pidof.c
66index 51b742f..a8fc8ef 100644
67--- a/toys/lsb/pidof.c
68+++ b/toys/lsb/pidof.c
69@@ -5,7 +5,7 @@
70 *
71 * http://refspecs.linuxfoundation.org/LSB_4.1.0/LSB-Core-generic/LSB-Core-generic/pidof.html
72
73-USE_PIDOF(NEWTOY(pidof, "<1so:", TOYFLAG_USR|TOYFLAG_BIN))
74+USE_PIDOF(NEWTOY(pidof, "<1so:", TOYFLAG_BIN))
75
76 config PIDOF
77 bool "pidof"
78diff --git a/toys/other/chvt.c b/toys/other/chvt.c
79index 6544265..a93327f 100644
80--- a/toys/other/chvt.c
81+++ b/toys/other/chvt.c
82@@ -2,7 +2,7 @@
83 *
84 * Copyright (C) 2008 David Anders <danders@amltd.com>
85
86-USE_CHVT(NEWTOY(chvt, "<1", TOYFLAG_USR|TOYFLAG_SBIN))
87+USE_CHVT(NEWTOY(chvt, "<1", TOYFLAG_USR|TOYFLAG_BIN))
88
89 config CHVT
90 bool "chvt"
91diff --git a/toys/other/ifconfig.c b/toys/other/ifconfig.c
92index 8db3ff0..445799d 100644
93--- a/toys/other/ifconfig.c
94+++ b/toys/other/ifconfig.c
95@@ -6,7 +6,7 @@
96 *
97 * Not in SUSv4.
98
99-USE_IFCONFIG(NEWTOY(ifconfig, "^?a", TOYFLAG_BIN))
100+USE_IFCONFIG(NEWTOY(ifconfig, "^?a", TOYFLAG_SBIN))
101
102 config IFCONFIG
103 bool "ifconfig"
104diff --git a/toys/other/insmod.c b/toys/other/insmod.c
105index 81721a3..cb222a5 100644
106--- a/toys/other/insmod.c
107+++ b/toys/other/insmod.c
108@@ -2,7 +2,7 @@
109 *
110 * Copyright 2012 Elie De Brauwer <eliedebrauwer@gmail.com>
111
112-USE_INSMOD(NEWTOY(insmod, "<1", TOYFLAG_BIN|TOYFLAG_NEEDROOT))
113+USE_INSMOD(NEWTOY(insmod, "<1", TOYFLAG_SBIN|TOYFLAG_NEEDROOT))
114
115 config INSMOD
116 bool "insmod"
117diff --git a/toys/other/lsmod.c b/toys/other/lsmod.c
118index b8f5d82..4d16048 100644
119--- a/toys/other/lsmod.c
120+++ b/toys/other/lsmod.c
121@@ -2,7 +2,7 @@
122 *
123 * Copyright 2012 Elie De Brauwer <eliedebrauwer@gmail.com>
124
125-USE_LSMOD(NEWTOY(lsmod, NULL, TOYFLAG_BIN))
126+USE_LSMOD(NEWTOY(lsmod, NULL, TOYFLAG_SBIN))
127
128 config LSMOD
129 bool "lsmod"
130diff --git a/toys/other/netcat.c b/toys/other/netcat.c
131index d27aa88..0fd26f7 100644
132--- a/toys/other/netcat.c
133+++ b/toys/other/netcat.c
134@@ -4,7 +4,7 @@
135 *
136 * TODO: udp, ipv6, genericize for telnet/microcom/tail-f
137
138-USE_NETCAT(OLDTOY(nc, netcat, TOYFLAG_BIN))
139+USE_NETCAT(OLDTOY(nc, netcat, TOYFLAG_USR|TOYFLAG_BIN))
140 USE_NETCAT(NEWTOY(netcat, USE_NETCAT_LISTEN("^tlL")"w#p#s:q#f:", TOYFLAG_BIN))
141
142 config NETCAT
143diff --git a/toys/other/pivot_root.c b/toys/other/pivot_root.c
144index 9a1f56c..7748032 100644
145--- a/toys/other/pivot_root.c
146+++ b/toys/other/pivot_root.c
147@@ -2,7 +2,7 @@
148 *
149 * Copyright 2012 Rob Landley <rob@landley.net>
150
151-USE_PIVOT_ROOT(NEWTOY(pivot_root, "<2>2", TOYFLAG_USR|TOYFLAG_BIN))
152+USE_PIVOT_ROOT(NEWTOY(pivot_root, "<2>2", TOYFLAG_SBIN))
153
154 config PIVOT_ROOT
155 bool "pivot_root"
156diff --git a/toys/other/readlink.c b/toys/other/readlink.c
157index 1c33362..fecd1ef 100644
158--- a/toys/other/readlink.c
159+++ b/toys/other/readlink.c
160@@ -2,7 +2,7 @@
161 *
162 * Copyright 2007 Rob Landley <rob@landley.net>
163
164-USE_READLINK(NEWTOY(readlink, "<1>1fenq[-fe]", TOYFLAG_BIN))
165+USE_READLINK(NEWTOY(readlink, "<1>1fenq[-fe]", TOYFLAG_USR|TOYFLAG_BIN))
166
167 config READLINK
168 bool "readlink"
169diff --git a/toys/other/reboot.c b/toys/other/reboot.c
170index 8baa4d8..a135888 100644
171--- a/toys/other/reboot.c
172+++ b/toys/other/reboot.c
173@@ -2,9 +2,9 @@
174 *
175 * Copyright 2013 Elie De Brauwer <eliedebrauwer@gmail.com>
176
177-USE_REBOOT(NEWTOY(reboot, "n", TOYFLAG_BIN|TOYFLAG_NEEDROOT))
178-USE_REBOOT(OLDTOY(halt, reboot, TOYFLAG_BIN|TOYFLAG_NEEDROOT))
179-USE_REBOOT(OLDTOY(poweroff, reboot, TOYFLAG_BIN|TOYFLAG_NEEDROOT))
180+USE_REBOOT(NEWTOY(reboot, "n", TOYFLAG_SBIN|TOYFLAG_NEEDROOT))
181+USE_REBOOT(OLDTOY(halt, reboot, TOYFLAG_SBIN|TOYFLAG_NEEDROOT))
182+USE_REBOOT(OLDTOY(poweroff, reboot, TOYFLAG_SBIN|TOYFLAG_NEEDROOT))
183
184 config REBOOT
185 bool "reboot"
186diff --git a/toys/other/rfkill.c b/toys/other/rfkill.c
187index af3efe1..7527ec7 100644
188--- a/toys/other/rfkill.c
189+++ b/toys/other/rfkill.c
190@@ -5,7 +5,7 @@
191 *
192 * No Standard
193
194-USE_RFKILL(NEWTOY(rfkill, "<1>2", TOYFLAG_SBIN))
195+USE_RFKILL(NEWTOY(rfkill, "<1>2", TOYFLAG_USR|TOYFLAG_SBIN))
196
197 config RFKILL
198 bool "rfkill"
199diff --git a/toys/other/rmmod.c b/toys/other/rmmod.c
200index b789acc..10c134c 100644
201--- a/toys/other/rmmod.c
202+++ b/toys/other/rmmod.c
203@@ -2,7 +2,7 @@
204 *
205 * Copyright 2012 Elie De Brauwer <eliedebrauwer@gmail.com>
206
207-USE_RMMOD(NEWTOY(rmmod, "<1wf", TOYFLAG_BIN|TOYFLAG_NEEDROOT))
208+USE_RMMOD(NEWTOY(rmmod, "<1wf", TOYFLAG_SBIN|TOYFLAG_NEEDROOT))
209
210 config RMMOD
211 bool "rmmod"
212diff --git a/toys/other/swapoff.c b/toys/other/swapoff.c
213index b89e915..fb17130 100644
214--- a/toys/other/swapoff.c
215+++ b/toys/other/swapoff.c
216@@ -2,7 +2,7 @@
217 *
218 * Copyright 2012 Elie De Brauwer <eliedebrauwer@gmail.com>
219
220-USE_SWAPOFF(NEWTOY(swapoff, "<1>1", TOYFLAG_BIN|TOYFLAG_NEEDROOT))
221+USE_SWAPOFF(NEWTOY(swapoff, "<1>1", TOYFLAG_SBIN|TOYFLAG_NEEDROOT))
222
223 config SWAPOFF
224 bool "swapoff"
225diff --git a/toys/other/swapon.c b/toys/other/swapon.c
226index 49f1249..838d382 100644
227--- a/toys/other/swapon.c
228+++ b/toys/other/swapon.c
229@@ -2,7 +2,7 @@
230 *
231 * Copyright 2012 Elie De Brauwer <eliedebrauwer@gmail.com>
232
233-USE_SWAPON(NEWTOY(swapon, "<1>1p#<0>32767", TOYFLAG_BIN|TOYFLAG_NEEDROOT))
234+USE_SWAPON(NEWTOY(swapon, "<1>1p#<0>32767", TOYFLAG_SBIN|TOYFLAG_NEEDROOT))
235
236 config SWAPON
237 bool "swapon"
238diff --git a/toys/other/sysctl.c b/toys/other/sysctl.c
239index 8e57ca1..0c6c640 100644
240--- a/toys/other/sysctl.c
241+++ b/toys/other/sysctl.c
242@@ -5,7 +5,7 @@
243 *
244 * No Standard
245
246-USE_SYSCTL(NEWTOY(sysctl, "^neNqwpaA[!ap][!aq][!aw][+aA]", TOYFLAG_USR|TOYFLAG_BIN))
247+USE_SYSCTL(NEWTOY(sysctl, "^neNqwpaA[!ap][!aq][!aw][+aA]", TOYFLAG_SBIN))
248
249 config SYSCTL
250 bool "sysctl"
251diff --git a/toys/posix/cut.c b/toys/posix/cut.c
252index 7f10c5e..1ab3ce8 100644
253--- a/toys/posix/cut.c
254+++ b/toys/posix/cut.c
255@@ -5,7 +5,7 @@
256 *
257 * http://pubs.opengroup.org/onlinepubs/9699919799/utilities/cut.html
258
259-USE_CUT(NEWTOY(cut, "b:|c:|f:|d:sn[!cbf]", TOYFLAG_BIN))
260+USE_CUT(NEWTOY(cut, "b:|c:|f:|d:sn[!cbf]", TOYFLAG_USR|TOYFLAG_BIN))
261
262 config CUT
263 bool "cut"
264diff --git a/toys/posix/df.c b/toys/posix/df.c
265index 141e8e5..5d37b45 100644
266--- a/toys/posix/df.c
267+++ b/toys/posix/df.c
268@@ -4,7 +4,7 @@
269 *
270 * See http://opengroup.org/onlinepubs/9699919799/utilities/df.html
271
272-USE_DF(NEWTOY(df, "Pkt*a[-Pk]", TOYFLAG_USR|TOYFLAG_SBIN))
273+USE_DF(NEWTOY(df, "Pkt*a[-Pk]", TOYFLAG_BIN))
274
275 config DF
276 bool "df"
277diff --git a/toys/posix/head.c b/toys/posix/head.c
278index e8517d4..3ac4373 100644
279--- a/toys/posix/head.c
280+++ b/toys/posix/head.c
281@@ -4,7 +4,7 @@
282 *
283 * See http://opengroup.org/onlinepubs/9699919799/utilities/head.html
284
285-USE_HEAD(NEWTOY(head, "n#<0=10", TOYFLAG_BIN))
286+USE_HEAD(NEWTOY(head, "n#<0=10", TOYFLAG_USR|TOYFLAG_BIN))
287
288 config HEAD
289 bool "head"
290diff --git a/toys/posix/id.c b/toys/posix/id.c
291index 353aa04..7ab489e 100644
292--- a/toys/posix/id.c
293+++ b/toys/posix/id.c
294@@ -6,10 +6,10 @@
295 *
296 * See http://opengroup.org/onlinepubs/9699919799/utilities/id.html
297
298-USE_ID(NEWTOY(id, ">1"USE_ID_SELINUX("Z")"nGgru[!"USE_ID_SELINUX("Z")"Ggu]", TOYFLAG_BIN))
299+USE_ID(NEWTOY(id, ">1"USE_ID_SELINUX("Z")"nGgru[!"USE_ID_SELINUX("Z")"Ggu]", TOYFLAG_USR|TOYFLAG_BIN))
300 USE_GROUPS(NEWTOY(groups, NULL, TOYFLAG_USR|TOYFLAG_BIN))
301-USE_LOGNAME(NEWTOY(logname, ">0", TOYFLAG_BIN))
302-USE_WHOAMI(OLDTOY(whoami, logname, TOYFLAG_BIN))
303+USE_LOGNAME(NEWTOY(logname, ">0", TOYFLAG_USR|TOYFLAG_BIN))
304+USE_WHOAMI(OLDTOY(whoami, logname, TOYFLAG_USR|TOYFLAG_BIN))
305
306 config ID
307 bool "id"
308diff --git a/toys/posix/mkfifo.c b/toys/posix/mkfifo.c
309index 15fab70..4e0fca3 100644
310--- a/toys/posix/mkfifo.c
311+++ b/toys/posix/mkfifo.c
312@@ -4,7 +4,7 @@
313 *
314 * See http://opengroup.org/onlinepubs/9699919799/utilities/mkfifo.html
315
316-USE_MKFIFO(NEWTOY(mkfifo, "<1m:", TOYFLAG_BIN))
317+USE_MKFIFO(NEWTOY(mkfifo, "<1m:", TOYFLAG_USR|TOYFLAG_BIN))
318
319 config MKFIFO
320 bool "mkfifo"
321diff --git a/toys/posix/renice.c b/toys/posix/renice.c
322index 8c20644..489eb13 100644
323--- a/toys/posix/renice.c
324+++ b/toys/posix/renice.c
325@@ -4,7 +4,7 @@
326 *
327 * See http://pubs.opengroup.org/onlinepubs/9699919799/utilities/renice.html
328
329-USE_RENICE(NEWTOY(renice, "<1gpun#|", TOYFLAG_BIN))
330+USE_RENICE(NEWTOY(renice, "<1gpun#|", TOYFLAG_USR|TOYFLAG_BIN))
331
332 config RENICE
333 bool "renice"
334diff --git a/toys/posix/tail.c b/toys/posix/tail.c
335index e92c044..ba1d311 100644
336--- a/toys/posix/tail.c
337+++ b/toys/posix/tail.c
338@@ -4,7 +4,7 @@
339 *
340 * See http://opengroup.org/onlinepubs/9699919799/utilities/tail.html
341
342-USE_TAIL(NEWTOY(tail, "fc-n-[-cn]", TOYFLAG_BIN))
343+USE_TAIL(NEWTOY(tail, "fc-n-[-cn]", TOYFLAG_USR|TOYFLAG_BIN))
344
345 config TAIL
346 bool "tail"
347diff --git a/toys/posix/tee.c b/toys/posix/tee.c
348index 0388510..5574088 100644
349--- a/toys/posix/tee.c
350+++ b/toys/posix/tee.c
351@@ -4,7 +4,7 @@
352 *
353 * See http://opengroup.org/onlinepubs/9699919799/utilities/tee.html
354
355-USE_TEE(NEWTOY(tee, "ia", TOYFLAG_BIN))
356+USE_TEE(NEWTOY(tee, "ia", TOYFLAG_USR|TOYFLAG_BIN))
357
358 config TEE
359 bool "tee"
360diff --git a/toys/posix/uniq.c b/toys/posix/uniq.c
361index 3cfdb94..c127cfe 100644
362--- a/toys/posix/uniq.c
363+++ b/toys/posix/uniq.c
364@@ -4,7 +4,7 @@
365 *
366 * See http://opengroup.org/onlinepubs/9699919799/utilities/uniq.html
367
368-USE_UNIQ(NEWTOY(uniq, "f#s#w#zicdu", TOYFLAG_BIN))
369+USE_UNIQ(NEWTOY(uniq, "f#s#w#zicdu", TOYFLAG_USR|TOYFLAG_BIN))
370
371 config UNIQ
372 bool "uniq"
373diff --git a/toys/posix/who.c b/toys/posix/who.c
374index 876a562..414cdfc 100644
375--- a/toys/posix/who.c
376+++ b/toys/posix/who.c
377@@ -9,7 +9,7 @@
378 * Posix says to support many options (-abdHlmpqrstTu) but this
379 * isn't aimed at minicomputers with modem pools.
380
381-USE_WHO(NEWTOY(who, "a", TOYFLAG_BIN))
382+USE_WHO(NEWTOY(who, "a", TOYFLAG_USR|TOYFLAG_BIN))
383
384 config WHO
385 bool "who"
386--
3871.8.1.2
388
diff --git a/meta-oe/recipes-core/toybox/toybox/toybox_build-add-Missing-CFLAGS.patch b/meta-oe/recipes-core/toybox/toybox/toybox_build-add-Missing-CFLAGS.patch
new file mode 100644
index 000000000..80d6b2a02
--- /dev/null
+++ b/meta-oe/recipes-core/toybox/toybox/toybox_build-add-Missing-CFLAGS.patch
@@ -0,0 +1,28 @@
1From 686492e6b0aa582b42bf95cfc9a31324204d8f79 Mon Sep 17 00:00:00 2001
2From: Alejandro Joya <alejandro.joya.cruz@intel.com>
3Date: Tue, 2 Feb 2016 17:47:50 -0800
4Subject: [PATCH] toybox_build: add Missing CFLAGS
5
6add CFLAGS to multiple builds to forward libraries location in Yocto.
7
8Signed-off-by: Alejandro Joya <alejandro.joya.cruz@intel.com>
9---
10 Makefile | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/Makefile b/Makefile
14index 5422efe..2dca3ae 100644
15--- a/Makefile
16+++ b/Makefile
17@@ -37,7 +37,7 @@ bloatcheck: toybox_old toybox_unstripped
18
19 generated/instlist: toybox_stuff
20 NOBUILD=1 scripts/make.sh
21- $(HOSTCC) -I . scripts/install.c -o generated/instlist
22+ $(HOSTCC) -I . $(CFLAGS) scripts/install.c -o generated/instlist
23
24 install_flat: generated/instlist
25 scripts/install.sh --symlink --force
26--
271.9.1
28
diff --git a/meta-oe/recipes-core/toybox/toybox_0.6.0.bb b/meta-oe/recipes-core/toybox/toybox_0.7.0.bb
index da03200b2..a1fa8a91b 100644
--- a/meta-oe/recipes-core/toybox/toybox_0.6.0.bb
+++ b/meta-oe/recipes-core/toybox/toybox_0.7.0.bb
@@ -1,10 +1,11 @@
1SUMMARY = "Toybox combines common utilities together into a single executable." 1SUMMARY = "Toybox combines common utilities together into a single executable."
2HOMEPAGE = "http://www.landley.net/toybox/" 2HOMEPAGE = "http://www.landley.net/toybox/"
3 3
4SRC_URI = "http://www.landley.net/toybox/downloads/${BPN}-${PV}.tar.gz" 4SRC_URI = "http://www.landley.net/toybox/downloads/${BPN}-${PV}.tar.gz \
5 file://toybox_build-add-Missing-CFLAGS.patch"
5 6
6SRC_URI[md5sum] = "7f4a6c89e56c48e3350e611f5b36c2cf" 7SRC_URI[md5sum] = "d86c78624b47625c2f0fc64eda599443"
7SRC_URI[sha256sum] = "b6e2694d19ac08f1c3416d5b2a02a31d445db2ed98dec89761430cdff2c9710d" 8SRC_URI[sha256sum] = "65428816f88ad3fe92b67df86dc05427c8078fe03843b8b9715fdfa6d29c0f97"
8 9
9 10
10LICENSE = "BSD-0-Clause" 11LICENSE = "BSD-0-Clause"
@@ -12,9 +13,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=f0b8b3dd6431bcaa245da0a08bd0d511"
12 13
13SECTION = "base" 14SECTION = "base"
14 15
16CFLAGS_prepend = "-I ${STAGING_DIR_HOST}${includedir_native}"
17
15do_configure() { 18do_configure() {
16 oe_runmake defconfig 19 oe_runmake defconfig
17
18 # Disable killall5 as it isn't managed by update-alternatives 20 # Disable killall5 as it isn't managed by update-alternatives
19 sed -e 's/CONFIG_KILLALL5=y/# CONFIG_KILLALL5 is not set/' -i .config 21 sed -e 's/CONFIG_KILLALL5=y/# CONFIG_KILLALL5 is not set/' -i .config
20} 22}