summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-06 10:24:33 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-06 10:24:40 +0200
commit5b27dc8974cbd4fd769ed61d9287bedc63d2a644 (patch)
treefa0218071b48d9ce59788515d400715023e8a64b /meta-oe/recipes-core
parentaccc0d62ae67e36acfed8a469f0deea716d9de70 (diff)
downloadmeta-openembedded-5b27dc8974cbd4fd769ed61d9287bedc63d2a644.tar.gz
systemd: bump SRCREV and fix postinst
The u-a class gets in the way of the addgroup, so do things manually Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb23
1 files changed, 9 insertions, 14 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index f6c675273..6a9d86497 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -17,9 +17,9 @@ PKGV = "v${GITPKGVTAG}"
17PV = "git" 17PV = "git"
18PR = "r4" 18PR = "r4"
19 19
20inherit autotools vala update-alternatives 20inherit autotools vala
21 21
22SRCREV = "9a66640832d103f906c2ef609a1d19d43fc542f6" 22SRCREV = "78e39b43b89c6bf9ce401d6030939a004a23c850"
23 23
24SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \ 24SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \
25 file://execute.patch \ 25 file://execute.patch \
@@ -54,11 +54,6 @@ do_install_append() {
54 fi 54 fi
55} 55}
56 56
57ALTERNATIVE_NAME = "init"
58ALTERNATIVE_LINK = "${base_sbindir}/init"
59ALTERNATIVE_PATH = "${base_bindir}/systemd"
60ALTERNATIVE_PRIORITY = "80"
61
62PACKAGES =+ "${PN}-gui ${PN}-serialgetty" 57PACKAGES =+ "${PN}-gui ${PN}-serialgetty"
63 58
64FILES_${PN}-gui = "${bindir}/systemadm" 59FILES_${PN}-gui = "${bindir}/systemadm"
@@ -101,17 +96,17 @@ RRECOMMENDS_${PN} += "kbd kbd-consolefonts \
101# u-a for runlevel and telinit 96# u-a for runlevel and telinit
102 97
103pkg_postinst_${PN} () { 98pkg_postinst_${PN} () {
104# can't do this offline, but we need the u-a bits 99update-alternatives --install ${base_sbindir}/init init ${base_bindir}/systemd 300
105if [ "x$D" != "x" ]; then
106 echo "can't do addgroup offline"
107else
108 grep "^lock:" /etc/group > /dev/null || addgroup lock
109fi
110
111update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300 100update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300
112update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300 101update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300
113update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300 102update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300
114update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/systemctl 300 103update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/systemctl 300
115 104
105# can't do this offline, but we need the u-a bits above
106if [ "x$D" != "x" ]; then
107 echo "can't do addgroup offline" ; exit 1
108else
109 grep "^lock:" /etc/group > /dev/null || addgroup lock
110fi
116} 111}
117 112