diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-06-06 10:24:33 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-06-06 10:24:40 +0200 |
commit | 5b27dc8974cbd4fd769ed61d9287bedc63d2a644 (patch) | |
tree | fa0218071b48d9ce59788515d400715023e8a64b /meta-oe/recipes-core | |
parent | accc0d62ae67e36acfed8a469f0deea716d9de70 (diff) | |
download | meta-openembedded-5b27dc8974cbd4fd769ed61d9287bedc63d2a644.tar.gz |
systemd: bump SRCREV and fix postinst
The u-a class gets in the way of the addgroup, so do things manually
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r-- | meta-oe/recipes-core/systemd/systemd_git.bb | 23 |
1 files changed, 9 insertions, 14 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb index f6c675273..6a9d86497 100644 --- a/meta-oe/recipes-core/systemd/systemd_git.bb +++ b/meta-oe/recipes-core/systemd/systemd_git.bb | |||
@@ -17,9 +17,9 @@ PKGV = "v${GITPKGVTAG}" | |||
17 | PV = "git" | 17 | PV = "git" |
18 | PR = "r4" | 18 | PR = "r4" |
19 | 19 | ||
20 | inherit autotools vala update-alternatives | 20 | inherit autotools vala |
21 | 21 | ||
22 | SRCREV = "9a66640832d103f906c2ef609a1d19d43fc542f6" | 22 | SRCREV = "78e39b43b89c6bf9ce401d6030939a004a23c850" |
23 | 23 | ||
24 | SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \ | 24 | SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \ |
25 | file://execute.patch \ | 25 | file://execute.patch \ |
@@ -54,11 +54,6 @@ do_install_append() { | |||
54 | fi | 54 | fi |
55 | } | 55 | } |
56 | 56 | ||
57 | ALTERNATIVE_NAME = "init" | ||
58 | ALTERNATIVE_LINK = "${base_sbindir}/init" | ||
59 | ALTERNATIVE_PATH = "${base_bindir}/systemd" | ||
60 | ALTERNATIVE_PRIORITY = "80" | ||
61 | |||
62 | PACKAGES =+ "${PN}-gui ${PN}-serialgetty" | 57 | PACKAGES =+ "${PN}-gui ${PN}-serialgetty" |
63 | 58 | ||
64 | FILES_${PN}-gui = "${bindir}/systemadm" | 59 | FILES_${PN}-gui = "${bindir}/systemadm" |
@@ -101,17 +96,17 @@ RRECOMMENDS_${PN} += "kbd kbd-consolefonts \ | |||
101 | # u-a for runlevel and telinit | 96 | # u-a for runlevel and telinit |
102 | 97 | ||
103 | pkg_postinst_${PN} () { | 98 | pkg_postinst_${PN} () { |
104 | # can't do this offline, but we need the u-a bits | 99 | update-alternatives --install ${base_sbindir}/init init ${base_bindir}/systemd 300 |
105 | if [ "x$D" != "x" ]; then | ||
106 | echo "can't do addgroup offline" | ||
107 | else | ||
108 | grep "^lock:" /etc/group > /dev/null || addgroup lock | ||
109 | fi | ||
110 | |||
111 | update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300 | 100 | update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300 |
112 | update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300 | 101 | update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300 |
113 | update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300 | 102 | update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300 |
114 | update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/systemctl 300 | 103 | update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/systemctl 300 |
115 | 104 | ||
105 | # can't do this offline, but we need the u-a bits above | ||
106 | if [ "x$D" != "x" ]; then | ||
107 | echo "can't do addgroup offline" ; exit 1 | ||
108 | else | ||
109 | grep "^lock:" /etc/group > /dev/null || addgroup lock | ||
110 | fi | ||
116 | } | 111 | } |
117 | 112 | ||