diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-28 13:49:59 +0000 |
---|---|---|
committer | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-28 14:32:06 +0000 |
commit | 3a30c562385cb3d9cd1b3043f6fe677a22024018 (patch) | |
tree | 66dc67f338ba316c25ca672950ef334e9e357386 /meta-oe/recipes-core | |
parent | d66c9a8b625f7b19f7b17e728dc82413399c2e19 (diff) | |
download | meta-openembedded-3a30c562385cb3d9cd1b3043f6fe677a22024018.tar.gz |
Replace bb.data.* with d.*
Used sed expression given here:
http://lists.linuxtogo.org/pipermail/openembedded-core/2011-November/012373.html
Plus an additional expression for .expand. Full expression is:
sed \
-e 's:bb.data.\(setVar([^,]*,[^,]*\), \([^ )]*\) *):\2.\1):g' \
-e 's:bb.data.\(setVarFlag([^,]*,[^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(expand([^,]*\), \([^ )]*\) *):\2.\1):g' \
-i `grep -ril bb.data *`
Some minor correction in systemd.bbclass was needed for some expressions
that didn't quite match the regex in the desired way; additionally a few
instances were manually changed.
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-core')
4 files changed, 6 insertions, 6 deletions
diff --git a/meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb b/meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb index 3bcebabf4..1e9f15a67 100644 --- a/meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb +++ b/meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb | |||
@@ -9,8 +9,8 @@ EXTRA_OECONF = "--program-prefix=" | |||
9 | 9 | ||
10 | # Compatability for the rare systems not using or having SYSV | 10 | # Compatability for the rare systems not using or having SYSV |
11 | python () { | 11 | python () { |
12 | if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0': | 12 | if d.getVar('HOST_NONSYSV', True) and d.getVar('HOST_NONSYSV', True) != '0': |
13 | bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d) | 13 | d.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ') |
14 | } | 14 | } |
15 | 15 | ||
16 | RDEPENDS_${PN} = "util-linux-native" | 16 | RDEPENDS_${PN} = "util-linux-native" |
diff --git a/meta-oe/recipes-core/glib-2.0/glibmm.inc b/meta-oe/recipes-core/glib-2.0/glibmm.inc index 60e9bceaa..15aeaac2c 100644 --- a/meta-oe/recipes-core/glib-2.0/glibmm.inc +++ b/meta-oe/recipes-core/glib-2.0/glibmm.inc | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d8045f3b8f929c1cb29a1e3fd737b499 \ | |||
7 | file://COPYING.tools;md5=751419260aa954499f7abaabaa882bbe" | 7 | file://COPYING.tools;md5=751419260aa954499f7abaabaa882bbe" |
8 | 8 | ||
9 | DEPENDS = "mm-common glib-2.0 libsigc++-2.0" | 9 | DEPENDS = "mm-common glib-2.0 libsigc++-2.0" |
10 | SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}" | 10 | SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" |
11 | 11 | ||
12 | SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/glibmm/${SHRT_VER}/glibmm-${PV}.tar.bz2;name=archive" | 12 | SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/glibmm/${SHRT_VER}/glibmm-${PV}.tar.bz2;name=archive" |
13 | 13 | ||
diff --git a/meta-oe/recipes-core/meta/distro-feed-configs.bb b/meta-oe/recipes-core/meta/distro-feed-configs.bb index a25ef8f70..cff0946da 100644 --- a/meta-oe/recipes-core/meta/distro-feed-configs.bb +++ b/meta-oe/recipes-core/meta/distro-feed-configs.bb | |||
@@ -21,8 +21,8 @@ PACKAGE_ARCH = "${MACHINE_ARCH}" | |||
21 | 21 | ||
22 | #def distro_feed_configs(d): | 22 | #def distro_feed_configs(d): |
23 | # import bb | 23 | # import bb |
24 | # parchs = bb.data.getVar( "PACKAGE_EXTRA_ARCHS", d, 1 ).split() | 24 | # parchs = d.getVar( "PACKAGE_EXTRA_ARCHS", 1 ).split() |
25 | # march = bb.data.getVar( "MACHINE_ARCH", d, 1 ).split() | 25 | # march = d.getVar( "MACHINE_ARCH", 1 ).split() |
26 | # archs = [ "all" ] + parchs + march | 26 | # archs = [ "all" ] + parchs + march |
27 | # confs = [ ( "${sysconfdir}/opkg/%s-feed.conf" % feed ) for feed in archs ] | 27 | # confs = [ ( "${sysconfdir}/opkg/%s-feed.conf" % feed ) for feed in archs ] |
28 | # return " ".join( confs ) | 28 | # return " ".join( confs ) |
diff --git a/meta-oe/recipes-core/proxy-libintl/proxy-libintl_20100902.bb b/meta-oe/recipes-core/proxy-libintl/proxy-libintl_20100902.bb index f125fb57f..451a3c697 100644 --- a/meta-oe/recipes-core/proxy-libintl/proxy-libintl_20100902.bb +++ b/meta-oe/recipes-core/proxy-libintl/proxy-libintl_20100902.bb | |||
@@ -16,7 +16,7 @@ SRC_URI[sha256sum] = "291ac350cc5eb4a01b0d651ca99fae64cee8a1c06b2005277fab5a4356 | |||
16 | S = "${WORKDIR}" | 16 | S = "${WORKDIR}" |
17 | FILES_${PN}-dev = "${includedir}/libintl.h ${libdir}/libintl.a" | 17 | FILES_${PN}-dev = "${includedir}/libintl.h ${libdir}/libintl.a" |
18 | 18 | ||
19 | CFLAGS_append = " -fPIC -Wall -I ../../include ${@['-DSTUB_ONLY', ''][bb.data.getVar('USE_NLS', d, 1) != 'no']}" | 19 | CFLAGS_append = " -fPIC -Wall -I ../../include ${@['-DSTUB_ONLY', ''][d.getVar('USE_NLS', 1) != 'no']}" |
20 | TARGET_CC_ARCH += "${LDFLAGS}" | 20 | TARGET_CC_ARCH += "${LDFLAGS}" |
21 | 21 | ||
22 | do_compile() { | 22 | do_compile() { |