diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-06-28 14:51:58 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-06-28 14:57:03 +0200 |
commit | 15a5642b2a4df41dc0adf9d250cd5085eaf1d69b (patch) | |
tree | 1fba23ff174965b022128979ef445e09a65b5c6f /meta-oe/recipes-core | |
parent | 705e4e484f69dca56db5728e7fb1f14de95fc183 (diff) | |
download | meta-openembedded-15a5642b2a4df41dc0adf9d250cd5085eaf1d69b.tar.gz |
libcap2: drop, it's in oe-core already
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r-- | meta-oe/recipes-core/libcap/libcap2/make.patch | 30 | ||||
-rw-r--r-- | meta-oe/recipes-core/libcap/libcap2_2.20.bb | 29 |
2 files changed, 0 insertions, 59 deletions
diff --git a/meta-oe/recipes-core/libcap/libcap2/make.patch b/meta-oe/recipes-core/libcap/libcap2/make.patch deleted file mode 100644 index 57a2cae51..000000000 --- a/meta-oe/recipes-core/libcap/libcap2/make.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | --- a/Make.Rules | ||
2 | +++ b/Make.Rules | ||
3 | @@ -47,25 +47,18 @@ | ||
4 | KERNEL_HEADERS := $(topdir)/libcap/include | ||
5 | IPATH += -fPIC -I$(topdir)/libcap/include -I$(KERNEL_HEADERS) | ||
6 | |||
7 | -CC := gcc | ||
8 | -CFLAGS := -O2 | ||
9 | -BUILD_CC := $(CC) | ||
10 | -BUILD_CFLAGS := $(CFLAGS) $(IPATH) | ||
11 | -AR := ar | ||
12 | -RANLIB := ranlib | ||
13 | DEBUG = -g #-DDEBUG | ||
14 | WARNINGS=-Wall -Wwrite-strings \ | ||
15 | -Wpointer-arith -Wcast-qual -Wcast-align \ | ||
16 | -Wstrict-prototypes -Wmissing-prototypes \ | ||
17 | -Wnested-externs -Winline -Wshadow | ||
18 | LD=$(CC) -Wl,-x -shared | ||
19 | -LDFLAGS := #-g | ||
20 | |||
21 | -SYSTEM_HEADERS = /usr/include | ||
22 | +SYSTEM_HEADERS ?= /usr/include | ||
23 | INCS=$(topdir)/libcap/include/sys/capability.h | ||
24 | LDFLAGS += -L$(topdir)/libcap | ||
25 | CFLAGS += -Dlinux $(WARNINGS) $(DEBUG) | ||
26 | -PAM_CAP := $(shell if [ -f /usr/include/security/pam_modules.h ]; then echo yes ; else echo no ; fi) | ||
27 | +PAM_CAP := $(shell if [ -f $(SYSTEM_HEADERS)/security/pam_modules.h ]; then echo yes ; else echo no ; fi) | ||
28 | INDENT := $(shell if [ -n "$(which indent 2>/dev/null)" ]; then echo "| indent -kr" ; fi) | ||
29 | DYNAMIC := $(shell if [ ! -d "$(topdir)/.git" ]; then echo yes; fi) | ||
30 | LIBATTR := yes | ||
diff --git a/meta-oe/recipes-core/libcap/libcap2_2.20.bb b/meta-oe/recipes-core/libcap/libcap2_2.20.bb deleted file mode 100644 index ec124e6b1..000000000 --- a/meta-oe/recipes-core/libcap/libcap2_2.20.bb +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | DESCRIPTION = "Libcap is a library for getting and setting POSIX.1e (formerly POSIX 6) draft 15 capabilities." | ||
2 | PRIORITY = "optional" | ||
3 | SECTION = "libs" | ||
4 | LICENSE = "GPLv1" | ||
5 | LIC_FILES_CHKSUM = "file://License;md5=731de803c1ccbcb05a9b3523279c8d7f" | ||
6 | |||
7 | DEPENDS = "bison-native flex-native attr ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" | ||
8 | |||
9 | SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/security/linux-privs/libcap2/libcap-${PV}.tar.bz2 \ | ||
10 | file://make.patch \ | ||
11 | " | ||
12 | |||
13 | SRC_URI[md5sum] = "10e47ed32ca2214eb0e58780282d27b4" | ||
14 | SRC_URI[sha256sum] = "20e7c1ea4d3d5c410efb3a6ff138dc417912fae316d883460dcd58d9803a9220" | ||
15 | |||
16 | S = "${WORKDIR}/libcap-${PV}" | ||
17 | |||
18 | EXTRA_OEMAKE = "SYSTEM_HEADERS=${STAGING_INCDIR}" | ||
19 | |||
20 | BUILD_CFLAGS += "-I${S}/libcap/include" | ||
21 | CFLAGS += "-I${S}/libcap/include" | ||
22 | LDFLAGS =+ "-L../libcap" | ||
23 | |||
24 | do_install() { | ||
25 | install -d ${D}${includedir}/sys | ||
26 | install -m 0644 libcap/include/sys/capability.h ${D}${includedir}/sys/ | ||
27 | install -d ${D}${libdir} | ||
28 | oe_libinstall -s -C libcap libcap ${D}${libdir} | ||
29 | } | ||