summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-02-22 16:56:45 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-02-23 16:46:32 +0100
commit3a5e1a0d86b8fc8d1898e69b07e51a5f64f5e2c3 (patch)
tree34a3859051df0ab799962bb57ebc7599fca71793 /meta-oe/recipes-core
parent62dd0bf7ebbb01d1e592e048db78e0bb96502cc4 (diff)
downloadmeta-openembedded-3a5e1a0d86b8fc8d1898e69b07e51a5f64f5e2c3.tar.gz
busybox: remove unneeded systemd code / use ${systemd_unitdir}
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend15
1 files changed, 5 insertions, 10 deletions
diff --git a/meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend b/meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend
index 98b959fdf..2c7373240 100644
--- a/meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend
+++ b/meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend
@@ -1,6 +1,6 @@
1inherit systemd 1inherit systemd
2 2
3PRINC := "${@int(PRINC) + 2}" 3PRINC := "${@int(PRINC) + 3}"
4 4
5# look for files in the layer first 5# look for files in the layer first
6FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 6FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
@@ -16,16 +16,11 @@ do_install_append() {
16 install -d ${D}${sysconfdir}/default 16 install -d ${D}${sysconfdir}/default
17 install -m 0644 ${WORKDIR}/busybox-syslog.default ${D}${sysconfdir}/default/busybox-syslog 17 install -m 0644 ${WORKDIR}/busybox-syslog.default ${D}${sysconfdir}/default/busybox-syslog
18 18
19 install -d ${D}${base_libdir}/systemd/system
20 sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-syslog.service.in \ 19 sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-syslog.service.in \
21 > ${D}${base_libdir}/systemd/system/busybox-syslog.service 20 > ${D}${systemd_unitdir}/system/busybox-syslog.service
22 sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-klogd.service.in \ 21 sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-klogd.service.in \
23 > ${D}${base_libdir}/systemd/system/busybox-klogd.service 22 > ${D}${systemd_unitdir}/system/busybox-klogd.service
24 23
25 ln -sf /dev/null ${D}${base_libdir}/systemd/system/syslog.service 24 ln -sf /dev/null ${D}${systemd_unitdir}/system/syslog.service
26} 25}
27 26FILES_${PN}-syslog-systemd = "${systemd_unitdir}/system/syslog.service"
28PACKAGES += "${PN}-syslog-systemd"
29
30RDEPENDS_${PN}-syslog-systemd += "${PN}-syslog"
31FILES_${PN}-syslog-systemd = "${base_libdir}/systemd"