diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 22:49:41 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:23:17 +0200 |
commit | a45830a39bb47a9eab27980d52966226c9504ea4 (patch) | |
tree | 001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-core | |
parent | 6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff) | |
download | meta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz |
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python
tasks).
* Some recipes were using tabs.
* Some were using 8 spaces.
* Some were using mix or different number of spaces.
* Make them consistently use 4 spaces everywhere.
* Yocto styleguide advises to use tabs (but the only reason to keep
tabs is the need to update a lot of recipes). Lately this advice
was also merged into the styleguide on the OE wiki.
* Using 4 spaces in both types of tasks is better because it's less
error prone when someone is not sure if e.g.
do_generate_toolchain_file() is Python or shell task and also allows
to highlight every tab used in .bb, .inc, .bbappend, .bbclass as
potentially bad (shouldn't be used for indenting of multiline
variable assignments and cannot be used for Python tasks).
* Don't indent closing quote on multiline variables
we're quite inconsistent wheater it's first character on line
under opening quote or under first non-whitespace character in
previous line.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core')
10 files changed, 63 insertions, 63 deletions
diff --git a/meta-oe/recipes-core/busybox/busybox_1.20.2.bbappend b/meta-oe/recipes-core/busybox/busybox_1.20.2.bbappend index 5d06265326..721ef19d76 100644 --- a/meta-oe/recipes-core/busybox/busybox_1.20.2.bbappend +++ b/meta-oe/recipes-core/busybox/busybox_1.20.2.bbappend | |||
@@ -6,8 +6,8 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |||
6 | SRC_URI += "file://busybox-syslog.default" | 6 | SRC_URI += "file://busybox-syslog.default" |
7 | 7 | ||
8 | do_install_append() { | 8 | do_install_append() { |
9 | install -d ${D}${sysconfdir}/default | 9 | install -d ${D}${sysconfdir}/default |
10 | install -m 0644 ${WORKDIR}/busybox-syslog.default ${D}${sysconfdir}/default/busybox-syslog | 10 | install -m 0644 ${WORKDIR}/busybox-syslog.default ${D}${sysconfdir}/default/busybox-syslog |
11 | } | 11 | } |
12 | 12 | ||
13 | FILES_${PN}-syslog += "${sysconfdir}/default/busybox-syslog" | 13 | FILES_${PN}-syslog += "${sysconfdir}/default/busybox-syslog" |
diff --git a/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb b/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb index 03b510e6c4..18d3efbb84 100644 --- a/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb +++ b/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb | |||
@@ -12,11 +12,11 @@ SRC_URI = "git://git.collabora.co.uk/git/user/alban/dbus-daemon-proxy;protocol=g | |||
12 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
13 | 13 | ||
14 | do_compile() { | 14 | do_compile() { |
15 | ${CC} ${LDFLAGS} `pkg-config --cflags --libs dbus-glib-1` -o dbus-daemon-proxy dbus-daemon-proxy.c | 15 | ${CC} ${LDFLAGS} `pkg-config --cflags --libs dbus-glib-1` -o dbus-daemon-proxy dbus-daemon-proxy.c |
16 | } | 16 | } |
17 | 17 | ||
18 | do_install() { | 18 | do_install() { |
19 | install -d ${D}${bindir} | 19 | install -d ${D}${bindir} |
20 | install -m 0755 dbus-daemon-proxy ${D}${bindir} | 20 | install -m 0755 dbus-daemon-proxy ${D}${bindir} |
21 | } | 21 | } |
22 | 22 | ||
diff --git a/meta-oe/recipes-core/f2fs-tools/f2fs-tools_1.1.0.bb b/meta-oe/recipes-core/f2fs-tools/f2fs-tools_1.1.0.bb index 292a88ae7e..e5b5439656 100644 --- a/meta-oe/recipes-core/f2fs-tools/f2fs-tools_1.1.0.bb +++ b/meta-oe/recipes-core/f2fs-tools/f2fs-tools_1.1.0.bb | |||
@@ -13,7 +13,7 @@ inherit autotools | |||
13 | BBCLASSEXTEND = "native" | 13 | BBCLASSEXTEND = "native" |
14 | 14 | ||
15 | do_configure_prepend() { | 15 | do_configure_prepend() { |
16 | # workaround for endless do_configure loop: | 16 | # workaround for endless do_configure loop: |
17 | # make: Warning: File `Makefile.am' has modification time 5.3e+04 s in the future | 17 | # make: Warning: File `Makefile.am' has modification time 5.3e+04 s in the future |
18 | touch ${S}/* | 18 | touch ${S}/* |
19 | } | 19 | } |
diff --git a/meta-oe/recipes-core/fakeroot/fakeroot_1.18.4.bb b/meta-oe/recipes-core/fakeroot/fakeroot_1.18.4.bb index a277a69bf6..8288dfb549 100644 --- a/meta-oe/recipes-core/fakeroot/fakeroot_1.18.4.bb +++ b/meta-oe/recipes-core/fakeroot/fakeroot_1.18.4.bb | |||
@@ -6,18 +6,18 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949" | |||
6 | PR = "r0" | 6 | PR = "r0" |
7 | 7 | ||
8 | SRC_URI = "\ | 8 | SRC_URI = "\ |
9 | ${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.orig.tar.bz2 \ | 9 | ${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.orig.tar.bz2 \ |
10 | " | 10 | " |
11 | 11 | ||
12 | inherit autotools | 12 | inherit autotools |
13 | 13 | ||
14 | do_configure_prepend() { | 14 | do_configure_prepend() { |
15 | mkdir -p ${S}/build-aux | 15 | mkdir -p ${S}/build-aux |
16 | } | 16 | } |
17 | 17 | ||
18 | do_install_append() { | 18 | do_install_append() { |
19 | install -d ${D}${includedir}/fakeroot | 19 | install -d ${D}${includedir}/fakeroot |
20 | install -m 644 *.h ${D}${includedir}/fakeroot | 20 | install -m 644 *.h ${D}${includedir}/fakeroot |
21 | } | 21 | } |
22 | 22 | ||
23 | # fakeroot needs getopt which is provided by the util-linux package | 23 | # fakeroot needs getopt which is provided by the util-linux package |
diff --git a/meta-oe/recipes-core/glib-2.0/glibmm.inc b/meta-oe/recipes-core/glib-2.0/glibmm.inc index 15aeaac2c8..bdb6ff8594 100644 --- a/meta-oe/recipes-core/glib-2.0/glibmm.inc +++ b/meta-oe/recipes-core/glib-2.0/glibmm.inc | |||
@@ -14,11 +14,11 @@ SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/glibmm/${SHRT_VER}/glibmm-${PV} | |||
14 | inherit autotools pkgconfig | 14 | inherit autotools pkgconfig |
15 | 15 | ||
16 | do_install_append() { | 16 | do_install_append() { |
17 | install -d ${D}${datadir}/glibmm-2.4 | 17 | install -d ${D}${datadir}/glibmm-2.4 |
18 | install -d ${D}${datadir}/aclocal | 18 | install -d ${D}${datadir}/aclocal |
19 | 19 | ||
20 | install -m 0644 glib/glibmmconfig.h ${D}${datadir}/glibmm-2.4/ | 20 | install -m 0644 glib/glibmmconfig.h ${D}${datadir}/glibmm-2.4/ |
21 | install -m 0644 scripts/glibmm_check_perl.m4 ${D}${datadir}/aclocal/ || true | 21 | install -m 0644 scripts/glibmm_check_perl.m4 ${D}${datadir}/aclocal/ || true |
22 | } | 22 | } |
23 | 23 | ||
24 | FILES_${PN} = "${libdir}/lib*.so.*" | 24 | FILES_${PN} = "${libdir}/lib*.so.*" |
diff --git a/meta-oe/recipes-core/jpeg/libjpeg-turbo_svn.bb b/meta-oe/recipes-core/jpeg/libjpeg-turbo_svn.bb index d87743b727..4fd258fc18 100644 --- a/meta-oe/recipes-core/jpeg/libjpeg-turbo_svn.bb +++ b/meta-oe/recipes-core/jpeg/libjpeg-turbo_svn.bb | |||
@@ -23,7 +23,7 @@ inherit autotools pkgconfig | |||
23 | 23 | ||
24 | EXTRA_OECONF = "--with-jpeg8 " | 24 | EXTRA_OECONF = "--with-jpeg8 " |
25 | 25 | ||
26 | PACKAGES =+ "jpeg-tools libturbojpeg" | 26 | PACKAGES =+ "jpeg-tools libturbojpeg" |
27 | 27 | ||
28 | DESCRIPTION_jpeg-tools = "The jpeg-tools package includes the client programs for access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files." | 28 | DESCRIPTION_jpeg-tools = "The jpeg-tools package includes the client programs for access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files." |
29 | FILES_jpeg-tools = "${bindir}/*" | 29 | FILES_jpeg-tools = "${bindir}/*" |
diff --git a/meta-oe/recipes-core/meta/distro-feed-configs.bb b/meta-oe/recipes-core/meta/distro-feed-configs.bb index cff0946da6..462af45284 100644 --- a/meta-oe/recipes-core/meta/distro-feed-configs.bb +++ b/meta-oe/recipes-core/meta/distro-feed-configs.bb | |||
@@ -13,8 +13,8 @@ do_compile() { | |||
13 | done | 13 | done |
14 | } | 14 | } |
15 | do_install () { | 15 | do_install () { |
16 | install -d ${D}${sysconfdir}/opkg | 16 | install -d ${D}${sysconfdir}/opkg |
17 | install -m 0644 ${S}/${sysconfdir}/opkg/* ${D}${sysconfdir}/opkg/ | 17 | install -m 0644 ${S}/${sysconfdir}/opkg/* ${D}${sysconfdir}/opkg/ |
18 | } | 18 | } |
19 | 19 | ||
20 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 20 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb b/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb index 402579c6de..c100b79e07 100644 --- a/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb +++ b/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb | |||
@@ -35,9 +35,9 @@ RCONFLICTS_${PN} += "task-basic" | |||
35 | # Util-linux (u)mount is included because the busybox one can't handle /etc/mtab being symlinked to /proc/mounts | 35 | # Util-linux (u)mount is included because the busybox one can't handle /etc/mtab being symlinked to /proc/mounts |
36 | # | 36 | # |
37 | RDEPENDS_${PN} = "\ | 37 | RDEPENDS_${PN} = "\ |
38 | ${TASK_BASIC_SSHDAEMON} \ | 38 | ${TASK_BASIC_SSHDAEMON} \ |
39 | avahi-daemon avahi-utils \ | 39 | avahi-daemon avahi-utils \ |
40 | " | 40 | " |
41 | 41 | ||
42 | # | 42 | # |
43 | # The following section is split in 3: | 43 | # The following section is split in 3: |
@@ -46,16 +46,16 @@ RDEPENDS_${PN} = "\ | |||
46 | # 3) Nice to have: packages that are nice to have, but aren't strictly needed | 46 | # 3) Nice to have: packages that are nice to have, but aren't strictly needed |
47 | # | 47 | # |
48 | RRECOMMENDS_${PN} = "\ | 48 | RRECOMMENDS_${PN} = "\ |
49 | ${MACHINE_EXTRA_RRECOMMENDS} \ | 49 | ${MACHINE_EXTRA_RRECOMMENDS} \ |
50 | ${@base_contains("MACHINE_FEATURES", "usbhost", "usbutils", "", d)} \ | 50 | ${@base_contains("MACHINE_FEATURES", "usbhost", "usbutils", "", d)} \ |
51 | ${@base_contains("MACHINE_FEATURES", "alsa", "alsa-utils-alsamixer", "", d)} \ | 51 | ${@base_contains("MACHINE_FEATURES", "alsa", "alsa-utils-alsamixer", "", d)} \ |
52 | ${@base_contains("MACHINE_FEATURES", "usbgadget", "kernel-module-g-ether kernel-module-g-serial kernel-module-g-mass-storage", "", d)} \ | 52 | ${@base_contains("MACHINE_FEATURES", "usbgadget", "kernel-module-g-ether kernel-module-g-serial kernel-module-g-mass-storage", "", d)} \ |
53 | \ | 53 | \ |
54 | ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4", "", d)} \ | 54 | ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4", "", d)} \ |
55 | ${@base_contains("DISTRO_FEATURES", "wifi", "iw wpa-supplicant", "", d)} \ | 55 | ${@base_contains("DISTRO_FEATURES", "wifi", "iw wpa-supplicant", "", d)} \ |
56 | \ | 56 | \ |
57 | tzdata \ | 57 | tzdata \ |
58 | \ | 58 | \ |
59 | cpufrequtils \ | 59 | cpufrequtils \ |
60 | htop \ | 60 | htop \ |
61 | " | 61 | " |
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb b/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb index 1d6ae9eda0..a46f4fac9d 100644 --- a/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb +++ b/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb | |||
@@ -33,9 +33,9 @@ RDEPENDS_${PN} = "\ | |||
33 | netbase \ | 33 | netbase \ |
34 | ${@base_contains("MACHINE_FEATURES", "keyboard", "keymaps", "", d)} \ | 34 | ${@base_contains("MACHINE_FEATURES", "keyboard", "keymaps", "", d)} \ |
35 | ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \ | 35 | ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \ |
36 | " | 36 | " |
37 | 37 | ||
38 | RRECOMMENDS_${PN} = "\ | 38 | RRECOMMENDS_${PN} = "\ |
39 | kernel \ | 39 | kernel \ |
40 | ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS} \ | 40 | ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS} \ |
41 | " | 41 | " |
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb b/meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb index 88b62b8ad5..fa53a67e78 100644 --- a/meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb +++ b/meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb | |||
@@ -18,36 +18,36 @@ RCONFLICTS_${PN} += "task-cli-tools" | |||
18 | RCONFLICTS_${PN}-debug += "task-cli-tools-debug" | 18 | RCONFLICTS_${PN}-debug += "task-cli-tools-debug" |
19 | 19 | ||
20 | RDEPENDS_${PN} = "\ | 20 | RDEPENDS_${PN} = "\ |
21 | dbus-daemon-proxy \ | 21 | dbus-daemon-proxy \ |
22 | dosfstools \ | 22 | dosfstools \ |
23 | htop \ | 23 | htop \ |
24 | iptables \ | 24 | iptables \ |
25 | lsof \ | 25 | lsof \ |
26 | mbuffer \ | 26 | mbuffer \ |
27 | mtd-utils \ | 27 | mtd-utils \ |
28 | nano \ | 28 | nano \ |
29 | nfs-utils-client \ | 29 | nfs-utils-client \ |
30 | nmon \ | 30 | nmon \ |
31 | powertop \ | 31 | powertop \ |
32 | screen \ | 32 | screen \ |
33 | socat \ | 33 | socat \ |
34 | sysstat \ | 34 | sysstat \ |
35 | " | 35 | " |
36 | 36 | ||
37 | RDEPENDS_${PN}-debug = "\ | 37 | RDEPENDS_${PN}-debug = "\ |
38 | evtest \ | 38 | evtest \ |
39 | devmem2 \ | 39 | devmem2 \ |
40 | i2c-tools \ | 40 | i2c-tools \ |
41 | gdb \ | 41 | gdb \ |
42 | procps \ | 42 | procps \ |
43 | pxaregs \ | 43 | pxaregs \ |
44 | s3c24xx-gpio \ | 44 | s3c24xx-gpio \ |
45 | s3c64xx-gpio \ | 45 | s3c64xx-gpio \ |
46 | serial-forward \ | 46 | serial-forward \ |
47 | strace \ | 47 | strace \ |
48 | tcpdump \ | 48 | tcpdump \ |
49 | " | 49 | " |
50 | 50 | ||
51 | RRECOMMENDS_${PN}-debug = "\ | 51 | RRECOMMENDS_${PN}-debug = "\ |
52 | ltrace \ | 52 | ltrace \ |
53 | " | 53 | " |