summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-09-04 18:24:48 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-09-06 13:13:59 +0200
commitba89801d4dc6b7c79d2f0e333e424d14a64c786a (patch)
tree83bd48b047155ed16df5f7323d825d17e48f85d5 /meta-oe/recipes-core
parent49e269ecc66adda341922cbd86167bbfa97c54ca (diff)
downloadmeta-openembedded-ba89801d4dc6b7c79d2f0e333e424d14a64c786a.tar.gz
task-x11*: remove in favor of packagegroup-core-x11* variants from oe-core
* packagegroup-core-x11* allows to remove task-x11-server and task-x11 from meta-oe without loosing any functionality * be carefull with 2 changed default values: XSERVER does not include xf86-input-mouse and xf86-input-keyboard VIRTUAL-RUNTIME_xserver_common defaults to x11-common in oe-core and to xserver-common in meta-oe's task-x11 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/tasks/task-x11-server_1.0.bb23
-rw-r--r--meta-oe/recipes-core/tasks/task-x11_1.0.bb30
2 files changed, 0 insertions, 53 deletions
diff --git a/meta-oe/recipes-core/tasks/task-x11-server_1.0.bb b/meta-oe/recipes-core/tasks/task-x11-server_1.0.bb
deleted file mode 100644
index 7e43d5507..000000000
--- a/meta-oe/recipes-core/tasks/task-x11-server_1.0.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1DESCRIPTION = "Task for an image with Xserver"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
4PR = "r9"
5
6inherit task
7
8# for backwards compatibility
9RPROVIDES_${PN} += "task-xserver"
10
11XSERVER ?= "xserver-xorg \
12 xf86-input-evdev \
13 xf86-input-mouse \
14 xf86-video-fbdev \
15 xf86-input-keyboard \
16"
17
18
19RDEPENDS_${PN} = " \
20 ${XSERVER} \
21"
22
23PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-oe/recipes-core/tasks/task-x11_1.0.bb b/meta-oe/recipes-core/tasks/task-x11_1.0.bb
deleted file mode 100644
index 326e09f31..000000000
--- a/meta-oe/recipes-core/tasks/task-x11_1.0.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1DESCRIPTION = "The X Window System -- install this task to get a client/server based display multiplexer."
2SECTION = "x11/server"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5PR = "r11"
6
7inherit task allarch
8
9PACKAGES += "${PN}-utils"
10
11RRECOMMENDS_${PN} = "\
12 ${PN}-server \
13 ${PN}-utils \
14"
15
16# xserver-common, x11-common
17VIRTUAL-RUNTIME_xserver_common ?= "xserver-common"
18
19# elsa or xserver-nodm-init(-systemd)
20VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
21
22RDEPENDS_${PN}-utils = "\
23 ${VIRTUAL-RUNTIME_xserver_common} \
24 ${VIRTUAL-RUNTIME_graphical_init_manager} \
25 xauth \
26 xhost \
27 xset \
28 xrandr \
29"
30