diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2012-09-17 10:58:08 +0000 |
---|---|---|
committer | Eric Bénard <eric@eukrea.com> | 2012-12-16 10:50:25 +0100 |
commit | d6dd53c3b69e341a1f5102d9e88bb72d07d0e33d (patch) | |
tree | 4298a0489636c684744497891acfb92e2752e350 /meta-oe/recipes-core | |
parent | e5b3091351d96dcb89cec287357c67be53e46e7d (diff) | |
download | meta-openembedded-d6dd53c3b69e341a1f5102d9e88bb72d07d0e33d.tar.gz |
systemd-systemctl-native: handle ALIAS tag
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r-- | meta-oe/recipes-core/systemd/systemd-systemctl-native.bb | 2 | ||||
-rwxr-xr-x | meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl | 17 |
2 files changed, 18 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb b/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb index 5f23e988e..25ddbdade 100644 --- a/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb +++ b/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb | |||
@@ -3,7 +3,7 @@ DESCRIPTION = "Wrapper to enable of systemd services" | |||
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" |
5 | 5 | ||
6 | PR = "r4" | 6 | PR = "r5" |
7 | 7 | ||
8 | inherit native | 8 | inherit native |
9 | 9 | ||
diff --git a/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl b/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl index f74adf6c6..196e7295d 100755 --- a/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl +++ b/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl | |||
@@ -96,6 +96,23 @@ for service in $services; do | |||
96 | fi | 96 | fi |
97 | done | 97 | done |
98 | 98 | ||
99 | # create the required symbolic 'Alias' links | ||
100 | alias=$(grep Alias $ROOT/$service_file \ | ||
101 | | sed 's,Alias=,,g' \ | ||
102 | | tr ',' '\n' \ | ||
103 | | grep '\.service$') | ||
104 | |||
105 | for r in $alias; do | ||
106 | if [ "$action" = "enable" ]; then | ||
107 | mkdir -p $ROOT/etc/systemd/system | ||
108 | ln -s $service_file $ROOT/etc/systemd/system/$r | ||
109 | echo "Enabled $service for $alias." | ||
110 | else | ||
111 | rm -f $ROOT/etc/systemd/system/$r | ||
112 | echo "Disabled $service for $alias." | ||
113 | fi | ||
114 | done | ||
115 | |||
99 | # call us for the other required scripts | 116 | # call us for the other required scripts |
100 | also=$(grep Also $ROOT/$service_file \ | 117 | also=$(grep Also $ROOT/$service_file \ |
101 | | sed 's,Also=,,g' \ | 118 | | sed 's,Also=,,g' \ |