diff options
author | Dan McGregor <dan.mcgregor@usask.ca> | 2018-10-18 09:46:28 -0600 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-10-18 14:19:37 -0700 |
commit | cdd3e9ab99d4ffda673b564ba802b6bd2d40eabf (patch) | |
tree | d572af42478e5022a7a35800418856d07864f79a /meta-oe/recipes-core/toybox | |
parent | 897c10b7c17c138a85bdeb36cf72e7201daf0e0e (diff) | |
download | meta-openembedded-cdd3e9ab99d4ffda673b564ba802b6bd2d40eabf.tar.gz |
toybox: Fix paths to match OE conventions
Many toybox commands get installed in places that are unexpected
in openembedded-core, causing conflicts. Fix up the paths I identified
that are causing conflicts.
Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core/toybox')
-rw-r--r-- | meta-oe/recipes-core/toybox/toybox/OE-path-changes.patch | 195 | ||||
-rw-r--r-- | meta-oe/recipes-core/toybox/toybox_0.7.5.bb | 4 |
2 files changed, 198 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/toybox/toybox/OE-path-changes.patch b/meta-oe/recipes-core/toybox/toybox/OE-path-changes.patch new file mode 100644 index 000000000..e42c22ebd --- /dev/null +++ b/meta-oe/recipes-core/toybox/toybox/OE-path-changes.patch | |||
@@ -0,0 +1,195 @@ | |||
1 | diff --git a/toys/net/microcom.c b/toys/net/microcom.c | ||
2 | index d34e1fe..a369e6c 100644 | ||
3 | --- a/toys/net/microcom.c | ||
4 | +++ b/toys/net/microcom.c | ||
5 | @@ -2,7 +2,7 @@ | ||
6 | * | ||
7 | * Copyright 2017 The Android Open Source Project. | ||
8 | |||
9 | -USE_MICROCOM(NEWTOY(microcom, "<1>1s:X", TOYFLAG_BIN)) | ||
10 | +USE_MICROCOM(NEWTOY(microcom, "<1>1s:X", TOYFLAG_USR|TOYFLAG_BIN)) | ||
11 | |||
12 | config MICROCOM | ||
13 | bool "microcom" | ||
14 | diff --git a/toys/other/blockdev.c b/toys/other/blockdev.c | ||
15 | index 38e0993..c5d9fcd 100644 | ||
16 | --- a/toys/other/blockdev.c | ||
17 | +++ b/toys/other/blockdev.c | ||
18 | @@ -4,7 +4,7 @@ | ||
19 | * | ||
20 | * No Standard. | ||
21 | |||
22 | -USE_BLOCKDEV(NEWTOY(blockdev, "<1>1(setro)(setrw)(getro)(getss)(getbsz)(setbsz)#<0(getsz)(getsize)(getsize64)(flushbufs)(rereadpt)",TOYFLAG_USR|TOYFLAG_BIN)) | ||
23 | +USE_BLOCKDEV(NEWTOY(blockdev, "<1>1(setro)(setrw)(getro)(getss)(getbsz)(setbsz)#<0(getsz)(getsize)(getsize64)(flushbufs)(rereadpt)",TOYFLAG_SBIN)) | ||
24 | |||
25 | config BLOCKDEV | ||
26 | bool "blockdev" | ||
27 | diff --git a/toys/other/chrt.c b/toys/other/chrt.c | ||
28 | index a1c37a0..d6db3a5 100644 | ||
29 | --- a/toys/other/chrt.c | ||
30 | +++ b/toys/other/chrt.c | ||
31 | @@ -4,7 +4,7 @@ | ||
32 | * | ||
33 | * Note: -ibrfo flags sorted to match SCHED positions for highest_bit() | ||
34 | |||
35 | -USE_CHRT(NEWTOY(chrt, "^mp#<0iRbrfo[!ibrfo]", TOYFLAG_USR|TOYFLAG_SBIN)) | ||
36 | +USE_CHRT(NEWTOY(chrt, "^mp#<0iRbrfo[!ibrfo]", TOYFLAG_USR|TOYFLAG_BIN)) | ||
37 | |||
38 | config CHRT | ||
39 | bool "chrt" | ||
40 | diff --git a/toys/other/hwclock.c b/toys/other/hwclock.c | ||
41 | index 1d313e3..412582d 100644 | ||
42 | --- a/toys/other/hwclock.c | ||
43 | +++ b/toys/other/hwclock.c | ||
44 | @@ -4,7 +4,7 @@ | ||
45 | * | ||
46 | * No standard, but see Documentation/rtc.txt in the linux kernel source.. | ||
47 | * | ||
48 | -USE_HWCLOCK(NEWTOY(hwclock, ">0(fast)f(rtc):u(utc)l(localtime)t(systz)s(hctosys)r(show)w(systohc)[-ul][!rtsw]", TOYFLAG_USR|TOYFLAG_BIN)) | ||
49 | +USE_HWCLOCK(NEWTOY(hwclock, ">0(fast)f(rtc):u(utc)l(localtime)t(systz)s(hctosys)r(show)w(systohc)[-ul][!rtsw]", TOYFLAG_SBIN)) | ||
50 | |||
51 | config HWCLOCK | ||
52 | bool "hwclock" | ||
53 | diff --git a/toys/other/modinfo.c b/toys/other/modinfo.c | ||
54 | index 1178d67..966a9de 100644 | ||
55 | --- a/toys/other/modinfo.c | ||
56 | +++ b/toys/other/modinfo.c | ||
57 | @@ -4,7 +4,7 @@ | ||
58 | * | ||
59 | * TODO: cleanup | ||
60 | |||
61 | -USE_MODINFO(NEWTOY(modinfo, "<1b:k:F:0", TOYFLAG_BIN)) | ||
62 | +USE_MODINFO(NEWTOY(modinfo, "<1b:k:F:0", TOYFLAG_SBIN)) | ||
63 | |||
64 | config MODINFO | ||
65 | bool "modinfo" | ||
66 | diff --git a/toys/other/pmap.c b/toys/other/pmap.c | ||
67 | index abb0a33..2acef02 100644 | ||
68 | --- a/toys/other/pmap.c | ||
69 | +++ b/toys/other/pmap.c | ||
70 | @@ -5,7 +5,7 @@ | ||
71 | * | ||
72 | * No Standard. | ||
73 | |||
74 | -USE_PMAP(NEWTOY(pmap, "<1xq", TOYFLAG_BIN)) | ||
75 | +USE_PMAP(NEWTOY(pmap, "<1xq", TOYFLAG_USR|TOYFLAG_BIN)) | ||
76 | |||
77 | config PMAP | ||
78 | bool "pmap" | ||
79 | diff --git a/toys/other/printenv.c b/toys/other/printenv.c | ||
80 | index e8bcf29..65f62ed 100644 | ||
81 | --- a/toys/other/printenv.c | ||
82 | +++ b/toys/other/printenv.c | ||
83 | @@ -2,7 +2,7 @@ | ||
84 | * | ||
85 | * Copyright 2012 Georgi Chorbadzhiyski <georgi@unixsol.org> | ||
86 | |||
87 | -USE_PRINTENV(NEWTOY(printenv, "0(null)", TOYFLAG_USR|TOYFLAG_BIN)) | ||
88 | +USE_PRINTENV(NEWTOY(printenv, "0(null)", TOYFLAG_BIN)) | ||
89 | |||
90 | config PRINTENV | ||
91 | bool "printenv" | ||
92 | diff --git a/toys/other/taskset.c b/toys/other/taskset.c | ||
93 | index 8ffdab7..89fd528 100644 | ||
94 | --- a/toys/other/taskset.c | ||
95 | +++ b/toys/other/taskset.c | ||
96 | @@ -2,7 +2,7 @@ | ||
97 | * | ||
98 | * Copyright 2012 Elie De Brauwer <eliedebrauwer@gmail.com> | ||
99 | |||
100 | -USE_TASKSET(NEWTOY(taskset, "<1^pa", TOYFLAG_BIN|TOYFLAG_STAYROOT)) | ||
101 | +USE_TASKSET(NEWTOY(taskset, "<1^pa", TOYFLAG_USR|TOYFLAG_BIN|TOYFLAG_STAYROOT)) | ||
102 | USE_NPROC(NEWTOY(nproc, "(all)", TOYFLAG_USR|TOYFLAG_BIN)) | ||
103 | |||
104 | config NPROC | ||
105 | diff --git a/toys/other/timeout.c b/toys/other/timeout.c | ||
106 | index 9b93466..e1d0f4d 100644 | ||
107 | --- a/toys/other/timeout.c | ||
108 | +++ b/toys/other/timeout.c | ||
109 | @@ -4,7 +4,7 @@ | ||
110 | * | ||
111 | * No standard | ||
112 | |||
113 | -USE_TIMEOUT(NEWTOY(timeout, "<2^vk:s: ", TOYFLAG_BIN)) | ||
114 | +USE_TIMEOUT(NEWTOY(timeout, "<2^vk:s: ", TOYFLAG_USR|TOYFLAG_BIN)) | ||
115 | |||
116 | config TIMEOUT | ||
117 | bool "timeout" | ||
118 | diff --git a/toys/other/truncate.c b/toys/other/truncate.c | ||
119 | index 142d3c7..40eb1e5 100644 | ||
120 | --- a/toys/other/truncate.c | ||
121 | +++ b/toys/other/truncate.c | ||
122 | @@ -2,7 +2,7 @@ | ||
123 | * | ||
124 | * Copyright 2011 Rob Landley <rob@landley.net> | ||
125 | |||
126 | -USE_TRUNCATE(NEWTOY(truncate, "<1s:|c", TOYFLAG_BIN)) | ||
127 | +USE_TRUNCATE(NEWTOY(truncate, "<1s:|c", TOYFLAG_USR|TOYFLAG_BIN)) | ||
128 | |||
129 | config TRUNCATE | ||
130 | bool "truncate" | ||
131 | diff --git a/toys/posix/nice.c b/toys/posix/nice.c | ||
132 | index 4b587ee..9f7b119 100644 | ||
133 | --- a/toys/posix/nice.c | ||
134 | +++ b/toys/posix/nice.c | ||
135 | @@ -4,7 +4,7 @@ | ||
136 | * | ||
137 | * See http://opengroup.org/onlinepubs/9699919799/utilities/nice.html | ||
138 | |||
139 | -USE_NICE(NEWTOY(nice, "^<1n#", TOYFLAG_USR|TOYFLAG_BIN)) | ||
140 | +USE_NICE(NEWTOY(nice, "^<1n#", TOYFLAG_BIN)) | ||
141 | |||
142 | config NICE | ||
143 | bool "nice" | ||
144 | diff --git a/toys/posix/nl.c b/toys/posix/nl.c | ||
145 | index 9b02bfa..41e1b89 100644 | ||
146 | --- a/toys/posix/nl.c | ||
147 | +++ b/toys/posix/nl.c | ||
148 | @@ -7,7 +7,7 @@ | ||
149 | * This implements a subset: only one logical page (-ip), no sections (-dfh). | ||
150 | * todo: -lv | ||
151 | |||
152 | -USE_NL(NEWTOY(nl, "v#<1=1l#b:n:s:w#<0=6E", TOYFLAG_BIN)) | ||
153 | +USE_NL(NEWTOY(nl, "v#<1=1l#b:n:s:w#<0=6E", TOYFLAG_USR|TOYFLAG_BIN)) | ||
154 | |||
155 | config NL | ||
156 | bool "nl" | ||
157 | diff --git a/toys/posix/paste.c b/toys/posix/paste.c | ||
158 | index ea04f02..8972f71 100644 | ||
159 | --- a/toys/posix/paste.c | ||
160 | +++ b/toys/posix/paste.c | ||
161 | @@ -6,7 +6,7 @@ | ||
162 | * | ||
163 | * Deviations from posix: the FILE argument isn't mandatory, none == '-' | ||
164 | |||
165 | -USE_PASTE(NEWTOY(paste, "d:s", TOYFLAG_BIN|TOYFLAG_LOCALE)) | ||
166 | +USE_PASTE(NEWTOY(paste, "d:s", TOYFLAG_USR|TOYFLAG_BIN|TOYFLAG_LOCALE)) | ||
167 | |||
168 | config PASTE | ||
169 | bool "paste" | ||
170 | diff --git a/toys/posix/ps.c b/toys/posix/ps.c | ||
171 | index aef2a7f..b559e09 100644 | ||
172 | --- a/toys/posix/ps.c | ||
173 | +++ b/toys/posix/ps.c | ||
174 | @@ -44,7 +44,7 @@ | ||
175 | * TODO: top: thread support and SMP | ||
176 | * TODO: pgrep -f only searches the amount of cmdline that fits in toybuf. | ||
177 | |||
178 | -USE_PS(NEWTOY(ps, "k(sort)*P(ppid)*aAdeflMno*O*p(pid)*s*t*Tu*U*g*G*wZ[!ol][+Ae][!oO]", TOYFLAG_USR|TOYFLAG_BIN|TOYFLAG_LOCALE)) | ||
179 | +USE_PS(NEWTOY(ps, "k(sort)*P(ppid)*aAdeflMno*O*p(pid)*s*t*Tu*U*g*G*wZ[!ol][+Ae][!oO]", TOYFLAG_BIN|TOYFLAG_LOCALE)) | ||
180 | // stayroot because iotop needs root to read other process' proc/$$/io | ||
181 | USE_TOP(NEWTOY(top, ">0m" "O*Hk*o*p*u*s#<1d#=3<1n#<1bq[!oO]", TOYFLAG_USR|TOYFLAG_BIN|TOYFLAG_LOCALE)) | ||
182 | USE_IOTOP(NEWTOY(iotop, ">0AaKO" "k*o*p*u*s#<1=7d#=3<1n#<1bq", TOYFLAG_USR|TOYFLAG_BIN|TOYFLAG_STAYROOT|TOYFLAG_LOCALE)) | ||
183 | diff --git a/toys/posix/sed.c b/toys/posix/sed.c | ||
184 | index cf7d15e..130ac08 100644 | ||
185 | --- a/toys/posix/sed.c | ||
186 | +++ b/toys/posix/sed.c | ||
187 | @@ -10,7 +10,7 @@ | ||
188 | * TODO: handle error return from emit(), error_msg/exit consistently | ||
189 | * What's the right thing to do for -i when write fails? Skip to next? | ||
190 | |||
191 | -USE_SED(NEWTOY(sed, "(help)(version)e*f*inEr[+Er]", TOYFLAG_USR|TOYFLAG_BIN|TOYFLAG_LOCALE|TOYFLAG_NOHELP)) | ||
192 | +USE_SED(NEWTOY(sed, "(help)(version)e*f*inEr[+Er]", TOYFLAG_BIN|TOYFLAG_LOCALE|TOYFLAG_NOHELP)) | ||
193 | |||
194 | config SED | ||
195 | bool "sed" | ||
diff --git a/meta-oe/recipes-core/toybox/toybox_0.7.5.bb b/meta-oe/recipes-core/toybox/toybox_0.7.5.bb index eaa548f89..7e8e7b2ea 100644 --- a/meta-oe/recipes-core/toybox/toybox_0.7.5.bb +++ b/meta-oe/recipes-core/toybox/toybox_0.7.5.bb | |||
@@ -5,7 +5,9 @@ DEPENDS = "attr virtual/crypt" | |||
5 | LICENSE = "BSD-0-Clause" | 5 | LICENSE = "BSD-0-Clause" |
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f0b8b3dd6431bcaa245da0a08bd0d511" | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f0b8b3dd6431bcaa245da0a08bd0d511" |
7 | 7 | ||
8 | SRC_URI = "http://www.landley.net/toybox/downloads/${BPN}-${PV}.tar.gz" | 8 | SRC_URI = "http://www.landley.net/toybox/downloads/${BPN}-${PV}.tar.gz \ |
9 | file://OE-path-changes.patch \ | ||
10 | " | ||
9 | SRC_URI[md5sum] = "a8bb502a1be941f06dd2644fff25f547" | 11 | SRC_URI[md5sum] = "a8bb502a1be941f06dd2644fff25f547" |
10 | SRC_URI[sha256sum] = "3ada450ac1eab1dfc352fee915ea6129b9a4349c1885f1394b61bd2d89a46c04" | 12 | SRC_URI[sha256sum] = "3ada450ac1eab1dfc352fee915ea6129b9a4349c1885f1394b61bd2d89a46c04" |
11 | 13 | ||