summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-09-25 16:34:24 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-09-25 16:34:24 +0200
commitfb0d50c16fafb6956a94c472b7c6a74a456e38b6 (patch)
tree68a28e7eb8836975a48e4e82ed6c66311aaefe1a /meta-oe/recipes-core/systemd
parentadc2571887279bc80c2c4739f68fe4f5675cdeeb (diff)
downloadmeta-openembedded-fb0d50c16fafb6956a94c472b7c6a74a456e38b6.tar.gz
systemd: bump to v36
2 of the 3 analyze patches have been applied upstream, delete them Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/systemd')
-rw-r--r--meta-oe/recipes-core/systemd/systemd/0001-analyze-always-draw-1s-marker-for-scale.patch42
-rw-r--r--meta-oe/recipes-core/systemd/systemd/0002-analyze-report-startup-time-in-plot-mode-as-well.patch38
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb6
3 files changed, 2 insertions, 84 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd/0001-analyze-always-draw-1s-marker-for-scale.patch b/meta-oe/recipes-core/systemd/systemd/0001-analyze-always-draw-1s-marker-for-scale.patch
deleted file mode 100644
index 6097893b1..000000000
--- a/meta-oe/recipes-core/systemd/systemd/0001-analyze-always-draw-1s-marker-for-scale.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From 0797320a7a8d6a8bd899a4149322486db7f5baa2 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Thu, 22 Sep 2011 11:27:13 +0200
4Subject: [PATCH 1/3] analyze: always draw 1s marker for scale
5
6In situations like this:
7
8root@omap4430-panda:~# systemd-analyze
9Startup finished in 1499ms (kernel) + 916ms (userspace) = 2416ms
10
11The svg plot will only have the 0s marker and no subsequent markers for scale. This patch forces the 1s marker to always be drawn.
12
13Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
14---
15 src/systemd-analyze | 4 ++--
16 1 files changed, 2 insertions(+), 2 deletions(-)
17
18diff --git a/src/systemd-analyze b/src/systemd-analyze
19index ae7dcfb..649d0e1 100755
20--- a/src/systemd-analyze
21+++ b/src/systemd-analyze
22@@ -147,7 +147,7 @@ elif sys.argv[1] == 'plot':
23 context.set_line_width(1)
24 context.set_source_rgb(0.7, 0.7, 0.7)
25
26- for x in range(0, (finish_time - start_time)/10000, 100):
27+ for x in range(0, max((finish_time - start_time)/10000,110), 100):
28 context.move_to(x, 0)
29 context.line_to(x, height-border*2)
30
31@@ -163,7 +163,7 @@ elif sys.argv[1] == 'plot':
32 banner = "Running on %s (%s %s) %s" % (os.uname()[1], os.uname()[2], os.uname()[3], os.uname()[4])
33 draw_text(context, 0, -15, banner, hcenter = 0, vcenter = 1)
34
35- for x in range(0, (finish_time - start_time)/10000, 100):
36+ for x in range(0, max((finish_time - start_time)/10000,110), 100):
37 draw_text(context, x, -5, "%lus" % (x/100), vcenter = 0, hcenter = 0)
38
39 y = 0
40--
411.6.6.1
42
diff --git a/meta-oe/recipes-core/systemd/systemd/0002-analyze-report-startup-time-in-plot-mode-as-well.patch b/meta-oe/recipes-core/systemd/systemd/0002-analyze-report-startup-time-in-plot-mode-as-well.patch
deleted file mode 100644
index 67b7b776d..000000000
--- a/meta-oe/recipes-core/systemd/systemd/0002-analyze-report-startup-time-in-plot-mode-as-well.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From 88b284f5c079536f5151c3f1dcfc0e692ef26da6 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Thu, 22 Sep 2011 14:55:17 +0200
4Subject: [PATCH 2/3] analyze: report startup time in plot mode as well
5
6It now prints something like "Startup finished in 1507ms (kernel) + 850ms (userspace) = 2357ms" below the legend.
7
8Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
9---
10 src/systemd-analyze | 12 ++++++++++++
11 1 files changed, 12 insertions(+), 0 deletions(-)
12
13diff --git a/src/systemd-analyze b/src/systemd-analyze
14index 649d0e1..d0db984 100755
15--- a/src/systemd-analyze
16+++ b/src/systemd-analyze
17@@ -221,6 +221,18 @@ elif sys.argv[1] == 'plot':
18
19 draw_text(context, 0, height-border*2, "Legend: Red = Activating; Pink = Active; Dark Pink = Deactivating", hcenter = 0, vcenter = -1)
20
21+ if initrd_time > 0:
22+ draw_text(context, 0, height-border*2 + bar_height, "Startup finished in %lums (kernel) + %lums (initrd) + %lums (userspace) = %lums" % ( \
23+ initrd_time/1000, \
24+ (start_time - initrd_time)/1000, \
25+ (finish_time - start_time)/1000, \
26+ finish_time/1000), hcenter = 0, vcenter = -1)
27+ else:
28+ draw_text(context, 0, height-border*2 + bar_height, "Startup finished in %lums (kernel) + %lums (userspace) = %lums" % ( \
29+ start_time/1000, \
30+ (finish_time - start_time)/1000, \
31+ finish_time/1000), hcenter = 0, vcenter = -1)
32+
33 surface.finish()
34 elif sys.argv[1] in ("help", "--help", "-h"):
35 help()
36--
371.6.6.1
38
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index fd20a687f..b895f0d98 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -14,15 +14,13 @@ inherit gitpkgv
14PKGV = "v${GITPKGVTAG}" 14PKGV = "v${GITPKGVTAG}"
15 15
16PV = "git" 16PV = "git"
17PR = "r3" 17PR = "r0"
18 18
19inherit autotools vala perlnative 19inherit autotools vala perlnative
20 20
21SRCREV = "a2f5666d06fe8233025738047115bb9e3959df3e" 21SRCREV = "7c83341a593160e2b4739bdb8a1ad76b21bbdf9e"
22 22
23SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \ 23SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \
24 file://0001-analyze-always-draw-1s-marker-for-scale.patch \
25 file://0002-analyze-report-startup-time-in-plot-mode-as-well.patch \
26 file://0003-analyze-draw-kernel-boot-time-as-well.patch \ 24 file://0003-analyze-draw-kernel-boot-time-as-well.patch \
27 ${UCLIBCPATCHES} \ 25 ${UCLIBCPATCHES} \
28 " 26 "