summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-03-22 19:59:38 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-03-23 07:55:13 +0100
commitc43b2b36bc2f7795f12e8a537e24c65e3c5d4180 (patch)
treed3dc0ff65a98c55365a4e560a4e8f2216868a049 /meta-oe/recipes-core/systemd
parent0658069375e9dfe8c6b5e93b578ca56efaad6512 (diff)
downloadmeta-openembedded-c43b2b36bc2f7795f12e8a537e24c65e3c5d4180.tar.gz
systemd_git: replace ${base_libdir}/systemd by ${systemd_unitdir} set in oe-core
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/systemd')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index a32029911..e3aec317c 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -56,10 +56,10 @@ do_configure_prepend() {
56do_install() { 56do_install() {
57 autotools_do_install 57 autotools_do_install
58 # provided by a seperate recipe 58 # provided by a seperate recipe
59 rm ${D}${base_libdir}/systemd/system/serial-getty* -f 59 rm ${D}${systemd_unitdir}/system/serial-getty* -f
60 60
61 # provide support for initramfs 61 # provide support for initramfs
62 ln -s ${base_libdir}/systemd/systemd ${D}/init 62 ln -s ${systemd_unitdir}/systemd ${D}/init
63 63
64 # create dir for journal 64 # create dir for journal
65 install -d ${D}${localstatedir}/log/journal 65 install -d ${D}${localstatedir}/log/journal
@@ -84,9 +84,9 @@ RDEPENDS_${PN}-initramfs = "${PN}"
84 84
85FILES_${PN}-gui = "${bindir}/systemadm" 85FILES_${PN}-gui = "${bindir}/systemadm"
86 86
87FILES_${PN}-vconsole-setup = "${base_libdir}/systemd/systemd-vconsole-setup \ 87FILES_${PN}-vconsole-setup = "${systemd_unitdir}/systemd-vconsole-setup \
88 ${base_libdir}/systemd/system/systemd-vconsole-setup.service \ 88 ${systemd_unitdir}/system/systemd-vconsole-setup.service \
89 ${base_libdir}/systemd/system/sysinit.target.wants/systemd-vconsole-setup.service" 89 ${systemd_unitdir}/system/sysinit.target.wants/systemd-vconsole-setup.service"
90 90
91RRECOMMENDS_$PN}-vconsole-setup = "kbd kbd-consolefonts" 91RRECOMMENDS_$PN}-vconsole-setup = "kbd kbd-consolefonts"
92 92
@@ -96,8 +96,8 @@ FILES_${PN} = " ${base_bindir}/* \
96 ${datadir}/polkit-1 \ 96 ${datadir}/polkit-1 \
97 ${datadir}/${PN} \ 97 ${datadir}/${PN} \
98 ${sysconfdir} \ 98 ${sysconfdir} \
99 ${base_libdir}/systemd/* \ 99 ${systemd_unitdir}/* \
100 ${base_libdir}/systemd/system/* \ 100 ${systemd_unitdir}/system/* \
101 ${base_libdir}/udev/rules.d \ 101 ${base_libdir}/udev/rules.d \
102 ${base_libdir}/security/*.so \ 102 ${base_libdir}/security/*.so \
103 /cgroup \ 103 /cgroup \
@@ -111,7 +111,7 @@ FILES_${PN} = " ${base_bindir}/* \
111 ${libexecdir} \ 111 ${libexecdir} \
112 " 112 "
113 113
114FILES_${PN}-dbg += "${base_libdir}/systemd/.debug ${base_libdir}/systemd/*/.debug ${base_libdir}/security/.debug/" 114FILES_${PN}-dbg += "${systemd_unitdir}/.debug ${systemd_unitdir}/*/.debug ${base_libdir}/security/.debug/"
115FILES_${PN}-dev += "${base_libdir}/security/*.la ${datadir}/dbus-1/interfaces/" 115FILES_${PN}-dev += "${base_libdir}/security/*.la ${datadir}/dbus-1/interfaces/"
116 116
117RDEPENDS_${PN} += "dbus-systemd udev-systemd" 117RDEPENDS_${PN} += "dbus-systemd udev-systemd"
@@ -135,7 +135,7 @@ RRECOMMENDS_${PN} += "systemd-serialgetty \
135# u-a for runlevel and telinit 135# u-a for runlevel and telinit
136 136
137pkg_postinst_systemd () { 137pkg_postinst_systemd () {
138update-alternatives --install ${base_sbindir}/init init ${base_libdir}/systemd/systemd 300 138update-alternatives --install ${base_sbindir}/init init ${systemd_unitdir}/systemd 300
139update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300 139update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300
140update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300 140update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300
141update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300 141update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300
@@ -143,7 +143,7 @@ update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/s
143} 143}
144 144
145pkg_prerm_systemd () { 145pkg_prerm_systemd () {
146update-alternatives --remove init ${base_libdir}/systemd/systemd 146update-alternatives --remove init ${systemd_unitdir}/systemd
147update-alternatives --remove halt ${base_bindir}/systemctl 147update-alternatives --remove halt ${base_bindir}/systemctl
148update-alternatives --remove reboot ${base_bindir}/systemctl 148update-alternatives --remove reboot ${base_bindir}/systemctl
149update-alternatives --remove shutdown ${base_bindir}/systemctl 149update-alternatives --remove shutdown ${base_bindir}/systemctl