summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-03-22 19:59:36 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-03-23 07:55:12 +0100
commit815124f28e80b00230f820d663966af3423e210b (patch)
treef8694e35e8a13a5a1e2a2876635fc2f4450f824c /meta-oe/recipes-core/systemd
parented8bbbc690948ae772e576dca0714f2472394a93 (diff)
downloadmeta-openembedded-815124f28e80b00230f820d663966af3423e210b.tar.gz
systemd-compat-units: replace ${base_libdir}/systemd by ${systemd_unitdir} set in oe-core
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/systemd')
-rw-r--r--meta-oe/recipes-core/systemd/systemd-compat-units.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd-compat-units.bb b/meta-oe/recipes-core/systemd/systemd-compat-units.bb
index 2cbce67d6..c9a6b679e 100644
--- a/meta-oe/recipes-core/systemd/systemd-compat-units.bb
+++ b/meta-oe/recipes-core/systemd/systemd-compat-units.bb
@@ -10,15 +10,15 @@ inherit allarch
10SRC_URI = "file://*.service" 10SRC_URI = "file://*.service"
11 11
12do_install() { 12do_install() {
13 install -d ${D}${base_libdir}/systemd/system/basic.target.wants 13 install -d ${D}${systemd_unitdir}/system/basic.target.wants
14 install -d ${D}${base_libdir}/systemd/system/sysinit.target.wants/ 14 install -d ${D}${systemd_unitdir}/system/sysinit.target.wants/
15 install -m 0644 ${WORKDIR}/run-postinsts.service ${D}${base_libdir}/systemd/system 15 install -m 0644 ${WORKDIR}/run-postinsts.service ${D}${systemd_unitdir}/system
16 ln -sf ../run-postinsts.service ${D}${base_libdir}/systemd/system/basic.target.wants/ 16 ln -sf ../run-postinsts.service ${D}${systemd_unitdir}/system/basic.target.wants/
17 ln -sf ../run-postinsts.service ${D}${base_libdir}/systemd/system/sysinit.target.wants/ 17 ln -sf ../run-postinsts.service ${D}${systemd_unitdir}/system/sysinit.target.wants/
18 18
19 install -m 0644 ${WORKDIR}/machineid.service ${D}${base_libdir}/systemd/system 19 install -m 0644 ${WORKDIR}/machineid.service ${D}${systemd_unitdir}/system
20 ln -sf ../machineid.service ${D}${base_libdir}/systemd/system/sysinit.target.wants/ 20 ln -sf ../machineid.service ${D}${systemd_unitdir}/system/sysinit.target.wants/
21 ln -sf ../machineid.service ${D}${base_libdir}/systemd/system/basic.target.wants/ 21 ln -sf ../machineid.service ${D}${systemd_unitdir}/system/basic.target.wants/
22 22
23 # hack to make old style sysvinit postinsts succeed 23 # hack to make old style sysvinit postinsts succeed
24 install -d ${D}${bindir} 24 install -d ${D}${bindir}
@@ -33,12 +33,12 @@ echo -n "Disabling the following sysv scripts: "
33 33
34for i in busybox-udhcpc dnsmasq hwclock.sh networking syslog syslog.busybox ; do 34for i in busybox-udhcpc dnsmasq hwclock.sh networking syslog syslog.busybox ; do
35 if [ -e $i ] ; then 35 if [ -e $i ] ; then
36 echo -n "$i " ; ln -s /dev/null $D${base_libdir}/systemd/system/$i.service 36 echo -n "$i " ; ln -s /dev/null $D${systemd_unitdir}/system/$i.service
37 fi 37 fi
38done ; echo 38done ; echo
39} 39}
40 40
41FILES_${PN} = "${base_libdir}/systemd/system ${bindir}" 41FILES_${PN} = "${systemd_unitdir}/system ${bindir}"
42RDPEPENDS_${PN} = "systemd" 42RDPEPENDS_${PN} = "systemd"
43 43
44 44