summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-05-28 14:30:45 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-05-28 16:42:55 +0200
commit73ee0542d93ed095233f909184b79e0c7184a38a (patch)
treec2764cf4bef08a9870879ec86de044632629bf14 /meta-oe/recipes-core/systemd
parent086a042fb75d79902c84d81dc1e3caa5dd995c16 (diff)
downloadmeta-openembedded-73ee0542d93ed095233f909184b79e0c7184a38a.tar.gz
systemd: add u-a entries for reboot, halt and friends
Also drag in full modprobe. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/systemd')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb25
1 files changed, 18 insertions, 7 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index 9f92f8ace..d1f4cbed9 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -15,7 +15,7 @@ inherit gitpkgv
15PKGV = "v${GITPKGVTAG}" 15PKGV = "v${GITPKGVTAG}"
16 16
17PV = "git" 17PV = "git"
18PR = "r1" 18PR = "r2"
19 19
20inherit autotools vala update-alternatives 20inherit autotools vala update-alternatives
21 21
@@ -88,13 +88,24 @@ FILES_${PN}-dbg += "${base_libdir}/systemd/.debug ${base_libdir}/systemd/*/.debu
88RDEPENDS_${PN} += "dbus-systemd udev-systemd" 88RDEPENDS_${PN} += "dbus-systemd udev-systemd"
89 89
90# kbd -> loadkeys,setfont 90# kbd -> loadkeys,setfont
91RRECOMMENDS_${PN} += "kbd kbd-consolefonts ${PN}-serialgetty" 91# systemd calls 'modprobe -sab --', which busybox doesn't support due to lack
92# of blacklist support, so use proper modprobe from module-init-tools
93RRECOMMENDS_${PN} += "kbd kbd-consolefonts ${PN}-serialgetty module-init-tools"
94
95# TODO:
96# u-a for runlevel and telinit
92 97
93pkg_postinst_${PN} () { 98pkg_postinst_${PN} () {
94 # can't do this offline 99# can't do this offline
95 if [ "x$D" != "x" ]; then 100if [ "x$D" != "x" ]; then
96 exit 1 101 exit 1
97 fi 102fi
98 grep "^lock:" /etc/group > /dev/null || addgroup lock 103grep "^lock:" /etc/group > /dev/null || addgroup lock
104
105update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300
106update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300
107update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300
108update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/systemctl 300
109
99} 110}
100 111