summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/libxml
diff options
context:
space:
mode:
authorNick Lewis <nick.lewis@usa.g4s.com>2014-01-06 17:16:03 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-11 14:58:49 +0100
commitfef89c60f381d52ddcbcf557b4082ed46233906c (patch)
treeb66fe7618234a4ae30963e82401c56b7cd1380c5 /meta-oe/recipes-core/libxml
parent94de3cef65e9fca0838d95ab8d32153ba7bcc4ed (diff)
downloadmeta-openembedded-fef89c60f381d52ddcbcf557b4082ed46233906c.tar.gz
libxml++: Upgrade to 2.37.1 and add ptest support
Signed-off-by: Nick Lewis <nick.lewis@usa.g4s.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core/libxml')
-rw-r--r--meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch73
-rw-r--r--meta-oe/recipes-core/libxml/libxml++-2.37.1/run-ptest3
-rw-r--r--meta-oe/recipes-core/libxml/libxml++_2.37.1.bb (renamed from meta-oe/recipes-core/libxml/libxml++_2.35.3.bb)20
3 files changed, 89 insertions, 7 deletions
diff --git a/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch b/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch
new file mode 100644
index 000000000..a18822f72
--- /dev/null
+++ b/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch
@@ -0,0 +1,73 @@
1diff --git a/Makefile.am b/Makefile.am
2index d4aadb1..0e36756 100644
3--- a/Makefile.am
4+++ b/Makefile.am
5@@ -253,5 +253,8 @@ post-html: docs/index.html
6 rsync $(rsync_args) -r docs/index.html $$USER,libxmlplusplus@web.sourceforge.net:$(web_path_project)
7 rsync $(rsync_args) -r examples $$USER,libxmlplusplus@web.sourceforge.net:$(web_path_project)
8
9+install-ptest:
10+ make -C examples install-ptest
11+
12 # Optional: auto-generate the ChangeLog file from the git log on make dist
13 include $(top_srcdir)/macros/dist-changelog.am
14diff --git a/examples/Makefile.am b/examples/Makefile.am
15index d9541ca..c28b49c 100644
16--- a/examples/Makefile.am
17+++ b/examples/Makefile.am
18@@ -36,6 +36,23 @@ check_PROGRAMS = \
19 schemavalidation/schemavalidation \
20 textreader/textreader
21
22+check_DOTLIBS = \
23+ dom_build/.libs/dom_build \
24+ dom_parse_entities/.libs/dom_parse_entities \
25+ dom_parser/.libs/dom_parser \
26+ dom_parser_raw/.libs/dom_parser_raw \
27+ dom_read_write/.libs/dom_read_write \
28+ dom_xinclude/.libs/dom_xinclude \
29+ dom_xpath/.libs/dom_xpath \
30+ dtdvalidation/.libs/dtdvalidation \
31+ import_node/.libs/import_node \
32+ sax_exception/.libs/sax_exception \
33+ sax_parser/.libs/sax_parser \
34+ sax_parser_build_dom/.libs/sax_parser_build_dom \
35+ sax_parser_entities/.libs/sax_parser_entities \
36+ schemavalidation/.libs/schemavalidation \
37+ textreader/.libs/textreader
38+
39 # Shell scripts that call the example programs.
40 check_SCRIPTS = \
41 dom_build/make_check.sh \
42@@ -147,10 +164,10 @@ dist_noinst_DATA = \
43 # file are located in different directories.
44 dom_read_write/make_check.sh: Makefile
45 echo '# Generated and used by "make check"' >$@
46- echo 'dom_read_write/dom_read_write "$(srcdir)/dom_read_write/example.xml" dom_read_write/example_output.xml >/dev/null' >>$@
47+ echo 'dom_read_write/.libs/dom_read_write "$(srcdir)/dom_read_write/example.xml" dom_read_write/example_output.xml >/dev/null' >>$@
48 chmod +x $@
49
50-script_template = cd "$(srcdir)/<!progname!>" && "$(abs_builddir)/<!progname!>/<!progname!>" >/dev/null
51+script_template = cd "$(srcdir)/<!progname!>" && ".libs/<!progname!>" >/dev/null
52 standard_scripts = $(filter-out dom_read_write/make_check.sh,$(check_SCRIPTS))
53
54 # All other script files are generated like so:
55@@ -162,3 +179,18 @@ $(standard_scripts): Makefile
56 CLEANFILES = \
57 dom_read_write/example_output.xml \
58 $(check_SCRIPTS)
59+
60+buildtest: all
61+ $(MAKE) $(AM_MAKEFLAGS) $(check_PROGRAMS) $(check_SCRIPTS)
62+ $(MAKE) $(AM_MAKEFLAGS) buildtest-TESTS
63+
64+install-ptest:
65+ $(MKDIR_P) $(DESTDIR)/examples
66+ cp --parents $(check_DOTLIBS) $(DESTDIR)/examples
67+ cp --parents $(check_SCRIPTS) $(DESTDIR)/examples
68+ cp --parents $(dist_noinst_DATA) $(DESTDIR)/examples
69+ cp Makefile $(DESTDIR)/examples
70+ $(MKDIR_P) $(DESTDIR)/macros
71+ cp ../macros/test-driver $(DESTDIR)/macros
72+ sed -i -e 's|^Makefile:|_Makefile:|' $(DESTDIR)/examples/Makefile
73+
diff --git a/meta-oe/recipes-core/libxml/libxml++-2.37.1/run-ptest b/meta-oe/recipes-core/libxml/libxml++-2.37.1/run-ptest
new file mode 100644
index 000000000..236f66753
--- /dev/null
+++ b/meta-oe/recipes-core/libxml/libxml++-2.37.1/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2cd examples
3make -k check-TESTS
diff --git a/meta-oe/recipes-core/libxml/libxml++_2.35.3.bb b/meta-oe/recipes-core/libxml/libxml++_2.37.1.bb
index fb9cdd954..0ed8ee399 100644
--- a/meta-oe/recipes-core/libxml/libxml++_2.35.3.bb
+++ b/meta-oe/recipes-core/libxml/libxml++_2.37.1.bb
@@ -6,17 +6,23 @@ SECTION = "libs"
6LICENSE = "GPLv2" 6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 " 7LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 "
8 8
9PR = "r1"
10
11SHRT_VER = "${@d.getVar('PV',True).split('.')[0]}.${@d.getVar('PV',True).split('.')[1]}" 9SHRT_VER = "${@d.getVar('PV',True).split('.')[0]}.${@d.getVar('PV',True).split('.')[1]}"
12SRC_URI = "${GNOME_MIRROR}/${BPN}/${SHRT_VER}/${BP}.tar.xz" 10SRC_URI = "${GNOME_MIRROR}/${BPN}/${SHRT_VER}/${BP}.tar.xz \
13 11 file://libxml++_ptest.patch \
14SRC_URI[md5sum] = "196a2dcdc84ab987fe3852b3f29cafd7" 12 file://run-ptest \
15SRC_URI[sha256sum] = "715a4214bbff90365cc8406a28e427febd90461006d608fbdcdcea7fc9891eaf" 13"
14SRC_URI[md5sum] = "2f9372a6eba6e40206c11f558a8fbc32"
15SRC_URI[sha256sum] = "f3b183600532a92af355719210223f858857092b8b1531c7907155c59a6db39f"
16 16
17DEPENDS = "libxml2 glibmm" 17DEPENDS = "libxml2 glibmm"
18 18
19inherit autotools pkgconfig 19inherit autotools pkgconfig ptest
20
21do_compile_ptest() {
22 oe_runmake -C examples buildtest
23}
20 24
21FILES_${PN}-doc += "${datadir}/devhelp" 25FILES_${PN}-doc += "${datadir}/devhelp"
22FILES_${PN}-dev += "${libdir}/libxml++-2.6/include/libxml++config.h" 26FILES_${PN}-dev += "${libdir}/libxml++-2.6/include/libxml++config.h"
27
28RDEPENDS_${PN}-ptest += "make"