diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-28 13:49:59 +0000 |
---|---|---|
committer | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-28 14:32:06 +0000 |
commit | 3a30c562385cb3d9cd1b3043f6fe677a22024018 (patch) | |
tree | 66dc67f338ba316c25ca672950ef334e9e357386 /meta-oe/recipes-core/fakeroot | |
parent | d66c9a8b625f7b19f7b17e728dc82413399c2e19 (diff) | |
download | meta-openembedded-3a30c562385cb3d9cd1b3043f6fe677a22024018.tar.gz |
Replace bb.data.* with d.*
Used sed expression given here:
http://lists.linuxtogo.org/pipermail/openembedded-core/2011-November/012373.html
Plus an additional expression for .expand. Full expression is:
sed \
-e 's:bb.data.\(setVar([^,]*,[^,]*\), \([^ )]*\) *):\2.\1):g' \
-e 's:bb.data.\(setVarFlag([^,]*,[^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(expand([^,]*\), \([^ )]*\) *):\2.\1):g' \
-i `grep -ril bb.data *`
Some minor correction in systemd.bbclass was needed for some expressions
that didn't quite match the regex in the desired way; additionally a few
instances were manually changed.
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-core/fakeroot')
-rw-r--r-- | meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb b/meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb index 3bcebabf4..1e9f15a67 100644 --- a/meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb +++ b/meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb | |||
@@ -9,8 +9,8 @@ EXTRA_OECONF = "--program-prefix=" | |||
9 | 9 | ||
10 | # Compatability for the rare systems not using or having SYSV | 10 | # Compatability for the rare systems not using or having SYSV |
11 | python () { | 11 | python () { |
12 | if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0': | 12 | if d.getVar('HOST_NONSYSV', True) and d.getVar('HOST_NONSYSV', True) != '0': |
13 | bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d) | 13 | d.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ') |
14 | } | 14 | } |
15 | 15 | ||
16 | RDEPENDS_${PN} = "util-linux-native" | 16 | RDEPENDS_${PN} = "util-linux-native" |