diff options
author | Luca Boccassi <luca.boccassi@microsoft.com> | 2019-10-28 14:58:23 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-10-28 15:26:42 -0700 |
commit | 71af733347cf3aa2f22abbaded72ae1383c40375 (patch) | |
tree | 351ed1d390f0fdc20249e9a6dcb5dd17a68f19e7 /meta-oe/recipes-core/dbus | |
parent | 9ac1df048a8af359f55fb5c57b6e031353996617 (diff) | |
download | meta-openembedded-71af733347cf3aa2f22abbaded72ae1383c40375.tar.gz |
dbus-broker: add patch to fix build with musl libc
Forwarded upstream: https://github.com/bus1/dbus-broker/pull/214
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core/dbus')
-rw-r--r-- | meta-oe/recipes-core/dbus/dbus-broker/0004-launcher-fix-build-with-musl-libc.patch | 38 | ||||
-rw-r--r-- | meta-oe/recipes-core/dbus/dbus-broker_21.bb | 1 |
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/dbus/dbus-broker/0004-launcher-fix-build-with-musl-libc.patch b/meta-oe/recipes-core/dbus/dbus-broker/0004-launcher-fix-build-with-musl-libc.patch new file mode 100644 index 000000000..0348d9722 --- /dev/null +++ b/meta-oe/recipes-core/dbus/dbus-broker/0004-launcher-fix-build-with-musl-libc.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From fc1d26dd08c48c04fc9883b36a94c219aba2091c Mon Sep 17 00:00:00 2001 | ||
2 | From: Luca Boccassi <luca.boccassi@microsoft.com> | ||
3 | Date: Mon, 28 Oct 2019 14:31:38 +0000 | ||
4 | Subject: [PATCH] launcher: fix build with musl libc | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | ../src/launch/launcher.c: In function ‘launcher_fork’: | ||
10 | ../src/launch/launcher.c:378:60: error: ‘WEXITED’ undeclared (first use in this function); did you mean ‘WIFEXITED’? | ||
11 | r = sd_event_add_child(launcher->event, NULL, pid, WEXITED, launcher_on_child_exit, launcher); | ||
12 | ^~~~~~~ | ||
13 | WIFEXITED | ||
14 | |||
15 | Include sys/wait.h which defines it. | ||
16 | |||
17 | Signed-off-by: Luca Boccassi <luca.boccassi@microsoft.com> | ||
18 | Suggested-by: Khem Raj <raj.khem@gmail.com> | ||
19 | Upstream-Status: pending https://github.com/bus1/dbus-broker/pull/214 | ||
20 | --- | ||
21 | src/launch/launcher.c | 1 + | ||
22 | 1 file changed, 1 insertion(+) | ||
23 | |||
24 | diff --git a/src/launch/launcher.c b/src/launch/launcher.c | ||
25 | index 2ec4bda..1f38fcf 100644 | ||
26 | --- a/src/launch/launcher.c | ||
27 | +++ b/src/launch/launcher.c | ||
28 | @@ -10,6 +10,7 @@ | ||
29 | #include <stdlib.h> | ||
30 | #include <sys/prctl.h> | ||
31 | #include <sys/un.h> | ||
32 | +#include <sys/wait.h> | ||
33 | #include <systemd/sd-bus.h> | ||
34 | #include <systemd/sd-daemon.h> | ||
35 | #include <systemd/sd-event.h> | ||
36 | -- | ||
37 | 2.20.1 | ||
38 | |||
diff --git a/meta-oe/recipes-core/dbus/dbus-broker_21.bb b/meta-oe/recipes-core/dbus/dbus-broker_21.bb index c509ff6f2..d2d051070 100644 --- a/meta-oe/recipes-core/dbus/dbus-broker_21.bb +++ b/meta-oe/recipes-core/dbus/dbus-broker_21.bb | |||
@@ -10,6 +10,7 @@ SRC_URI = "https://github.com/bus1/dbus-broker/releases/download/v${PV}/dbus-bro | |||
10 | SRC_URI += " file://0001-launch-improve-error-handling-for-opendir.patch" | 10 | SRC_URI += " file://0001-launch-improve-error-handling-for-opendir.patch" |
11 | SRC_URI += " file://0002-metrics-change-the-constant-used-for-invalid-timesta.patch" | 11 | SRC_URI += " file://0002-metrics-change-the-constant-used-for-invalid-timesta.patch" |
12 | SRC_URI += " file://0003-dbus-socket-treat-MSG_CTRUNC-gracefully.patch" | 12 | SRC_URI += " file://0003-dbus-socket-treat-MSG_CTRUNC-gracefully.patch" |
13 | SRC_URI += " file://0004-launcher-fix-build-with-musl-libc.patch" | ||
13 | SRC_URI[md5sum] = "a17886a92ab1e0bc2e4b1a274339e388" | 14 | SRC_URI[md5sum] = "a17886a92ab1e0bc2e4b1a274339e388" |
14 | SRC_URI[sha256sum] = "6fff9a831a514659e2c7d704e76867ce31ebcf43e8d7a62e080c6656f64cd39e" | 15 | SRC_URI[sha256sum] = "6fff9a831a514659e2c7d704e76867ce31ebcf43e8d7a62e080c6656f64cd39e" |
15 | 16 | ||