summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-10-06 11:19:05 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-07 20:22:29 +0200
commitd7c12fd07498af06f4c03182c838528e765e4721 (patch)
tree8b5c098888908d9099be93d805499dcfcff5917b /meta-oe/recipes-connectivity
parent2f04e069cba8d2a9fc9e640e8ddccc5929abff11 (diff)
downloadmeta-openembedded-d7c12fd07498af06f4c03182c838528e765e4721.tar.gz
openssl: Fix build with gold linker
There was a missing version script for one of the apps that was being flagged by gold. So we add appropriate openssl.ld for engines/ccgost Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Roman Khimov <khimov@altell.ru> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/openssl/openssl-1.0.0e/debian/version-script.patch34
-rw-r--r--meta-oe/recipes-connectivity/openssl/openssl_1.0.0e.bb2
2 files changed, 27 insertions, 9 deletions
diff --git a/meta-oe/recipes-connectivity/openssl/openssl-1.0.0e/debian/version-script.patch b/meta-oe/recipes-connectivity/openssl/openssl-1.0.0e/debian/version-script.patch
index 9d73f3161..6d73a4c8a 100644
--- a/meta-oe/recipes-connectivity/openssl/openssl-1.0.0e/debian/version-script.patch
+++ b/meta-oe/recipes-connectivity/openssl/openssl-1.0.0e/debian/version-script.patch
@@ -1,7 +1,7 @@
1Index: openssl-1.0.0c/Configure 1Index: openssl-1.0.0e/Configure
2=================================================================== 2===================================================================
3--- openssl-1.0.0c.orig/Configure 2011-08-12 23:02:54.436331036 -0700 3--- openssl-1.0.0e.orig/Configure 2011-10-04 22:49:47.599379260 -0700
4+++ openssl-1.0.0c/Configure 2011-08-12 23:03:39.626397324 -0700 4+++ openssl-1.0.0e/Configure 2011-10-04 22:49:53.263407376 -0700
5@@ -1486,6 +1486,8 @@ 5@@ -1486,6 +1486,8 @@
6 } 6 }
7 } 7 }
@@ -11,10 +11,10 @@ Index: openssl-1.0.0c/Configure
11 open(IN,'<Makefile.org') || die "unable to read Makefile.org:$!\n"; 11 open(IN,'<Makefile.org') || die "unable to read Makefile.org:$!\n";
12 unlink("$Makefile.new") || die "unable to remove old $Makefile.new:$!\n" if -e "$Makefile.new"; 12 unlink("$Makefile.new") || die "unable to remove old $Makefile.new:$!\n" if -e "$Makefile.new";
13 open(OUT,">$Makefile.new") || die "unable to create $Makefile.new:$!\n"; 13 open(OUT,">$Makefile.new") || die "unable to create $Makefile.new:$!\n";
14Index: openssl-1.0.0c/openssl.ld 14Index: openssl-1.0.0e/openssl.ld
15=================================================================== 15===================================================================
16--- /dev/null 1970-01-01 00:00:00.000000000 +0000 16--- /dev/null 1970-01-01 00:00:00.000000000 +0000
17+++ openssl-1.0.0c/openssl.ld 2011-08-12 23:03:39.626397324 -0700 17+++ openssl-1.0.0e/openssl.ld 2011-10-04 22:49:53.295407572 -0700
18@@ -0,0 +1,4461 @@ 18@@ -0,0 +1,4461 @@
19+OPENSSL_1.0.0 { 19+OPENSSL_1.0.0 {
20+ global: 20+ global:
@@ -4477,14 +4477,32 @@ Index: openssl-1.0.0c/openssl.ld
4477+ *; 4477+ *;
4478+}; 4478+};
4479+ 4479+
4480Index: openssl-1.0.0c/engines/openssl.ld 4480Index: openssl-1.0.0e/engines/openssl.ld
4481=================================================================== 4481===================================================================
4482--- /dev/null 1970-01-01 00:00:00.000000000 +0000 4482--- /dev/null 1970-01-01 00:00:00.000000000 +0000
4483+++ openssl-1.0.0c/engines/openssl.ld 2011-08-12 23:03:39.626397324 -0700 4483+++ openssl-1.0.0e/engines/openssl.ld 2011-10-04 22:49:53.295407572 -0700
4484@@ -0,0 +1,7 @@ 4484@@ -0,0 +1,10 @@
4485+OPENSSL_1.0.0 { 4485+OPENSSL_1.0.0 {
4486+ global: 4486+ global:
4487+ bind_engine; 4487+ bind_engine;
4488+ v_check;
4489+ OPENSSL_init;
4490+ OPENSSL_finish;
4491+ local:
4492+ *;
4493+};
4494+
4495Index: openssl-1.0.0e/engines/ccgost/openssl.ld
4496===================================================================
4497--- /dev/null 1970-01-01 00:00:00.000000000 +0000
4498+++ openssl-1.0.0e/engines/ccgost/openssl.ld 2011-10-04 22:49:53.339407745 -0700
4499@@ -0,0 +1,10 @@
4500+OPENSSL_1.0.0 {
4501+ global:
4502+ bind_engine;
4503+ v_check;
4504+ OPENSSL_init;
4505+ OPENSSL_finish;
4488+ local: 4506+ local:
4489+ *; 4507+ *;
4490+}; 4508+};
diff --git a/meta-oe/recipes-connectivity/openssl/openssl_1.0.0e.bb b/meta-oe/recipes-connectivity/openssl/openssl_1.0.0e.bb
index bc812d37a..8fcf0ff54 100644
--- a/meta-oe/recipes-connectivity/openssl/openssl_1.0.0e.bb
+++ b/meta-oe/recipes-connectivity/openssl/openssl_1.0.0e.bb
@@ -6,7 +6,7 @@ DEPENDS += "ocf-linux"
6 6
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS" 7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8 8
9PR = "${INC_PR}.2" 9PR = "${INC_PR}.3"
10 10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8" 11LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
12 12