summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-09 20:22:47 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-09 20:25:28 -0700
commit44c93d05579ac5c8f2c46f2a0f7c27703c2bb6c9 (patch)
tree4bca8e23e639edde47d76da55e6813eab20da699 /meta-oe/recipes-connectivity
parentb7b998c35e283d57d32c392399fecd11e1954f64 (diff)
downloadmeta-openembedded-44c93d05579ac5c8f2c46f2a0f7c27703c2bb6c9.tar.gz
libimobiledevice: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice/0001-include-unistd.h-for-usleep.patch31
-rw-r--r--meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_git.bb3
2 files changed, 33 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice/0001-include-unistd.h-for-usleep.patch b/meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice/0001-include-unistd.h-for-usleep.patch
new file mode 100644
index 000000000..424a203e5
--- /dev/null
+++ b/meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice/0001-include-unistd.h-for-usleep.patch
@@ -0,0 +1,31 @@
1From 6cb8069cfe08114f1dc7b50a7fcd4dc040cd1bbb Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 9 May 2023 20:19:23 -0700
4Subject: [PATCH] include unistd.h for usleep()
5
6clang16 flags the missing header
7
8Fixes
9../../git/tools/idevicedevmodectl.c:363:2: error: call to undeclared function 'usleep'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
10
11Upstream-Status: Submitted [https://github.com/libimobiledevice/libimobiledevice/pull/1444]
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 tools/idevicedevmodectl.c | 1 +
15 1 file changed, 1 insertion(+)
16
17diff --git a/tools/idevicedevmodectl.c b/tools/idevicedevmodectl.c
18index 739bc13..9fe8d6a 100644
19--- a/tools/idevicedevmodectl.c
20+++ b/tools/idevicedevmodectl.c
21@@ -34,6 +34,7 @@
22 #ifndef WIN32
23 #include <signal.h>
24 #endif
25+#include <unistd.h>
26
27 #ifdef WIN32
28 #include <windows.h>
29--
302.40.1
31
diff --git a/meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_git.bb b/meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_git.bb
index c17c7224f..1a0590c57 100644
--- a/meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_git.bb
+++ b/meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_git.bb
@@ -11,7 +11,8 @@ DEPENDS = "libplist usbmuxd libusbmuxd libtasn1 gnutls libgcrypt libimobiledevic
11PV = "1.3.0+git${SRCPV}" 11PV = "1.3.0+git${SRCPV}"
12 12
13SRCREV = "860ffb707af3af94467d2ece4ad258dda957c6cd" 13SRCREV = "860ffb707af3af94467d2ece4ad258dda957c6cd"
14SRC_URI = "git://github.com/libimobiledevice/libimobiledevice;protocol=https;branch=master" 14SRC_URI = "git://github.com/libimobiledevice/libimobiledevice;protocol=https;branch=master \
15 file://0001-include-unistd.h-for-usleep.patch"
15 16
16S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
17inherit autotools pkgconfig 18inherit autotools pkgconfig