summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorMartin Hundebøll <martin@geanix.com>2018-11-21 09:10:12 +0100
committerKhem Raj <raj.khem@gmail.com>2018-11-26 09:38:14 -0800
commit96498af78eee70f80e6377f86fa0a345fc99641d (patch)
treeb42be6557e907fd80866e561e0d26f4c93d982b7 /meta-oe/recipes-connectivity
parent4867a94b9a92fed3184dedec66d6c42f21d274f1 (diff)
downloadmeta-openembedded-96498af78eee70f80e6377f86fa0a345fc99641d.tar.gz
iwd: add version 0.12
The iwd wireless daemon is an alternative to wpa_supplicant. It is controlled using the iwctl command line client (or the dbus interface). Signed-off-by: Martin Hundebøll <martin@geanix.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd_0.12.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_0.12.bb b/meta-oe/recipes-connectivity/iwd/iwd_0.12.bb
new file mode 100644
index 000000000..a4261547e
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iwd/iwd_0.12.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Wireless daemon for Linux"
2LICENSE = "LGPL-2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
4
5inherit autotools pkgconfig systemd
6
7DEPENDS = "ell readline dbus"
8
9SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git"
10SRCREV = "d7609915db4b57229f7dd4c04b4eabcce637872a"
11S = "${WORKDIR}/git"
12
13SYSTEMD_SERVICE_${PN} = "iwd.service"
14
15PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
16PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd"
17
18EXTRA_OECONF += "--enable-external-ell"
19
20do_configure_prepend () {
21 mkdir -p ${S}/build-aux
22}
23
24FILES_${PN} += "${datadir}/dbus-1"