diff options
author | Eric BENARD <eric@eukrea.com> | 2012-11-26 18:10:15 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-11-27 12:45:56 +0100 |
commit | e919d827151e840d95fea189d8b56d046672510c (patch) | |
tree | 6c557ecee109e3a17a6d76571073effd24a6ac20 /meta-oe/recipes-connectivity | |
parent | 681ef5d05325c663ae0a223240e46740b08a8946 (diff) | |
download | meta-openembedded-e919d827151e840d95fea189d8b56d046672510c.tar.gz |
gammu: import from OE-classic and upgrade to 1.32.0
- provide default configuration files for both gammu and
gammu-smsd
- enable MySQL support
- enable libdbi support
Signed-off-by: Eric BĂ©nard <eric@eukrea.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r-- | meta-oe/recipes-connectivity/gammu/gammu/gammu-smsdrc | 80 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/gammu/gammu/gammurc | 173 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb | 55 |
3 files changed, 308 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/gammu/gammu/gammu-smsdrc b/meta-oe/recipes-connectivity/gammu/gammu/gammu-smsdrc new file mode 100644 index 000000000..da413c2d3 --- /dev/null +++ b/meta-oe/recipes-connectivity/gammu/gammu/gammu-smsdrc | |||
@@ -0,0 +1,80 @@ | |||
1 | # This is a sample Gammu SMSD configuration file. It's required for gammu-smsd, | ||
2 | # see gammu-smsdrc(5) for documentation. | ||
3 | |||
4 | # Gammu configuration, this section is like section "gammu" in "gammurc" file, | ||
5 | # see gammurc(5) for documentation. | ||
6 | [gammu] | ||
7 | device = /dev/ttyUSB0 | ||
8 | model = at115200 | ||
9 | #connection = dlr3 | ||
10 | #synchronizetime = yes | ||
11 | #logfile = gammulog # this is not used at all in SMSD mode | ||
12 | #logformat = textall | ||
13 | #use_locking = yes | ||
14 | #gammuloc = gammu.us | ||
15 | #startinfo = yes | ||
16 | |||
17 | # When uncomment this section and insert numbers here, smsd will process | ||
18 | # incoming sms only from numbers written here (incoming sms from all other | ||
19 | # numbers will be deleted) | ||
20 | #[include_numbers] | ||
21 | #number1 = 1234 | ||
22 | |||
23 | # When uncomment this section and insert numbers here, smsd will process | ||
24 | # incoming sms from all numbers not written here (incoming sms from numbers | ||
25 | # written here will be deleted). This is "black" list. | ||
26 | # Note: after using "include_numbers" section this one will be ignored | ||
27 | #[exclude_numbers] | ||
28 | #number1 = 1234 | ||
29 | |||
30 | # General SMSD settings, see gammu-smsdrc(5) for detailed description. | ||
31 | [smsd] | ||
32 | # SMSD service to use, one of FILES, MYSQL, PGSQL, DBI | ||
33 | service = files | ||
34 | # PIN for SIM card | ||
35 | PIN = 0000 | ||
36 | # File (or stderr, syslog, eventlog) where information will be logged | ||
37 | logfile = smsdlog | ||
38 | # Amount of information being logged, each bit mean one level | ||
39 | debuglevel = 0 | ||
40 | # Configuration for using more phones on same database | ||
41 | #phoneid = MyPhone1 | ||
42 | # Script to be executed when new message has been received | ||
43 | #runonreceive = /some/script | ||
44 | # Commication frequency settings | ||
45 | commtimeout = 30 | ||
46 | sendtimeout = 30 | ||
47 | #receivefrequency = 0 | ||
48 | |||
49 | # Phone communication settings | ||
50 | #checksecurity = 1 | ||
51 | #resetfrequency = 0 | ||
52 | |||
53 | # Delivery report configuration | ||
54 | #deliveryreport = no | ||
55 | #deliveryreportdelay = 10 | ||
56 | |||
57 | # Ignoring broken SMSC | ||
58 | #skipsmscnumber = +48602123456 | ||
59 | |||
60 | # Database backends congfiguration | ||
61 | user = gammu | ||
62 | password = gammupassword | ||
63 | pc = localhost | ||
64 | # pc can also contain port or socket path after colon (eg. localhost:/path/to/socket) | ||
65 | database = sms | ||
66 | |||
67 | # DBI configuration | ||
68 | driver = sqlite | ||
69 | # driverspath = /usr/lib/dbd/ | ||
70 | # Database directory for sqlite | ||
71 | # dbdir = /var/lib/smsd | ||
72 | |||
73 | # Files backend configuration | ||
74 | inboxpath = /var/spool/sms/inbox/ | ||
75 | outboxpath = /var/spool/sms/outbox/ | ||
76 | sentsmspath = /var/spool/sms/sent/ | ||
77 | errorsmspath = /var/spool/sms/error/ | ||
78 | inboxformat = detail | ||
79 | transmitformat = auto | ||
80 | outboxformat = detail | ||
diff --git a/meta-oe/recipes-connectivity/gammu/gammu/gammurc b/meta-oe/recipes-connectivity/gammu/gammu/gammurc new file mode 100644 index 000000000..b55d739fa --- /dev/null +++ b/meta-oe/recipes-connectivity/gammu/gammu/gammurc | |||
@@ -0,0 +1,173 @@ | |||
1 | ; This is a sample ~/.gammurc file. | ||
2 | ; In Unix/Linux copy it into your home directory and name it .gammurc | ||
3 | ; or into /etc and name it gammurc | ||
4 | ; In Win32 copy it into directory with Gammu.exe and name gammurc | ||
5 | ; More about parameters later | ||
6 | ; Anything behind ; or # is comment. | ||
7 | ; ----------------------------------------------------------------------------- | ||
8 | |||
9 | [gammu] | ||
10 | |||
11 | device = /dev/ttyUSB0 | ||
12 | connection = at115200 | ||
13 | ; Do not use model configuration unless you really need it | ||
14 | ;model = 6110 | ||
15 | ;synchronizetime = yes | ||
16 | ;logfile = gammulog | ||
17 | ;logformat = textall | ||
18 | ;use_locking = yes | ||
19 | ;gammuloc = locfile | ||
20 | ;startinfo = yes | ||
21 | ;gammucoding = utf8 | ||
22 | ;usephonedb = yes | ||
23 | |||
24 | ;[gammu1] | ||
25 | |||
26 | ;device = com8: | ||
27 | ;model = 6110 | ||
28 | ;connection = fbusblue | ||
29 | ;synchronizetime = yes | ||
30 | ;logfile = gammulog | ||
31 | ;logformat = textall | ||
32 | ;use_locking = yes | ||
33 | ;gammuloc = locfile | ||
34 | ;startinfo = yes | ||
35 | ;gammucoding = utf8 | ||
36 | |||
37 | ; Step 1. Please find required Connection parameter and look into assigned | ||
38 | ; with it device type. With some Connection you must set concrete model | ||
39 | |||
40 | ; ================================================================ cables ===== | ||
41 | ; New Nokia protocol for FBUS/DAU9P | ||
42 | ; Connection "fbus", device type serial | ||
43 | ; New Nokia protocol for DLR3/DLR3P | ||
44 | ; Connection "fbusdlr3"/"dlr3", device type serial | ||
45 | ; New Nokia protocol for DKU2 (and phone with USB converter on phone mainboard | ||
46 | ; like 6230) | ||
47 | ; Connection "dku2phonet"/"dku2", device type dku2 on Windows | ||
48 | ; Connection "fbususb" on Linux | ||
49 | ; New Nokia protocol for DKU5 (and phone without USB converter on phone | ||
50 | ; mainboard like 5100) | ||
51 | ; Connection "dku5fbus"/"dku5", device type dku5 | ||
52 | ; New Nokia protocol for PL2303 USB cable (and phone without USB converter | ||
53 | ; on phone mainboard like 5100) | ||
54 | ; Connection "fbuspl2303", device type usb | ||
55 | ; Old Nokia protocol for MBUS/DAU9P | ||
56 | ; Connection "mbus", device type serial | ||
57 | ; Variants: | ||
58 | ; You can modify a bit behaviour of connection using additional flags | ||
59 | ; specified just after connection name like connection-variant. | ||
60 | ; If you're using ARK3116 cable (or any other which does not like dtr | ||
61 | ; handling), you might need -nodtr variant of connection, eg. dlr3-nodtr. | ||
62 | ; If cable you use is not powered over DTR/RTS, try using -nopower variant of | ||
63 | ; connection, eg. fbus-nopower. | ||
64 | ; ----------------------------------------------------------------------------- | ||
65 | ; AT commands for DLR3, DKU5 or other AT compatible cable (8 bits, None | ||
66 | ; parity, no flow control, 1 stop bit). Used with Nokia, Alcatel, Siemens, etc. | ||
67 | ; Connection "at19200"/"at115200"/.., device type serial | ||
68 | ; AT commands for DKU2 cable | ||
69 | ; Connection "dku2at", device type dku2 | ||
70 | ; ============================================================== infrared ===== | ||
71 | ; Nokia protocol for infrared with Nokia 6110/6130/6150 | ||
72 | ; Connection "fbusirda"/"infrared", device type serial | ||
73 | ; Nokia protocol for infrared with other Nokia models | ||
74 | ; Connection "irdaphonet"/"irda", device type irda | ||
75 | ; ----------------------------------------------------------------------------- | ||
76 | ; AT commands for infrared. Used with Nokia, Alcatel, Siemens, etc. | ||
77 | ; Connection "irdaat", device type irda | ||
78 | ; ----------------------------------------------------------------------------- | ||
79 | ; OBEX for infrared | ||
80 | ; Connection "irdaobex", device type irda. | ||
81 | ; ============================================================= Bluetooth ===== | ||
82 | ; Nokia protocol with serial device set in BT stack (WidComm, other) from | ||
83 | ; adequate service and Nokia 6210 | ||
84 | ; Connection "fbusblue", device type serial | ||
85 | ; Nokia protocol with serial device set in BT stack (WidComm, other) from | ||
86 | ; adequate service and other Nokia models | ||
87 | ; Connection "phonetblue", device type serial | ||
88 | ; ----------------------------------------------------------------------------- | ||
89 | ; Nokia protocol for Bluetooth stack with Nokia 6210 | ||
90 | ; Connection "bluerffbus", device type BT | ||
91 | ; Nokia protocol for Bluetooth stack with DCT4 Nokia models, which don't inform | ||
92 | ; about services correctly (6310, 6310i with firmware lower than 5.50, 8910,..) | ||
93 | ; Connection "bluerfphonet", device type BT | ||
94 | ; Nokia protocol for Bluetooth stack with other DCT4 Nokia models | ||
95 | ; Connection "bluephonet", device type BT | ||
96 | ; ----------------------------------------------------------------------------- | ||
97 | ; AT commands for Bluetooth stack and 6210 / DCT4 Nokia models, which don't | ||
98 | ; inform about BT services correctly (6310, 6310i with firmware lower | ||
99 | ; than 5.50, 8910,..) | ||
100 | ; Connection "bluerfat", device type BT | ||
101 | ; AT commands for Bluetooth stack with other phones (Siemens, other Nokia,etc.) | ||
102 | ; Connection "blueat", device type BT | ||
103 | ; ----------------------------------------------------------------------------- | ||
104 | ; OBEX for Bluetooth stack with DCT4 Nokia models, which don't inform about | ||
105 | ; BT services correctly (6310, 6310i with firmware lower than 5.50, 8910,...) | ||
106 | ; Connection "bluerfobex", device type BT | ||
107 | ; OBEX for Bluetooth stack with other phones (Siemens, other Nokia, etc.) | ||
108 | ; Connection "blueobex", device type BT. | ||
109 | ; ----------------------------------------------------------------------------- | ||
110 | ; Connection "bluerfgnapbus", device type BT, model "gnap" | ||
111 | ; Connection "irdagnapbus", device type irda, model "gnap" | ||
112 | |||
113 | ; Step2. According to device type from Step1 and used OS set Port parameter | ||
114 | |||
115 | ; ----------------------------------------------------------------------------- | ||
116 | ; Port type | "Port" parameter in Windows/DOS | "Port" parameter in Linux/Unix | ||
117 | ; ----------|---------------------------------|-------------------------------- | ||
118 | ; serial | "com*:" | "/dev/ttyS*" | ||
119 | ; | (example "com1:") | (example "/dev/ttyS1") | ||
120 | ; | | or "/dev/tts/**" (with DevFS) | ||
121 | ; | | virtual serial ports like | ||
122 | ; | | "/dev/ircomm*" or "/dev/rfcomm*" | ||
123 | ; ----------|---------------------------------|-------------------------------- | ||
124 | ; irda | ignored (can be empty) | ignored (can be empty) | ||
125 | ; ----------|---------------------------------|-------------------------------- | ||
126 | ; BT | Bluetooth device address (example "00:11:22:33:44:55"). | ||
127 | ; | Optionally you can also include channel after slash | ||
128 | ; | (example "00:11:22:33:44:55/12"). Can be also empty. | ||
129 | ; ----------|---------------------------------|-------------------------------- | ||
130 | ; dku2 | ignored (can be empty) | /dev/ttyUSB* or /dev/ttyACM* | ||
131 | ; ----------|---------------------------------|-------------------------------- | ||
132 | ; dku5 | ignored (can be empty) | connection with it not possible | ||
133 | ; ----------|---------------------------------|-------------------------------- | ||
134 | ; usb | connection with it not possible | "/dev/ttyUSB*" | ||
135 | |||
136 | ; Step3. Set other config parameters | ||
137 | |||
138 | ; ----------------------------------------------------------------------------- | ||
139 | ; Parameter name | Description | ||
140 | ; ----------------|------------------------------------------------------------ | ||
141 | ; Model | Should not be used unless you have a good reason to do so. | ||
142 | ; | If Gammu doesn't recognize your phone model, put it here. | ||
143 | ; | Example values: "6110", "6150", "6210", "8210" | ||
144 | ; SynchronizeTime | if you want to set time from computer to phone during | ||
145 | ; | starting connection. Do not rather use this option when | ||
146 | ; | when to reset phone during connection (in some phones need | ||
147 | ; | to set time again after restart) | ||
148 | ; GammuLoc | name of localisation file | ||
149 | ; StartInfo | this option allow to set, that you want (setting "yes") | ||
150 | ; | to see message on the phone screen or phone should enable | ||
151 | ; | light for a moment during starting connection. Phone | ||
152 | ; | WON'T beep during starting connection with this option. | ||
153 | ; GammuCoding | forces using specified codepage (in win32 - for example | ||
154 | ; | "1250" will force CP1250) or UTF8 (in Linux - "utf8") | ||
155 | ; ----------------|------------------------------------------------------------ | ||
156 | ; Logfile | Use, when want to have logfile from communication. | ||
157 | ; Logformat | What debug info and format should be used: | ||
158 | ; | "nothing" - no debug level (default) | ||
159 | ; | "text" - transmission dump in text format | ||
160 | ; | "textall" - all possible info in text format | ||
161 | ; | "errors" - errors in text format | ||
162 | ; | "binary" - transmission dump in binary format | ||
163 | ; ----------------|------------------------------------------------------------ | ||
164 | ; Features | Custom features for phone. This can be used as override | ||
165 | ; | when values coded in common/gsmphones.c are bad or | ||
166 | ; | missing. Consult include/gammu-info.h for possible values | ||
167 | ; | (all Feature values without leading F_ prefix). | ||
168 | ; | Please report correct values to Gammu authors. | ||
169 | ; ----------------|------------------------------------------------------------ | ||
170 | ; Use_Locking | under Unix/Linux use "yes", if want to lock used device | ||
171 | ; | to prevent using it by other applications. In win32 ignored | ||
172 | |||
173 | ; vim: et ts=4 sw=4 sts=4 tw=78 spell spelllang=en_us | ||
diff --git a/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb b/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb new file mode 100644 index 000000000..3a2da3edc --- /dev/null +++ b/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb | |||
@@ -0,0 +1,55 @@ | |||
1 | DESCRIPTION = "GNU All Mobile Managment Utilities" | ||
2 | SECTION = "console/network" | ||
3 | DEPENDS = "cmake-native virtual/libiconv libdbi mysql5" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=a17cb0a873d252440acfdf9b3d0e7fbf" | ||
6 | HOMEPAGE = "http://www.gammu.org/" | ||
7 | |||
8 | SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}/${PV}/${PN}-${PV}.tar.bz2 \ | ||
9 | file://gammurc \ | ||
10 | file://gammu-smsdrc \ | ||
11 | " | ||
12 | |||
13 | SRC_URI[md5sum] = "8ea16c6b3cc48097a8e62311fe0e25b9" | ||
14 | SRC_URI[sha256sum] = "de67caa102aa4c8fbed5300e5a0262e40411c4cc79f4379a8d34eed797968fc3" | ||
15 | |||
16 | inherit distutils cmake gettext | ||
17 | |||
18 | do_install_append() { | ||
19 | # these files seem to only be used by symbian and trigger QA warnings | ||
20 | rm -rf ${D}/usr/share/gammu | ||
21 | #install default configuration files | ||
22 | install -d ${D}${sysconfdir} | ||
23 | install -m 0644 ${WORKDIR}/gammurc ${D}${sysconfdir}/gammurc | ||
24 | install -m 0644 ${WORKDIR}/gammu-smsdrc ${D}${sysconfdir}/gammu-smsdrc | ||
25 | } | ||
26 | |||
27 | EXTRA_OECONF = " \ | ||
28 | --enable-shared \ | ||
29 | --enable-backup \ | ||
30 | --enable-protection \ | ||
31 | " | ||
32 | |||
33 | EXTRA_OECMAKE = " \ | ||
34 | -DWITH_CURL=OFF \ | ||
35 | -DWITH_BLUETOOTH=OFF \ | ||
36 | -DWITH_NOKIA_SUPPORT=OFF \ | ||
37 | -DWITH_IRDA=OFF \ | ||
38 | -DWITH_PYTHON=OFF \ | ||
39 | -DWITH_MySQL=ON \ | ||
40 | -DWITH_Postgres=OFF \ | ||
41 | " | ||
42 | |||
43 | PACKAGES =+ "${PN}-smsd libgammu libgsmsd python-${PN}" | ||
44 | |||
45 | FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker ${sysconfdir}/bash_completion.d/gammu \ | ||
46 | ${bindir}/gammu-detect ${sysconfdir}/gammurc" | ||
47 | CONFFILES_${PN} = "${sysconfdir}/gammurc" | ||
48 | FILES_${PN}-smsd = "${bindir}/gammu-smsd* ${sysconfdir}/gammu-smsdrc" | ||
49 | CONFFILES_${PN}-smsd = "${sysconfdir}/gammu-smsdrc" | ||
50 | FILES_${PN}-dev += "${bindir}/gammu-config ${libdir}/*.so" | ||
51 | FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/.debug ${PYTHON_SITEPACKAGES_DIR}/gammu/.debug" | ||
52 | FILES_libgammu = "${libdir}/libGammu.so.*" | ||
53 | FILES_libgsmsd = "${libdir}/libgsmsd.so.*" | ||
54 | FILES_python-${PN} = "${PYTHON_SITEPACKAGES_DIR}/gammu/*.??" | ||
55 | |||