diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 14:42:28 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:22:04 +0200 |
commit | fd84ec341f3224e1f79f185588f2cd844f464f86 (patch) | |
tree | 3e9f708a4f3554c2ef4c636ab199aa295a237dc7 /meta-oe/recipes-connectivity | |
parent | f2b3287cc162169028ad59e9fc5ebde8e03cbb04 (diff) | |
download | meta-openembedded-fd84ec341f3224e1f79f185588f2cd844f464f86.tar.gz |
cherokee: move systemd support from meta-systemd back to meta-oe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r-- | meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service | 10 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb | 16 |
2 files changed, 23 insertions, 3 deletions
diff --git a/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service b/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service new file mode 100644 index 000000000..a2d703185 --- /dev/null +++ b/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service | |||
@@ -0,0 +1,10 @@ | |||
1 | [Unit] | ||
2 | Description=Cherokee web server | ||
3 | After=syslog.target | ||
4 | |||
5 | [Service] | ||
6 | Type=forking | ||
7 | ExecStart=/usr/sbin/cherokee -d -C /etc/cherokee/cherokee.conf | ||
8 | |||
9 | [Install] | ||
10 | WantedBy=multi-user.target | ||
diff --git a/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb b/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb index 84d6dce32..422ebdab4 100644 --- a/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb +++ b/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb | |||
@@ -5,16 +5,18 @@ SECTION = "network" | |||
5 | LICENSE = "GPLv2" | 5 | LICENSE = "GPLv2" |
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
7 | 7 | ||
8 | PR = "r6" | 8 | PR = "r9" |
9 | 9 | ||
10 | DEPENDS = "libpcre openssl mysql5 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" | 10 | DEPENDS = "libpcre openssl mysql5 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
11 | 11 | ||
12 | SRC_URI = "http://www.cherokee-project.com/download/1.2/${PV}/cherokee-${PV}.tar.gz \ | 12 | SRC_URI = "http://www.cherokee-project.com/download/1.2/${PV}/cherokee-${PV}.tar.gz \ |
13 | file://cherokee.init" | 13 | file://cherokee.init \ |
14 | file://cherokee.service \ | ||
15 | " | ||
14 | SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb" | 16 | SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb" |
15 | SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d" | 17 | SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d" |
16 | 18 | ||
17 | inherit autotools pkgconfig binconfig update-rc.d | 19 | inherit autotools pkgconfig binconfig update-rc.d systemd |
18 | 20 | ||
19 | EXTRA_OECONF = "--disable-static \ | 21 | EXTRA_OECONF = "--disable-static \ |
20 | --disable-nls \ | 22 | --disable-nls \ |
@@ -27,6 +29,9 @@ do_install_append () { | |||
27 | 29 | ||
28 | # clean up .la files for plugins | 30 | # clean up .la files for plugins |
29 | rm -f ${D}${libdir}/cherokee/*.la | 31 | rm -f ${D}${libdir}/cherokee/*.la |
32 | |||
33 | install -d ${D}${systemd_unitdir}/system | ||
34 | install -m 0644 ${WORKDIR}/cherokee.service ${D}${systemd_unitdir}/system | ||
30 | } | 35 | } |
31 | 36 | ||
32 | # Put -dev near the front so we can move the .la files into it with a wildcard | 37 | # Put -dev near the front so we can move the .la files into it with a wildcard |
@@ -44,3 +49,8 @@ CONFFILES_${PN} = " \ | |||
44 | 49 | ||
45 | INITSCRIPT_NAME = "cherokee" | 50 | INITSCRIPT_NAME = "cherokee" |
46 | INITSCRIPT_PARAMS = "defaults 91 91" | 51 | INITSCRIPT_PARAMS = "defaults 91 91" |
52 | |||
53 | RPROVIDES_${PN} += "${PN}-systemd" | ||
54 | RREPLACES_${PN} += "${PN}-systemd" | ||
55 | RCONFLICTS_${PN} += "${PN}-systemd" | ||
56 | SYSTEMD_SERVICE_${PN} = "cherokee.service" | ||